X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

character encoding for file:// URLs

Posted

When I open a file whose character encoding is UTF-8 in Firefox via a file:// URL, it displays all the non-ASCII characters incorrectly. In the View->Chacter Encoding sub-menu, I see the check mark near "Western". When I choose "Unicode" manually from the View->Character Encoding menu, the file displays correctly. But when I then hit <f5> to reload the page, Firefox sets character encoding to "Western" again, the display is garbled again, and to display the file correctly I have to set the right character encoding manually once more.

Since I need that functionality frequently, this is a real nuisance which debases the user experience a lot for me.

Similar questions have been asked on the Internet, but no one seems to have got a satisfactory answer.

Thus, my question is: What should I do to have Firefox display file:// URLs in UTF-8 by default, or at least to have it remember the "Character Encoding" setting over page reloads?

As my system is UTF-8 only, I would much prefer the first.

(Maintaining separate encodings for different languages instead of using Unicode everywhere should IMO be considered a 20th-century anachronism that certainly has to be supported, probably still for a long time to come, but that should not be forced on users as the default.)

Just in case: yes, I know about BOM, but my question is not about changing my files so that Firefox displays them correctly without changing its behavior, but about changing its behavior so that it displays my files correctly without me having to change them.

Regards, T.

When I open a file whose character encoding is UTF-8 in Firefox via a file:// URL, it displays all the non-ASCII characters incorrectly. In the View->Chacter Encoding sub-menu, I see the check mark near "Western". When I choose "Unicode" manually from the View->Character Encoding menu, the file displays correctly. But when I then hit <f5> to reload the page, Firefox sets character encoding to "Western" again, the display is garbled again, and to display the file correctly I have to set the right character encoding manually once more. Since I need that functionality frequently, this is a real nuisance which debases the user experience a lot for me. Similar questions have been asked on the Internet, but no one seems to have got a satisfactory answer. Thus, my question is: What should I do to have Firefox display file:// URLs in UTF-8 by default, or at least to have it remember the "Character Encoding" setting over page reloads? As my system is UTF-8 only, I would much prefer the first. (Maintaining separate encodings for different languages instead of using Unicode everywhere should IMO be considered a 20th-century anachronism that certainly has to be supported, probably still for a long time to come, but that should not be forced on users as the default.) Just in case: yes, I know about BOM, but my question is not about changing my files so that Firefox displays them correctly without changing its behavior, but about changing its behavior so that it displays my files correctly without me having to change them. Regards, T.

Modified by toomas

Additional System Details

Installed Plug-ins

  • Allows digital signing with Estonian, Finnish, Latvian and Lithuanian ID cards
  • Shockwave Flash 24.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

Question owner

Answering my own question:

I accidentally stumbled upon a sort-of “solution”: when I choose "Japanese" (but not when I choose "Russian" or "Ukrainian") from View→Character Encoding→Auto-Detect, my file (which is in Estonian) displays correctly even when opening it for the first time. IOW, if the "Japanese" entry is already chosen when I open the file, I don't have to set the encoding manually at all.

Answering my own question: I accidentally stumbled upon a sort-of “solution”: when I choose "Japanese" (but not when I choose "Russian" or "Ukrainian") from View→Character Encoding→Auto-Detect, my file (which is in Estonian) displays correctly even when opening it for the first time. IOW, if the "Japanese" entry is already chosen when I open the file, I don't have to set the encoding manually at all.

Modified by toomas