Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is not connecting to the internet and there are no error messages. Google chrome is able to connect to the internet.

  • 3 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

I'm using an HP Spectre pc with windows 10 which was the original os. My computer was stuck so I shut it down and restarted it. I saw that the computer was updating and when it was finished I logged in to the os and and opened firefox. The homepage came up and I tried to go to a website and nothing happens. I get a white screen with no error message. I've been through the solutions on the help page and nothing is working. I am using Norton firewall and firefox is allowed. Please help. Thank you.

All Replies (3)

more options

What's your computer system and Firefox version?

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Hi FredMcD,

Thank you for your response. My computer system is the latest version of Windows 10 and Firefox version 49.0.2

I'm running Norton 360, which is up to date as my security system and I didn't see anything in the post on how to configure the their firewall to allow Firefox to access the internet.

more options

Norton 360: Open the 360 program by clicking its icon near the clock. Once open, mouse to the top right and click Settings.

In the new window, on the left, press Firewall. On the new page, select Program Control. There is a search box on the right. Remove any Firefox and Mozilla entries.