X
Tap here to go to the mobile version of the site.

Support Forum

Flash Block Addon Works but Sites Play Audio

Posted

Somehow websites have figured out how to play audio even when the Flash object is blocked. This did not used to be the case and I only recently noticed they can sneak the audio through.

I have looked around other help sites but found no solution. I have a link of an example, below. Note: this link has audio that is particularly annoying and vacuous.

http://tvlistings.aol.com/listings/ga/columbus/over-the-air/31902

Somehow websites have figured out how to play audio even when the Flash object is blocked. This did not used to be the case and I only recently noticed they can sneak the audio through. I have looked around other help sites but found no solution. I have a link of an example, below. Note: this link has audio that is particularly annoying and vacuous. http://tvlistings.aol.com/listings/ga/columbus/over-the-air/31902

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.101.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 23.0 r0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

Helpful Reply

Anyone ?

Anyone ?
jscher2000
  • Top 10 Contributor
8580 solutions 70173 answers

Helpful Reply

Hi Chrislongski, my guess would be they are not using Flash.

Firefox has built-in HTML5 audio and video players. To see what audio formats Firefox can play, you can experiment with the following test page:

http://hpr.dogphilosophy.net/test/

Now... how can you stop autoplay of HTML5 audio? Maybe this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autop and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch the value from true to false

With that setting, you're likely to encounter something odd on video sites that autostart their videos (like YouTube): the player has a pause button, has started buffering, but isn't playing. To start the player, click pause, then click play.

Unfortunately, I don't know of a way to block only some kinds of media autoplay without an add-on (which you could try searching for in case there's something new up there).

Hi Chrislongski, my guess would be they are not using Flash. Firefox has built-in HTML5 audio and video players. To see what audio formats Firefox can play, you can experiment with the following test page: http://hpr.dogphilosophy.net/test/ Now... how can you stop autoplay of HTML5 audio? Maybe this setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''autop''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch the value from true to false With that setting, you're likely to encounter something odd on video sites that autostart their videos (like YouTube): the player has a pause button, has started buffering, but isn't playing. To start the player, click pause, then click play. Unfortunately, I don't know of a way to block only some kinds of media autoplay without an add-on (which you could try searching for in case there's something new up there).
jscher2000
  • Top 10 Contributor
8580 solutions 70173 answers

By the way, since sites playing unwanted audio are not that common, I find it more convenient to mute their tabs by clicking the little speaker icon that appears on the tab up on the tab bar. That way, I can leave autoplay on so video players behave normally.

See: Mute sound in Firefox tabs

By the way, since sites playing unwanted audio are not that common, I find it more convenient to mute their tabs by clicking the little speaker icon that appears on the tab up on the tab bar. That way, I can leave autoplay on so video players behave normally. See: [[Mute sound in Firefox tabs]]