X
Tap here to go to the mobile version of the site.

Support Forum

Facebook fails to load if using br encoding

Posted

Yesterday I opened Facebook.com and saw this: "Þk¢¨hõpFrÒêÐ ×c÷¼ª~ß÷ÓTL²æŠÁ,ùZ> ”%YÉ –ík$AIШ`¯whªß¥Ð”û~SüzÿZ&¬­;…»TtzìVË!¨Øí–ÞKÿä}ió%Û9’=“#Û :Æ=Ç^xðõ%k4¸äqh`5B{ @Ø´‹?-`ÕÍÙÊešr“¢K›¢éRvñÿ[ë3²;7l4°ð 7PÈ5bσê3B¨ªîéôŸé‘]0*q‚ÈÇéüU?Âä1̬÷~‹HZÓÎD6sö¢ƒzª—Àfqhÿϯ5«f$&cùØ]Ûg1`@”@“Á 3(u~â0iøÒ‚zéŽÛïåÁϼï—ïðÖŸ~+kÞ:ï|“B‡†£Òâ8Ì*™^‘ÚgƆà*¬}Öüˈ+©…?¢·ò#z»þ2É«ù©qQ†ƒ˜’KíóáW?þð‹ãoõ v-± ·‹_oþÉ7Ñn›àj#ô ‡¸â'¼ (Ë؏¶a÷i_Œ'|³‹²– Á:ÌR™Â6Üt†G=|¸ƒuxøüqèËýßôo‘ÿ-5=Žª¿™Fœ MO¿h ..." and much more (copy-pasted this because for some reason I couldn't upload a screenshot).

After a bit of digging I found the suggestion to 'Reset' to the default values the network.http.accept-encoding and network.http.accept-encoding.secure settings. In my case they were already set to the default values, so I started messing with them and found this:

network.http.accept-encoding.secure - gzip, deflate, br means https://www.facebook.com is shown as in the example;

network.http.accept-encoding.secure - gzip, deflate means https://www.facebook.com is shown as it should be;

The same problem with the same solution happened on the other PC in my house.

My questions are: What could cause this behavior? What are the disadvantages of not having br as an option for encoding? Are there any security risks?

Yesterday I opened Facebook.com and saw this: "Þk¢¨hõpFrÒêÐ ×c÷¼ª~ß÷ÓTL²æŠÁ,ùZ> ”%YÉ –ík$AIШ`¯whªß¥Ð”û~SüzÿZ&¬­;…»TtzìVË!¨Øí–ÞKÿä}ió%Û9’=“#Û :Æ=Ç^xðõ%k4¸äqh`5B{ @Ø´‹?-`ÕÍÙÊešr“¢K›¢éRvñÿ[ë3²;7l4°ð 7PÈ5bσê3B¨ªîéôŸé‘]0*q‚ÈÇéüU?Âä1̬÷~‹HZÓÎD6sö¢ƒzª—Àfqhÿϯ5«f$&cùØ]Ûg1`@”@“Á 3(u~â0iøÒ‚zéŽÛïåÁϼï—ïðÖŸ~+kÞ:ï|“B‡†£Òâ8Ì*™^‘ÚgƆà*¬}Öüˈ+©…?¢·ò#z»þ2É«ù©qQ†ƒ˜’KíóáW?þð‹ãoõ v-± ·‹_oþÉ7Ñn›àj#ô ‡¸â'¼ (Ë؏¶a÷i_Œ'|³‹²– Á:ÌR™Â6Üt†G=|¸ƒuxøüqèËýßôo‘ÿ-5=Žª¿™Fœ MO¿h ..." and much more (copy-pasted this because for some reason I couldn't upload a screenshot). After a bit of digging I found the suggestion to 'Reset' to the default values the <strong>network.http.accept-encoding</strong> and <strong>network.http.accept-encoding.secure</strong> settings. In my case they were already set to the default values, so I started messing with them and found this: <strong>network.http.accept-encoding.secure</strong> - <strong>gzip, deflate, br</strong> means https://www.facebook.com is shown as in the example; <strong>network.http.accept-encoding.secure</strong> - <strong>gzip, deflate</strong> means https://www.facebook.com is shown as it should be; The same problem with the same solution happened on the other PC in my house. My questions are: What could cause this behavior? What are the disadvantages of not having br as an option for encoding? Are there any security risks?

Modified by blue_alien_bg

Chosen solution

Firefox 44+ accepts a new kind of encoding (compression) called Brotli (br) for secure connections and Facebook turned on Brotli encoding a couple days ago.

Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing

See also https://forum.kaspersky.com/index.php?showtopic=351027

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 21.0 r0

Application

  • Firefox 46.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
  • Support URL: https://support.mozilla.org/1/firefox/46.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello 1.2.6 (loop@mozilla.org)
  • Google Analytics Opt-out Browser Add-on 0.9.8 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • Pocket 1.0 (firefox@getpocket.com)
  • Speed Dial 0.9.6.18 ({64161300-e22b-11db-8314-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7700 Series
  • adapterDescription2:
  • adapterDeviceID: 0x683d
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.0
  • driverDate: 4-29-2016
  • driverDate2:
  • driverVersion: 16.150.2401.1002
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7700 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
James
  • Moderator
1594 solutions 11226 answers

Chosen Solution

Firefox 44+ accepts a new kind of encoding (compression) called Brotli (br) for secure connections and Facebook turned on Brotli encoding a couple days ago.

Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing

See also https://forum.kaspersky.com/index.php?showtopic=351027

Firefox 44+ accepts a new kind of encoding (compression) called Brotli (br) for secure connections and Facebook turned on Brotli encoding a couple days ago. Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing See also https://forum.kaspersky.com/index.php?showtopic=351027

Helpful Reply

James said

Firefox 44+ accepts a new kind of encoding (compression) called Brotli (br) for secure connections and Facebook turned on Brotli encoding a couple days ago. Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing See also https://forum.kaspersky.com/index.php?showtopic=351027

Yes, that definitely works. I told Kaspersky not to scan encrypted connections and reset the network.http.accept-encoding.secure to its default value and Facebook opens perfectly.

''James [[#answer-875911|said]]'' <blockquote> Firefox 44+ accepts a new kind of encoding (compression) called Brotli (br) for secure connections and Facebook turned on Brotli encoding a couple days ago. Kapsersky doesn't know about this encoding and strips it from the HTTP response headers if you have "Inject script" checked in Kapsersky Settings -> Additional -> Network -> Traffic Processing See also https://forum.kaspersky.com/index.php?showtopic=351027 </blockquote> Yes, that definitely works. I told Kaspersky not to scan encrypted connections and reset the <strong>network.http.accept-encoding.secure</strong> to its default value and Facebook opens perfectly.