X
Tap here to go to the mobile version of the site.

Support Forum

Since the last 2 Firefox updates my new computer seems to hang or crash a lot

Posted

Hi, I was just wondering if this was only happening to me or not. I always update when told by my plug-ins, or virus protection and when Firefox says there's a new update. I've now got the latest 43.0.2 and since this and one or 2 updates before my computer hangs or crashes, whatever you want to call it and I will sometimes get the icon telling me Firefox has crashed, report, etc. I wanted to know what is causing it. It's a brand new computer with all the updates, including Microsoft, etc. I never used to have this problem before with Firefox. I tried to read some others that posted similar things but I didn't understand anything that was told to them to do. I'm not techy. I just know enough to get around. I'm going to probably use Internet Explorer more until Firefox fixes or updates again. It's pretty frustrating when you're in the middle of something and this happens. Like I said I wondered if it was because of the last few updates Firefox did. I was always told you need to keep it updated but if it causes problems like this perhaps I shouldn't. Thanks from the clueless, Debbie

Hi, I was just wondering if this was only happening to me or not. I always update when told by my plug-ins, or virus protection and when Firefox says there's a new update. I've now got the latest 43.0.2 and since this and one or 2 updates before my computer hangs or crashes, whatever you want to call it and I will sometimes get the icon telling me Firefox has crashed, report, etc. I wanted to know what is causing it. It's a brand new computer with all the updates, including Microsoft, etc. I never used to have this problem before with Firefox. I tried to read some others that posted similar things but I didn't understand anything that was told to them to do. I'm not techy. I just know enough to get around. I'm going to probably use Internet Explorer more until Firefox fixes or updates again. It's pretty frustrating when you're in the middle of something and this happens. Like I said I wondered if it was because of the last few updates Firefox did. I was always told you need to keep it updated but if it causes problems like this perhaps I shouldn't. Thanks from the clueless, Debbie

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

Question owner

Hi again FredMcD! I just answered another response to this same problem and liked I told her it appears since the last Firefox update things have gone back to normal or at least I hope so. What you sent me I don't think I understand anyway. Sorry, I've said it before and will continue to sound like a parrot about it but I'm not techy and only know a certain amount but am copying what you've sent me as before. But I doubt any drivers need updating as I update all my important windows updates and my HP ones as well and it's a new computer from last summer. Thanks again!

Hi again FredMcD! I just answered another response to this same problem and liked I told her it appears since the last Firefox update things have gone back to normal or at least I hope so. What you sent me I don't think I understand anyway. Sorry, I've said it before and will continue to sound like a parrot about it but I'm not techy and only know a certain amount but am copying what you've sent me as before. But I doubt any drivers need updating as I update all my important windows updates and my HP ones as well and it's a new computer from last summer. Thanks again!
black_rose_hime 0 solutions 3 answers

Actually I've been doing some testing and it turns out to be Tumblr causing the freezing/crashing.

Actually I've been doing some testing and it turns out to be Tumblr causing the freezing/crashing.

Question owner

Well I don't do Tumblr so I know that wasn't behind mind. Still thinking it was one of Firefox's updates.

Well I don't do Tumblr so I know that wasn't behind mind. Still thinking it was one of Firefox's updates.
davewhitearcata 0 solutions 12 answers

I also am having this problem. I have shut off hardware acceleration, protection, updated ALL drivers, reflashed the BIOS, uninstalled and reinstalled both Shockwave Flash and Firefox, run virus and malware scans and the problem persists. This started after a Firefox update. There is some kind of conflict between Firefox, Shockwave Flash and Win 10. My Win 8.1 computer does not have this issue. Disabling Flash cures the issue as does staying off websites that use flash. However, I want a browser that I don't have to put up with this. Mozilla needs to resolve this problem.

I also am having this problem. I have shut off hardware acceleration, protection, updated ALL drivers, reflashed the BIOS, uninstalled and reinstalled both Shockwave Flash and Firefox, run virus and malware scans and the problem persists. This started after a Firefox update. There is some kind of conflict between Firefox, Shockwave Flash and Win 10. My Win 8.1 computer does not have this issue. Disabling Flash cures the issue as does staying off websites that use flash. However, I want a browser that I don't have to put up with this. Mozilla needs to resolve this problem.

Question owner

Well I didn't go through all of those except turned off acceleration. Since then there's been one or more firefox updates and (knock on wood) I haven't seen the issue occur again. But there's always next time an update happens. I know it's very frustrating and I agree with you about Mozilla needing to resolve their problems. It's nice (or not so nice depending on how you look at it) to hear others having similar problems and knowing it's just not me (which it feels like most of the time). Thanks davewhitearcata.

Well I didn't go through all of those except turned off acceleration. Since then there's been one or more firefox updates and (knock on wood) I haven't seen the issue occur again. But there's always next time an update happens. I know it's very frustrating and I agree with you about Mozilla needing to resolve their problems. It's nice (or not so nice depending on how you look at it) to hear others having similar problems and knowing it's just not me (which it feels like most of the time). Thanks davewhitearcata.
davewhitearcata 0 solutions 12 answers

By turning Shockwave Flash to the "Ask to Activate" setting I have a workaround although anytime I go to a site that needs Flash I have to turn it on. Hopefully a fix will be coming. Glad your problem seems to have resolved.

By turning Shockwave Flash to the "Ask to Activate" setting I have a workaround although anytime I go to a site that needs Flash I have to turn it on. Hopefully a fix will be coming. Glad your problem seems to have resolved.

Question owner

Hi davewhitearcata, Well so far so good but I hold my breath with every Firefox update. I think I told one of the other nice forum members on this that if it acts up again I'll just use IE. Whenever I used that I didn't see a problem happening which is why I guessed it was the FF update. I've got most of my add-ons set to always activate. But I found something weird once that after I picked that I couldn't change it. The ask to activate was no longer highlighted for me to pick even if I wanted to change an add-on back. Strange but for now not worrying about that. Thanks!

Hi davewhitearcata, Well so far so good but I hold my breath with every Firefox update. I think I told one of the other nice forum members on this that if it acts up again I'll just use IE. Whenever I used that I didn't see a problem happening which is why I guessed it was the FF update. I've got most of my add-ons set to always activate. But I found something weird once that after I picked that I couldn't change it. The ask to activate was no longer highlighted for me to pick even if I wanted to change an add-on back. Strange but for now not worrying about that. Thanks!