X
Tap here to go to the mobile version of the site.

Support Forum

How can i block a program from internet access?

Posted

I have a program that I do not want to have internet access. How do I let firefox block it?

I have a program that I do not want to have internet access. How do I let firefox block it?

Chosen solution

Firefox has nothing to do with that. Your firewall is what you need to set up.


Configure firewalls so that Firefox can access the Internet. {web link}

Open your firewall settings, and for that program, block it.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 227f103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 7-17-2015
  • driverDate2:
  • driverVersion: 10.18.15.4256
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4247 solutions 59409 answers

Chosen Solution

Firefox has nothing to do with that. Your firewall is what you need to set up.


Configure firewalls so that Firefox can access the Internet. {web link}

Open your firewall settings, and for that program, block it.

Firefox has nothing to do with that. Your '''firewall''' is what you need to set up. '''[https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet Configure firewalls so that Firefox can access the Internet.]''' {web link} Open your firewall settings, and for that program, '''block''' it.