Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

fan runs high watching youtube,macbook pro retina 15" mid 2015 after updating second to last Firefox update. Safari doesn't have this issue. Pls help.

  • 11 replies
  • 3 have this problem
  • 69 views
  • Last reply by FredMcD

more options

Fan runs high & hot watching youtube videos. Have new macbook pro retina 15" mid 2015. 2.5 GHz intel core i7. Started happening after second to last Firefox update. Updated to most current thinking it would be fixed. It doesn't happen if I use Safari. Apple support senior lead tried to resolve issues. Sorry, I'm not very technical. Tried shift, control,option start. Tried option, command,R,P start. Tried logging on as a new user. Tried so many options, I can't remember them all. Uninstalled, reinstalled,and uninstalled again. ran disk repair(?). Followed Firefox troubleshoot all the way to the end. Started in Safe Mode...everything. She told me to contact Mozilla to see if you had any answers to my issues. I also had issues last week with Firefox crashing 3-4 times in a row while watching youtube. I sent reports to Firefox. I hope someone can help me. I prefer Firefox to Safari! Thank you!

All Replies (11)

more options

What Firefox are you using?

Use this link to check that your plugins are up-to-date. If any are listed as unknown or research, do not worry about them.


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

more options

Firefox 40.0.3 on MacbookPro Retina 15" mid 2015 OS V 10.10.5 Plugins all up to date: OpenH264 Video Codec, notes always activate Shockwave Flash v18.0.0.232, notes always activate Default Browser Helper, notes ask to activate QuickTime Plug-in 7.7.3. notes ask to activate hardware acceleration in Firefox pref advance general (unchecked) Not sure how to disable hardware acceleration for Flash plugin. will try Problem still persist. %CPU on activity monitor runs high. Thanks FredMcD for trying to help me!!

more options

bit72 said

Not sure how to disable hardware acceleration for Flash plugin

Follow the instructions in the link.

more options

Doesn't help. Thank you for trying. Firefox also keeps crashing while viewing certain website (ie Nordstrom). I've sent crash reports to Mozilla each time (sometimes 4 in a row). Other times I have no problems viewing the same site. I think I will start using Safari. Thank you so much for your help.

more options

For us to check those reports, we need to see them.

Some of your crash reports weren’t sent to the Mozilla Servers.

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP in front of the numbers/letters, click it and select Submit.

Using your mouse, mark the most resent 7 - 10 crash reports, and copy them. Now go to the reply box below and paste them in.

aboutcrashesFx29
more options

Here they are: bp-93dc3576-802c-4a84-a558-fc05e2150916 9/16/15 9:09 AM bp-f8eed4c8-abc2-4eb6-88f6-dd1982150915 9/14/15 6:51 PM bp-e6ce2a6d-828e-46e5-aa7a-d91032150915 9/14/15 6:49 PM bp-9edb5974-ebdc-4ae3-8e6a-53d3f2150915 9/14/15 6:46 PM bp-29b3b07c-0d69-47e9-ba13-dacb52150914 9/13/15 6:00 PM bp-51d1e6ab-ceba-4514-ae2f-35bcc2150909 9/9/15 2:53 PM bp-3d897c95-fbf7-40a9-82cc-0dde92150909 9/9/15 2:51 PM bp-5ed7fd00-832e-4c19-b9c6-932252150918 9/9/15 2:49 PM bp-7121d0be-6467-45cb-add5-cf9882150909 9/9/15 2:49 PM bp-02af0f3c-8583-4548-ac89-4263b2150909

fyi: changed default to Safari & the 1st thing that comes up is a scam virus alert that I could not get rid of. Had to shut computer down. Changed back to Firefox :)

more options

bit72 said

the 1st thing that comes up is a scam virus alert that I could not get rid of. Had to shut computer down.

. Whenever you get a message / popup like that;

DO NOT USE ANY OF THE PROVIDED LINKS OR ANY PHONE NUMBERS ! !

Such messages are only Spam that could lead you to Fake Support. Not only can they damage or hack your system, they charge you to do so.

You can report such a site at; Google Report Phishing Page {web link} which is the same when done while on site by going to Help > Report Web Forgery

Help us safeguard Mozilla’s trademarks by reporting misuse {web link}


This add-on can stop such pages; disallow Script Button {web link} The Disallow Script button looks like a letter "M" and the title is the Minus Script, drag and drop the button on a toolbar. If the button is not displayed then nothing operates, except rules for plugins.

more options

Product Firefox Version 40.0.3

Release Channel release OS Mac OS X OS Version 10.10.5 14F27

The crash report flagged these programs;

AppleIntelHD5000GraphicsGLDriver

libsystem_pthread.dylib =  ? Word for Mac

libsystem_c.dylib = ? Word for Mac

libsystem_kernel.dylib =  ? Word for Mac

libGL.dylib = unknown

libGPUSupportMercury.dylib

This is for Sumo's Related Bugs

1198594 RESOLVED FIXED crash in libsystem_kernel.dylib@0x16286 1176404 NEW --- Crashes at __pthread_kill | ... gpusGenerateCrashLog ... | gpusSubmitDataBuffers, mostly on OS X 10.10 and 10.11 1176316 RESOLVED DUPLICATE crash in libsystem_kernel.dylib@0x16286

  • on another report

1187466 NEW --- [Windows] crash in mozilla::layers::BasicCompositor::DrawQuad(mozilla::gfx::RectTyped<T> const&, mozilla::gfx::RectTyped<T> const&, mozilla::layers::EffectChain const&, float, mozilla::gfx::Matrix4x4 const&) 1187464 NEW --- [Mac OS X] crash in mozilla::layers::BasicCompositor::DrawQuad(mozilla::gfx::RectTyped<T> const&, mozilla::gfx::RectTyped<T> const&, mozilla::layers::EffectChain const&, float, mozilla::gfx::Matrix4x4 const&)


For some time now, a lot of Mac’s with Microsoft programs have been crashing. Check with Microsoft / Mac support sites.


I've called the big guys to help you. Good luck.

more options

Try to set media.apple.mp4.enabled to false on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

more options

Hi Cor-el,

Thank you for trying to help. I'm a computer illiterate so I'm afraid to go on beyond "I'll be careful". I will ask someone to help me do what you suggest and get back with you.

Thank you! bit72

more options

If you follow cor-el's instructions, you will be fine.