X
Tap here to go to the mobile version of the site.

Support Forum

I've FF 38.0.5 installed on Win 8.1 x64 BUT javascript:void(0); links/buttons don't work/respond

Posted

I tried to Refresh Firefox (NoScript & Add-Block Plus were removed as well)

Java(TM) Platform SE 8 U45 & Java Deployment Toolkit 8.0.450.15 in add-ons is set to: Ask to Active

"javascript.enabled" Value in about:config is set to TRUE and I toggled it to false and then true again, and no changes..

everything is fine on IE But not @ FF or Chrome as well !!

In Java control panel (desktop application): Java content in the browser is Enabled

Windows Defender is on.

I tried to Refresh Firefox (NoScript & Add-Block Plus were removed as well) Java(TM) Platform SE 8 U45 & Java Deployment Toolkit 8.0.450.15 in add-ons is set to: Ask to Active "javascript.enabled" Value in about:config is set to TRUE and I toggled it to false and then true again, and no changes.. everything is fine on IE But not @ FF or Chrome as well !! In Java control panel (desktop application): Java content in the browser is Enabled Windows Defender is on.

Modified by QahmedX

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.7.20033
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.45.2 for Mozilla browsers
  • Nokia Suite Enabler Plugin
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.8.158
  • 5.1.40416.0

Application

  • Firefox 38.0.5
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.5/WINNT/en-US/

Extensions

  • IDM CC 7.3.100 (mozilla_cc@internetdownloadmanager.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce 840M
  • adapterDeviceID: 0x0a16
  • adapterDeviceID2: 0x1341
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterSubsysID: 16ad1043
  • adapterSubsysID2: 16ad1043
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 3-7-2014
  • driverDate2: 5-27-2015
  • driverVersion: 10.18.10.3496
  • driverVersion2: 9.18.13.5306
  • info: {u'AzureContentBackend': u'direct2d 1.1', u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
the-edmeister
  • Top 25 Contributor
  • Moderator
5399 solutions 40158 answers
To avoid confusion: http://kb.mozillazine.org/JavaScript_is_not_Java http://kb.mozillazine.org/Java http://kb.mozillazine.org/JavaScript

Question owner

^ Thanks.

I've found javascript.enabled Value in about:config is set to TRUE and toggled it to false and then true again, and no changes..

Lately i tried to clear History; cookies, cache,.. etc AND now javascript:{} is working on all browsers including FF :) BUT javascript:void(0); isn't fine neither on FF nor chrome, AND working fine in IE.

I hit inspect element and got its code: <a href="javascript:void(0);" class="" data-sort="cp_desc">Price: High to Low</a>

^ Thanks. I've found javascript.enabled Value in about:config is set to TRUE and toggled it to false and then true again, and no changes.. Lately i tried to clear History; cookies, cache,.. etc AND now javascript:{} is working on all browsers including FF :) BUT javascript:void(0); isn't fine neither on FF nor chrome, AND working fine in IE. I hit inspect element and got its code: <a href="javascript:void(0);" class="" data-sort="cp_desc">Price: High to Low</a>

Modified by QahmedX

Question owner

The problem happens in Safe Mode as well

The problem happens in Safe Mode as well
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157955 answers

Helpful Reply

There should be an 'ev' appended at the end of the link like you can see further up in the screenshot to indicate that some JavaScript would run when you click the link.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
There should be an 'ev' appended at the end of the link like you can see further up in the screenshot to indicate that some JavaScript would run when you click the link. ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *Hold down the Shift key and left-click the Reload button *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *Press "Command + Shift + R" (Mac) Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies" Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

A strange thing happen here..

I did everything you said, and finally it worked, BUT as explained below:

first i open the page and hit "=Best Match" and it work, but when i select Price: High to Low, nothing happen UNTIL i hit "Ctrl + F5", then it work fine.. And if i closed the browser and opened it again, it doesn't work again until i hit "Ctrl+F5" again!! as if the previous action in the previous session was not saved??!

I attached 2 imgs showing the "ev" before and after hitting "Ctrl+F5"

A strange thing happen here.. I did everything you said, and finally it worked, BUT as explained below: first i open the page and hit "=Best Match" and it work, but when i select Price: High to Low, nothing happen UNTIL i hit "Ctrl + F5", then it work fine.. And if i closed the browser and opened it again, it doesn't work again until i hit "Ctrl+F5" again!! as if the previous action in the previous session was not saved??! I attached 2 imgs showing the "ev" before and after hitting "Ctrl+F5"

Question owner

any solution for that? specially after updating to v39.0 and nothing new..

QahmedX said

A strange thing happen here.. I did everything you said, and finally it worked, BUT as explained below: first i open the page and hit "=Best Match" and it work, but when i select Price: High to Low, nothing happen UNTIL i hit "Ctrl + F5", then it work fine.. And if i closed the browser and opened it again, it doesn't work again until i hit "Ctrl+F5" again!! as if the previous action in the previous session was not saved??! I attached 2 imgs showing the "ev" before and after hitting "Ctrl+F5"
any solution for that? specially after updating to v39.0 and nothing new.. ''QahmedX [[#answer-745724|said]]'' <blockquote> A strange thing happen here.. I did everything you said, and finally it worked, BUT as explained below: first i open the page and hit "=Best Match" and it work, but when i select Price: High to Low, nothing happen UNTIL i hit "Ctrl + F5", then it work fine.. And if i closed the browser and opened it again, it doesn't work again until i hit "Ctrl+F5" again!! as if the previous action in the previous session was not saved??! I attached 2 imgs showing the "ev" before and after hitting "Ctrl+F5" </blockquote>
nightsmusic 0 solutions 16 answers

I'm having the same problem, only on Firefox and only since this last update to ver. 39. Nothing I've tried has helped and frankly, it's making me frustrated enough to just change browsers which I do NOT want to do!

I'm having the same problem, only on Firefox and only since this last update to ver. 39. Nothing I've tried has helped and frankly, it's making me frustrated enough to just change browsers which I do NOT want to do!