Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why I can't go to my gmail account.What is the problem?

  • 10 replies
  • 10 have this problem
  • 6 views
  • Last reply by Ovi

more options

Secure Connection Failed

An error occurred during a connection to accounts.google.com. Cannot communicate securely with peer: no common encryption algorithm(s). (Error code: ssl_error_no_cypher_overlap)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

What is the problem?

All Replies (10)

more options

Hi Ovi, Sorry you are having problems.

I am able to sign in to gmail from Firefox 38 so it is probably not due to the Firefox upgrade.

  1. Try using Firefox in its safemode.
  2. Have you any Security related software that could be interfering ?
    1. Please list security related software you use.
    2. Try disabling, or even temporarily removing that.
      Please say what you tried.

Your system details aside indicate you have a file user.js if you did not create that yourself, or know what did create it that could be an indication of the presence of malware .

If you did not create the file please paste its contents into your next reply. It is then probably worth using multiple tools to check for malware.


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one. Windows 8 has antivirus built-in already.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

Still the same problem.I followed ur method.I am sure about that My pc has no Malware

more options

Is Gmail the only site where you've seen a secure certificate error or have you seen it on other sites, too?

Do you use any products or services that modify your web connections? Those would include security software suites that filter your browsing session, proxy servers that control access to sites, and anonymizing services (TOR, private VPN) that connect through remote computers.

Have you disabled any ciphers in Firefox's settings? You can check that here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste ssl3 and pause while the list is filtered

This should list numerous entries starting with security.ssl3. which identify different encryption ciphers. By default, all are set to true. When I connect to the login page, Firefox and Google use the cipher associated with this preference:

security.ssl3.ecdhe_rsa_aes_128_gcm_sha256

(3) If necessary, you can toggle disabled ciphers from false to true by double-clicking them or using right-click > Reset. If you are trying to avoid using RC4 ciphers, you can keep those disabled (look for the preference names containing rc4 or edit the filter to ssl3.*rc4).

more options

Gmail is only one.other is seems good.I don't use vpn

more options

I wasn't able to open the screen shot. Is the description of the error the same -- Error code: ssl_error_no_cypher_overlap ?

And you checked that no ciphers are disabled?

more options

jscher2000 said

I wasn't able to open the screen shot. Is the description of the error the same -- Error code: ssl_error_no_cypher_overlap ? And you checked that no ciphers are disabled?
more options

Screenshot of the problem

more options

Could you try disabling IPv6:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste dns and pause while the list is filtered

(3) Double-click the network.dns.disableIPv6 preference to switch it from true to false

Then reload the login page bypassing the cache using Ctrl+Shift+r (or Shift-click the reload button in the address bar).

Any difference?

more options

My IPV6 is disabled.

more options

The problem was solved after I re-install Firefox