Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is blocking data on a website I use all the time

more options

Hi

I am often needing to use different public wifi's - so maybe this is why it is happening.

or maybe something else has happened as I installed a new add-on TabMix Plus..

or maybe I muffed something else up...I do not know.

But as of today, Firefox keeps blocking content on sites I visit all the time. I have cookies allowed.

So I click in the URL bar, and say allow. But each page, this is happening. Rather tedious.

How can I remind firefox, that this site is OK. I love its content, please allow it always. How can I say this automatically without having to click the icon in URL each time.

please see screenshot of icon I am receiving. The symbol gets a little red line thru it once I have clicked "allowed" thankyou

Attached screenshots

Modified by helpresearch

All Replies (6)

more options

What does it say in the URL bar that you need to allow? A screenshot would be nice. Where does the "shield" appear? On a toolbar?

Please provide a listing of your installed extensions. There are a couple of extensions that use the type of "shield" icon for the toolbar button.

more options

With the newest Firefox, some Security Certificates have been disabled because of issues with new mal-ware. Can you check with the site on what Security Certificates they are using? (SSL and TSL encryption protocols)

more options

The shield icon should not appear on "well run" sites designed to be accessed over a secure (HTTPS) connection. However, many sites were never designed for HTTPS and work better with HTTP (in which case, Firefox doesn't care whether the content in the page is secure or not). Do you know whether this particular problem site is designed for use over HTTPS?

more options

Thankyou for all your wonderful help. jscher2000 - I do not know. I can ask (designed for use over HTTPS) FredMcD - I can check and ask (Can you check with the site on what Security Certificates they are using? (SSL and TSL encryption protocols))

There is no other question posted, so I am thinking it is me and lots of people would report very quickly. More quickly than me. But I will ask as you have suggested it.

What I did think is very odd, I upgraded to v38 earlier this week. All week I have been on public wifi and this message only started yesterday. Last night when I was home and using mobile broadband, no message. Each time I move to new public wifi or come home to mobile broadband, I am rebooting my macbook.

So it makes me thing, its me and not the site. (I only received it on 1 site, it is my favorite community (books))

more options

I re-iterate, to make sure I am not confusing.

this screenshot I provided is from URL bar. I click in the URL bar, and say allow, then the page displays normally.

It is at this point, in the pop-up, Firefox is telling me it is disallowing content. And it offers a Learn link. So I clicked that and it took me to this page https://support.mozilla.org/en-US/kb/how-does-content-isnt-secure-affect-my-safety?as=u&utm_source=inproduct

And that made no sense to me, as I always use this site, I had not received the message yesterday. Only think I could think of that I had done differently from yesterday to today was install add-on TabMix Plus. And that has to do with tabs, not security. So I am confused as to what caused it to suddenly appear.

Only thing I could think of, maybe the site rolled out some tweaks and that is why I saw it and then didnt see by the time I got home. I have no idea.

more options

Thus why I use

Virus Total Scan Url :: Add-ons for Firefox https://addons.mozilla.org/en-US/fire.../?src=search

Program exes and url links they can scan before you load them and they show you what is on site giving warning.