X
Tap here to go to the mobile version of the site.

Support Forum

From either Google Inbox or Gmail on Mac OSX using command-click to open a link in new tab incorrectly brings that new tab to front.

Posted

Same action on any other site works fine and opens new page in a new tab without bringing it to the front. Looking for if there's a setting that needs to be adjusted, or if this is something weird with how Google Inbox and Gmail work. Would love to get this sorted. Thanks!

Same action on any other site works fine and opens new page in a new tab without bringing it to the front. Looking for if there's a setting that needs to be adjusted, or if this is something weird with how Google Inbox and Gmail work. Would love to get this sorted. Thanks!

Chosen solution

I think the other, similarly named, preferences address most other situations:

  • browser.tabs.loadInBackground => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = true, do not make the new tab active
    • In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting.
  • browser.tabs.loadDivertedInBackground => when you divert a script-generated new window to a new tab using Ctrl+click
    • default = false, make the new tab active
  • browser.tabs.loadBookmarksInBackground => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = false, make the new tab active
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 15.007.20033
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Provides information about the default web browser
  • Version 5.41.0.0
  • 15.8.0.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0

Application

  • Firefox 37.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
  • Support URL: https://support.mozilla.org/1/firefox/37.0.2/Darwin/en-US/

Extensions

  • AdBlock for YouTube™ 0.1.0 (jid1-q4sG8pYhq8KGHs@jetpack)
  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Buffer 2.11.2 (jid1-zUyU7TGKwejAyA@jetpack)
  • Reddit Enhancement Suite 4.5.4 (jid1-xUfzOsOFlzSOXg@jetpack)
  • 1-Click YouTube Video Downloader 2.4.0 (YoutubeDownloader@PeterOlayev.com) (Inactive)
  • AdBlock Lite 0.2.3 (jid1-dwtFBkQjb3SIQp@jetpack) (Inactive)
  • Firebug 2.0.9 (firebug@software.joehewitt.com) (Inactive)
  • OneTab 1.9 (extension@one-tab.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x a26
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 5000 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Helpful Reply

If you mean the Gmail message list, those are not normal links. When you click one of those rows, a script runs that normally opens the message into the same tab. Holding Command (or on Windows Ctrl) while clicking diverts the content to a new tab, but the script seems to override the normal "open link in a background tab" behavior.

Is there a workaround... hmm... yes, I think so! Give this a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste tabs and pause while the list is filtered

(3) Double-click the browser.tabs.loadDivertedInBackground preference to switch it from the default value of false to true -- the line should turn bold

Then in your Gmail tab, try again. Success?

I wasn't able to test on the newer Inbox layout.

If you mean the Gmail message list, those are not normal links. When you click one of those rows, a script runs that normally opens the message into the same tab. Holding Command (or on Windows Ctrl) while clicking diverts the content to a new tab, but the script seems to override the normal "open link in a background tab" behavior. Is there a workaround... hmm... yes, I think so! Give this a try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''tabs''' and pause while the list is filtered (3) Double-click the '''browser.tabs.loadDivertedInBackground''' preference to switch it from the default value of false to true -- the line should turn bold Then in your Gmail tab, try again. Success? I wasn't able to test on the newer Inbox layout.
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Helpful Reply

I just noticed something really interesting. When I logged out of Gmail, I got a message asking whether I wanted to leave the page and I said yes. Instantly, all of the messages I had opened in new tabs using Ctrl+click closed. How do they do that?

I just noticed something really interesting. When I logged out of Gmail, I got a message asking whether I wanted to leave the page and I said yes. Instantly, all of the messages I had opened in new tabs using Ctrl+click closed. ''How do they do that?''

Question owner

Thanks! Can you think of other situations where this config change would affect how it works? I.e. will the change in browser.tabs.loadDivertedInBackground only affect this specific situation, or will it cause all link clicks to open in the background whether they're from Inbox/Gmail or otherwise?

Thanks! Can you think of other situations where this config change would affect how it works? I.e. will the change in '''browser.tabs.loadDivertedInBackground''' only affect this specific situation, or will it cause all link clicks to open in the background whether they're from Inbox/Gmail or otherwise?
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Chosen Solution

I think the other, similarly named, preferences address most other situations:

  • browser.tabs.loadInBackground => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = true, do not make the new tab active
    • In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting.
  • browser.tabs.loadDivertedInBackground => when you divert a script-generated new window to a new tab using Ctrl+click
    • default = false, make the new tab active
  • browser.tabs.loadBookmarksInBackground => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab)
    • default = false, make the new tab active
I think the other, similarly named, preferences address most other situations: * '''browser.tabs.loadInBackground''' => when you open a regular link in a new tab using Ctrl+click (or right-click > Open in a New Tab) ** default = true, do not make the new tab active ** In the Options dialog/page, this is controlled by the "When I open a link in a new tab, switch to it immediately" setting. * '''browser.tabs.load<u>Diverted</u>InBackground''' => when you divert a script-generated new window to a new tab using Ctrl+click ** default = false, make the new tab active * '''browser.tabs.load<u>Bookmarks</u>InBackground''' => when you load a bookmark in a new tab using Ctrl+click (or right-click > Open in a New Tab) ** default = false, make the new tab active

Question owner

Thanks so much for the additional details. Very helpful!

Thanks so much for the additional details. Very helpful!

Question owner

Also - it does work - applied it and it now opens tabs using command-click into the background from both Google Inbox and Gmail.

Also - it does work - applied it and it now opens tabs using command-click into the background from both Google Inbox and Gmail.

Modified by supnah

Question owner

I ended up disabling as it treats links the same way if they're from outside apps like the Twitter app or anything like that. Picking the one that will be wrong less often. It would be awesome to do something that targeted the Gmail/Inbox thing more specifically, but that might not be possible. Thanks for the info!

I ended up disabling as it treats links the same way if they're from outside apps like the Twitter app or anything like that. Picking the one that will be wrong less often. It would be awesome to do something that targeted the Gmail/Inbox thing more specifically, but that might not be possible. Thanks for the info!
jscher2000
  • Top 10 Contributor
8638 solutions 70669 answers

Hmm, I didn't test that.

You could force external application links in a separate window as a workaround, but if you like all your tabs in one window, then you'll be even unhappier.

If you decide to try that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste link.o and pause while the list is filtered

(3) In this case, experiment with setting (C) to two. The others are here for future reference:

(A) browser.link.open_newwindow

3 = divert new window to a new tab (default) (checked*) 2 = allow link to open a new window (unchecked*) 1 = force new window into same tab

* First checkbox in Options > Tabs (Firefox 38: Options > General)

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

0 = apply the setting under (A) to ALL new windows (even script windows) 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default) 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

-1 = apply the setting under (A) to external links (default) 3 = open external links in a new tab in the last active window 2 = open external links in a new window 1 = open external links in the last active tab replacing the current page

Hmm, I didn't test that. You ''could'' force external application links in a separate window as a workaround, but if you like all your tabs in one window, then you'll be even unhappier. If you decide to try that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''link.o''' and pause while the list is filtered (3) '''In this case, experiment with setting (C) to two'''. The others are here for future reference: (A) <strong>browser.link.open_newwindow</strong> 3 = divert new window to a new tab (<u>default</u>) (checked*) 2 = allow link to open a new window (unchecked*) 1 = force new window into same tab <strong>*</strong> First checkbox in Options &gt; Tabs (Firefox 38: Options > General) (B) <strong>browser.link.open_newwindow.restriction</strong> - for links in Firefox tabs 0 = apply the setting under (A) to ALL new windows (even script windows) 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (<u>default</u>) 1 = override the setting under (A) and always use new windows (C) <strong>browser.link.open_newwindow.override.external</strong> - for links in other programs -1 = apply the setting under (A) to external links (<u>default</u>) 3 = open external links in a <u>new tab</u> in the last active window '''2 = open external links in a <u>new window</u>''' 1 = open external links in the <u>last active tab</u> replacing the current page