Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is there a way to make clicking on an image zoom to the area that you clicked?

  • 4 replies
  • 1 has this problem
  • 56 views
  • Last reply by denbynat0r

more options

Until recently (unless my memory is completely shot), clicking an image to view it at full size would center the image around the point that I clicked. Recently, clicking has defaulted to zooming to the upper-left corner of the image. It can be a real pain to scroll to the portion of the image I actually want to view when I'm looking at a particularly large image. Is there any way to restore the previous behavior?

Chosen solution

This still works for me. I just test it and the horizontal and vertical scroll bars move automatically to show the area I clicked when I opened a large image (2400x2400) from my hard drive.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (4)

more options

Is that done via an add-on?

more options

FredMcD said

Is that done via an add-on?

Not as far as I'm aware. The only add-on I use that could possibly affect image viewing in any way is Zoom Page, which is set to text only, and wouldn't affect the behavior I'm talking about even if it weren't. Basically, I used to be able to navigate to a giant map .jpg or .png in-browser, and when I would click on, say, the lower central section of the resized version, the full-size version would show the area that I'd clicked. Now, it simply snaps to the upper-left corner of the full-size view regardless of where I click the resized image. It's just kind of a pain, is all.

more options

Chosen Solution

This still works for me. I just test it and the horizontal and vertical scroll bars move automatically to show the area I clicked when I opened a large image (2400x2400) from my hard drive.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I was able to find the offending add-on (turns out it was the text-zooming one after all). Thanks for your help!