X
Tap here to go to the mobile version of the site.

Support Forum

Ctrl L keyboard shortcut has stopped working

Posted

For some reason, the Ctrl+L keyboard shortcut to focus on the location bar has stopped working in Firefox. I'm running version 38.0. Have tried restarting Firefox in safe mode with all extensions disabled and it still did not work. The alternative shortcut, Alt+D, does work.

Any ideas??

For some reason, the Ctrl+L keyboard shortcut to focus on the location bar has stopped working in Firefox. I'm running version 38.0. Have tried restarting Firefox in safe mode with all extensions disabled and it still did not work. The alternative shortcut, Alt+D, does work. Any ideas??

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.13
  • Google Update
  • Pando Web Plugin
  • Shockwave Flash 16.0 r0
  • Shockwave Flash 13.0 r0
  • Shockwave Flash 12.0 r0
  • Shockwave Flash 11.8 r800
  • 5.1.30514.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40236 answers

No ideas. {Ctrl + L} is still working for me on 38.0 Beta 01 on my WinXP box.

No ideas. {Ctrl + L} is still working for me on 38.0 Beta 01 on my WinXP box.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

Did you try a new profile?


Other issue:

Note that your System Details List shows multiple Flash plugins (most recent is 17.0.0.134). Shockwave Flash 16.0 r0 Shockwave Flash 13.0 r0 Shockwave Flash 12.0 r0 Shockwave Flash 11.8 r800 You can find the installation path of all plugins on the about:plugins page.

You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32) and possibly (re)install the latest Flash player.

  • (32 bit Windows) C:\Windows\System32\Macromed\Flash\
  • (64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\

See this about uninstalling Flash players:

Note that this will remove all installed Flash players.

You can find the latest Flash player versions for Firefox on this page:

Did you try a new profile? *http://kb.mozillazine.org/Profile_Manager *https://support.mozilla.org/kb/Managing+profiles ----- Other issue: Note that your System Details List shows multiple Flash plugins (most recent is 17.0.0.134). Shockwave Flash 16.0 r0 Shockwave Flash 13.0 r0 Shockwave Flash 12.0 r0 Shockwave Flash 11.8 r800 You can find the installation path of all plugins on the <b>about:plugins</b> page. *http://kb.mozillazine.org/Issues_related_to_plugins#Identifying_installed_plugins You can check the Flash player installation folder for multiple Flash player plugins and remove older version(s) of the plugin (NPSWF32) and possibly (re)install the latest Flash player. *(32 bit Windows) C:\Windows\System32\Macromed\Flash\ *(64 bit Windows) C:\Windows\SysWOW64\Macromed\Flash\ See this about uninstalling Flash players: *http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Note that this will remove all installed Flash players. You can find the latest Flash player versions for Firefox on this page: *http://www.adobe.com/special/products/flashplayer/fp_distribution3.html

Question owner

Thanks, will try a new profile allthough I would hate to have to ditch all my stuff.

Thanks for pointing out about the flash players. I'll have to look into that.

Thanks, will try a new profile allthough I would hate to have to ditch all my stuff. Thanks for pointing out about the flash players. I'll have to look into that.

Question owner

I just tried Ctrl+L in a new profile (with my Firefox 38.0 installation) and it still doesn't work.

Very strange. I'm well aware a new profile usually fixes just about anything.

I just tried Ctrl+L in a new profile (with my Firefox 38.0 installation) and it still doesn't work. Very strange. I'm well aware a new profile usually fixes just about anything.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

You do use an en-US version?

Try a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.


You do use an en-US version? Try a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall
swehack 0 solutions 2 answers

I can add that I have the exact same problem on all my computers running Firefox, and since it's such a diverse plethora of computers with Firefox I find it hard to believe that the profile is damaged in any way.

All of them run FF 37 or higher. It's two Macs with different Mac OS versions, one Fedora 20 laptop, one Ubuntu 14.04 desktop and one Windows 7 laptop.

The Windows 7 laptop isn't even mine, it's a friends, so it is completely unrelated to my Sync profile.

These computers all have one thing in common, FF 37 and Swedish locale, and ctrl+k works while ctrl+l does not.

I also just now tried a co-workers Windows 7/FF37, another computer unrelated to me in any way, and sure enough he has the same issue with using Ctrl+L. Obviously this is a bug.

I can add that I have the exact same problem on all my computers running Firefox, and since it's such a diverse plethora of computers with Firefox I find it hard to believe that the profile is damaged in any way. All of them run FF 37 or higher. It's two Macs with different Mac OS versions, one Fedora 20 laptop, one Ubuntu 14.04 desktop and one Windows 7 laptop. The Windows 7 laptop isn't even mine, it's a friends, so it is completely unrelated to my Sync profile. These computers all have one thing in common, FF 37 and Swedish locale, and ctrl+k works while ctrl+l does not. I also just now tried a co-workers Windows 7/FF37, another computer unrelated to me in any way, and sure enough he has the same issue with using Ctrl+L. Obviously this is a bug.

Modified by swehack

Helpful Reply

Very interesting! I also have this issue on several different PC:s, with synced Firefox profiles. All using the Swedish locale! (And Ctrl+K works for me to.)

Very interesting! I also have this issue on several different PC:s, with synced Firefox profiles. All using the Swedish locale! (And Ctrl+K works for me to.)
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

Maybe you can check these shortcut keys in the DOM Inspector.


Open the browser window in the DOM Inspector.

  • File > Inspect Chrome Document.
  • Choose the first entry from the drop-down list.

You can expand entries in the DOM tree when necessary to open collapsed items. Scroll down to keyset with ID mainKeyset and expand this entry. Look for key with ID focusURLBar and focusURLBar2 and check what key and modifier are specified.

Maybe you can check these shortcut keys in the DOM Inspector. *DOM Inspector: https://addons.mozilla.org/firefox/addon/dom-inspector-6622/ *https://developer.mozilla.org/DOM_Inspector *https://developer.mozilla.org/Introduction_to_DOM_Inspector ---- Open the browser window in the DOM Inspector. *File > Inspect <b>Chrome</b> Document. *Choose the first entry from the drop-down list. You can expand entries in the DOM tree when necessary to open collapsed items. Scroll down to keyset with ID mainKeyset and expand this entry. Look for key with ID focusURLBar and focusURLBar2 and check what key and modifier are specified.
cor-el
  • Top 10 Contributor
  • Moderator
17535 solutions 158559 answers

Helpful Reply

I check the browser .dtd file of the sv-SE Swedish language pack and see this error:

sv-SE:

<!ENTITY openCmd.commandkey           "I">
<!ENTITY urlbar.placeholder2          "Sök eller ange adress">
<!ENTITY urlbar.accesskey             "d">
<!ENTITY urlbar.switchToTab.label     "Växla till fliken:">

en-US:

<!ENTITY openCmd.commandkey           "l">
<!ENTITY urlbar.placeholder2          "Search or enter address">
<!ENTITY urlbar.accesskey             "d">
<!ENTITY urlbar.switchToTab.label     "Switch to tab:">

A possible solution for now is to install the en-US Firefox version and the sv-SE language pack and edit the browser.dtd file and change the openCmd.commandkey item to "l".

  • sv-SE.xpi/browser/chrome/sv-SE/locale/browser/browser.dtd

There is already a bug filed for this issue:

  • bug 1141990 - [sv-SE] Ctrl+I / Cmd+I defined as location bar keyboard shortcut in Swedish locale, instead of Ctrl+L / Cmd+L
I check the browser .dtd file of the sv-SE Swedish language pack and see this error: sv-SE: <pre><nowiki><!ENTITY openCmd.commandkey "I"> <!ENTITY urlbar.placeholder2 "Sök eller ange adress"> <!ENTITY urlbar.accesskey "d"> <!ENTITY urlbar.switchToTab.label "Växla till fliken:"> </nowiki></pre> en-US: <pre><nowiki><!ENTITY openCmd.commandkey "l"> <!ENTITY urlbar.placeholder2 "Search or enter address"> <!ENTITY urlbar.accesskey "d"> <!ENTITY urlbar.switchToTab.label "Switch to tab:"></nowiki></pre> A possible solution for now is to install the en-US Firefox version and the sv-SE language pack and edit the browser.dtd file and change the openCmd.commandkey item to "l". *sv-SE.xpi/browser/chrome/sv-SE/locale/browser/browser.dtd ---- There is already a bug filed for this issue: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1141990 bug 1141990] - [sv-SE] Ctrl+I / Cmd+I defined as location bar keyboard shortcut in Swedish locale, instead of Ctrl+L / Cmd+L