X
Tap here to go to the mobile version of the site.

Support Forum

Facebook videoplayer doesn't load, only Facebook and only on Firefox - other flash videoplayers on Firefox do work, Facebook video on other browsers do either.

Posted

win8.1x64, ff36.0.1 32bit, adobe flash up to date.

Have reinstalled both, FF and flash, but with no success.

win8.1x64, ff36.0.1 32bit, adobe flash up to date. Have reinstalled both, FF and flash, but with no success.

Modified by antongruba

Additional System Details

Installed Plug-ins

  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 13.0 r0
  • 5.1.20513.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

More Information

FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

Security Issue: Update your Flash Player Version 17.0.0.134
https://www.adobe.com/products/flashplayer/distribution3.html

See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Security Issue: Update your Flash Player '''Version 17.0.0.134<br>https://www.adobe.com/products/flashplayer/distribution3.html''' See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

FredMcD said

Security Issue: Update your Flash Player Version 17.0.0.134
https://www.adobe.com/products/flashplayer/distribution3.html
See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Hey, Thanks for responding.

As for flash, I have this exect version and keep it up to date automatically. Reinstalled, downgraded, upgraded - everything. Same is for the browser. But still...

As for the driver, I have brand new computer with all the necessary s/w installed. Moreover, there was no such problem at the very beginning and FB video worked perfectly fine, but something unknown have happend specifically to Facebook-Firefox thing. There is something I did do with FF after the first installation that might have a sort relation to the issue - I've installed x64 version, but it began to crash endlessly the flash plug-in, so I've returned to x86, which did fine for some while before the breakdown. Well, it still does apart from FB.

''FredMcD [[#answer-706953|said]]'' <blockquote> Security Issue: Update your Flash Player '''Version 17.0.0.134<br>https://www.adobe.com/products/flashplayer/distribution3.html''' See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration </blockquote> Hey, Thanks for responding. As for flash, I have this exect version and keep it up to date automatically. Reinstalled, downgraded, upgraded - everything. Same is for the browser. But still... As for the driver, I have brand new computer with all the necessary s/w installed. Moreover, there was no such problem at the very beginning and FB video worked perfectly fine, but something unknown have happend specifically to Facebook-Firefox thing. There is something I did do with FF after the first installation that might have a sort relation to the issue - I've installed x64 version, but it began to crash endlessly the flash plug-in, so I've returned to x86, which did fine for some while before the breakdown. Well, it still does apart from FB.
FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

antongruba said

As for flash, I have this exect version and keep it up to date automatically. Reinstalled, downgraded, upgraded - everything. Same is for the browser. But still...

Your System Details shows; Installed Plug-ins; Shockwave Flash 13.0 r0 That is why I told you to update

As for the driver, I have brand new computer with . . . .

Check for updates anyway. You never know.

there was no such problem at the very beginning and FB video worked
Check and report what these links say;

Flash Player Test Page YouTube Test Page: What video does this browser support

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.

''antongruba [[#answer-707276|said]]'' <blockquote> As for flash, I have this exect version and keep it up to date automatically. Reinstalled, downgraded, upgraded - everything. Same is for the browser. But still... </blockquote> Your System Details shows; Installed Plug-ins; Shockwave Flash 13.0 r0 That is why I told you to update <blockquote> As for the driver, I have brand new computer with . . . . </blockquote> Check for updates anyway. You never know. <blockquote> there was no such problem at the very beginning and FB video worked </blockquote>Check and report what these links say; '''[https://www.adobe.com/software/flash/about/ Flash Player Test Page]''' '''[https://www.youtube.com/html5 YouTube Test Page: What video does this browser support]''' Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies<br> '''''Warning ! ! '' This will log you out of sites you're logged in to.''' Type '''about:preferences'''<Enter> in the address bar. * '''Cookies;''' Select '''Privacy.''' Under '''History,''' select Firefox will '''Use Custom Settings.''' Press the button on the right side called '''Show Cookies.''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache;''' Select '''Advanced > Network.''' Across from '''Cached Web Content,''' Press '''Clear Now.''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? Then restart.

Question owner

Exhausted. Done all (Except the driver. No need really. It's only Facebook, well.) and it was alright. Something about the site. Now, when I right-click on the not working player Shockwave hangs. At the beginning of the problem I still could at least open Flash settings, now even that is broken. I'm totally confused.

Exhausted. Done all (Except the driver. No need really. It's only Facebook, well.) and it was alright. Something about the site. Now, when I right-click on the not working player Shockwave hangs. At the beginning of the problem I still could at least open Flash settings, now even that is broken. I'm totally confused.

Question owner

At the moment tried it all, no success. Should I reinstall the system? Don't think so.

Have to turn to Chrome. Sorry, FF, even though you're better in quiet a number of aspects, it's no deal this way.

At the moment tried it all, no success. Should I reinstall the system? Don't think so. Have to turn to Chrome. Sorry, FF, even though you're better in quiet a number of aspects, it's no deal this way.
FredMcD
  • Top 10 Contributor
4255 solutions 59584 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
guigs 1072 solutions 11697 answers

I understand that Flash player has been updated. However I also understand that there are two installations of Firefox.

I have been able to reproduce this on a Windows 8 machine with Flash 17 installed. I get a warning that the plugin has stopped responding on the page. I do not know if this is specific to the operating system, it seems so so far.

When it did not load, I refreshed the page and the video began to play just fine. However playback does not work. If I pause it the unresponsive script starts as well. Since its Flash that is crashing and hanging try the Flash player settings by searching for flash on the start menu of the computer.

Please also report this issue to Facebook: https://www.facebook.com/help/186570224871049 I have as well in reference to this thread.

I understand that Flash player has been updated. However I also understand that there are two installations of Firefox. I have been able to reproduce this on a Windows 8 machine with Flash 17 installed. I get a warning that the plugin has stopped responding on the page. I do not know if this is specific to the operating system, it seems so so far. When it did not load, I refreshed the page and the video began to play just fine. However playback does not work. If I pause it the unresponsive script starts as well. Since its Flash that is crashing and hanging try the Flash player settings by searching for flash on the start menu of the computer. Please also report this issue to Facebook: https://www.facebook.com/help/186570224871049 I have as well in reference to this thread.

Modified by guigs

guigs 1072 solutions 11697 answers

I disabled hardware acceleration in Firefox and set Adobe Flash to always activate and refreshed the page and the video started to play.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  1. Open Firefox Options window (Preferences on Mac or Linux) as follows:
    • In Firefox 29.0 and above, click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux.
    • In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  2. In the Firefox Options (or Preferences) window, click the Advanced tab, then select General.
  3. In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  4. Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

I disabled hardware acceleration in Firefox and set Adobe Flash to always activate and refreshed the page and the video started to play. Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: #Open Firefox ''Options'' window (''Preferences'' on Mac or Linux) as follows: #* In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]] and select ''Options'' for Windows or ''Preferences'' on Mac or Linux. #* In Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. #In the Firefox Options (or Preferences) window, click the ''Advanced'' tab, then select ''General''. #In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. #Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back to us! Thank you.
guigs 1072 solutions 11697 answers
https://bugzilla.mozilla.org/show_bug.cgi?id=1149762

Question owner

guigs2 said, said, said:

...

Hey,

I have only one official x86 installation. A while beforehand I had installed x64, didn't do well regarding Flash, uninstalled.

The problem is on the regular and only at the moment installation. When I click Play, opens the player, black screen, happens nothing. Flash doesn't hang. (One day it did every time I right-clicked the black screen, but as well suddenly returned to order.) When I open Flash local settings I can't change anything - uncheck, for example, "hardware acceleration" and it's back there the next time. "Hardware acceleration" in FF settings I also tried toggling, but without any affection whatsoever.

Wrote to Facebook as well, no response.

Also, Facebook is not the only problematic site. I've discovered that others act strange too, some doesn't work at all either, some have no sound or various stuck control buttons. Youtube is perfect with that and many others too though.

Thanks.

''guigs2 [[#answer-711498|said]], [[#answer-711506|said]], [[#answer-711507|said]]:'' <blockquote> ... </blockquote> Hey, I have only one official x86 installation. A while beforehand I had installed x64, didn't do well regarding Flash, uninstalled. The problem is on the regular and only at the moment installation. When I click Play, opens the player, black screen, happens nothing. Flash doesn't hang. (One day it did every time I right-clicked the black screen, but as well suddenly returned to order.) When I open Flash local settings I can't change anything - uncheck, for example, "hardware acceleration" and it's back there the next time. "Hardware acceleration" in FF settings I also tried toggling, but without any affection whatsoever. Wrote to Facebook as well, no response. Also, Facebook is not the only problematic site. I've discovered that others act strange too, some doesn't work at all either, some have no sound or various stuck control buttons. Youtube is perfect with that and many others too though. Thanks.

Question owner

FredMcD said

I've called the big guys to help you. Good luck.

I appreciate your effort.

''FredMcD [[#answer-710663|said]]'' <blockquote> I've called the big guys to help you. Good luck. </blockquote> I appreciate your effort.