X
Tap here to go to the mobile version of the site.

Support Forum

How can I block the autoplaying videos in this webpage?

Posted

On right column of this webpage (http://www.wenxuecity.com/news/2015/0.../4096330.html), there is an autoplaying video, which I outlined in a red box. (You might need to refresh one more time for the video appears, as the website sometimes play flash or picture ad instead of video).

I tried severl addons to block videos and flashes, but none of them works or I don't know how to use them properly. Can someone help? Thanks!

On right column of this webpage ([http://www.wenxuecity.com/news/2015/03/11/4096330.html]), there is an autoplaying video, which I outlined in a red box. (You might need to refresh one more time for the video appears, as the website sometimes play flash or picture ad instead of video). I tried severl addons to block videos and flashes, but none of them works or I don't know how to use them properly. Can someone help? Thanks!
Attached screenshots

Modified by cor-el

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • Firefox 36.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0/Linux/en-US/

Extensions

  • Ads no more 2.1 ({a3a5c777-f583-4fef-9380-ab4add1bc2a2})
  • Click to Play per-element 0.3.1 (ClickToPlayPerElement@uaSad.addons.mozilla.org)
  • CNTVLive2 plugin for Firefox 1.0.0.6 (CNTVLive2@www.cntv.cn)
  • DownThemAll! 2.0.18 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Firebug 2.0.8 (firebug@software.joehewitt.com)
  • FirefoxAdKiller 0.87 ({b1df372d-8b32-4c7d-b6b4-9c5b78cf6fb1})
  • Flash Block 4.20.13 ({95ab36d4-fb6f-47b0-8b8d-e5f3bd547953})
  • Flashblock 1.5.18 ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • FlashStopper 1.2.5 (flashstopper@byo.co.il)
  • Google Translator for Firefox 2.1.0.3 (translator@zoli.bod)
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Mason 0.3.7.9.18 ({F632A5EA-F825-4AE7-94B5-233CFBA9F423})
  • Session Manager 0.8.1.6 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com)
  • Ubuntu Online Accounts 0.5 (online-accounts@lists.launchpad.net)
  • Unity Desktop Integration 3.0.2 (webapps-team@lists.launchpad.net)
  • Unity Websites integration 2014.08.06.beta ({2e1445b0-2682-11e1-bfc2-0800200c9a66})
  • Brief 1.7.3 (brief@mozdev.org) (Inactive)
  • DownloadHelper 4.9.24 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • FlashGot 1.5.6.10 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34}) (Inactive)
  • Novell Moonlight 3.99.0.3 (moonlight@novell.com) (Inactive)
  • SkipScreen 0.7.2 (SkipScreen@SkipScreen) (Inactive)
  • Torbutton 1.2.5 ({e0204bd5-9d31-402b-a99d-a6aa8ffebdca}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset
  • adapterDeviceID: Mesa DRI Mobile Intel® GM45 Express Chipset
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 2.1 Mesa 10.3.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Mobile Intel® GM45 Express Chipset
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Helpful Reply

If the problem video uses the built-in HTML5 video player, there is a setting to turn off autostart. It's worth a try, but it might not work in every case because the page might have a script to simulate you clicking the play button. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch it from true to false.

I say "if" because I usually got the Flash player plugin activation message, so I didn't actually see HTML5 video playing.

Does the "click to play per element" extension work for you on other sites? That one generally has the smoothest interaction with Firefox's Ask to Activate feature.

If the problem video uses the built-in HTML5 video player, there is a setting to turn off autostart. It's worth a try, but it might not work in every case because the page might have a script to simulate you clicking the play button. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch it from true to false. I say "if" because I usually got the Flash player plugin activation message, so I didn't actually see HTML5 video playing. Does the "click to play per element" extension work for you on other sites? That one generally has the smoothest interaction with Firefox's Ask to Activate feature.

Question owner

Thanks.

Setting media.autoplay.enabled to be false doesn't work.

I install "click to play per element" extension, but I don't know how it works or it doesn't work.

Thanks. Setting media.autoplay.enabled to be false doesn't work. I install "click to play per element" extension, but I don't know how it works or it doesn't work.

Modified by Timmm

jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Helpful Reply

If you set Shockwave Flash to "Ask to Activate" then sites can't load Flash media without your permission. The built-in permission feature is global, so once you give permission on page 1, the site has permission on pages 2, 3, 4, etc. The "Click to play per element" extension overrides this so you can give permission only to specific pieces of media you want to play.

Let's verify that Flash is set to "Ask to Activate" on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Then, on the right, if Shockwave Flash is set to "Always Activate", change the permission to "Ask to Activate".

When you visit a site that wants to use the Flash, you should see a notification icon in the address bar (looks like a little block of Lego) and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

Hopefully this will make it easier to manage.

Note: I suggest disabling the Flash Block/Flash Stopper extensions to avoid potential conflicts while you test this out.

If you set Shockwave Flash to "Ask to Activate" then sites can't load Flash media without your permission. The built-in permission feature is global, so once you give permission on page 1, the site has permission on pages 2, 3, 4, etc. The "Click to play per element" extension overrides this so you can give permission only to specific pieces of media you want to play. Let's verify that Flash is set to "Ask to Activate" on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Then, on the right, if Shockwave Flash is set to "Always Activate", change the permission to "Ask to Activate". When you visit a site that wants to use the Flash, you should see a notification icon in the address bar (looks like a little block of Lego) and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. Hopefully this will make it easier to manage. Note: I suggest disabling the Flash Block/Flash Stopper extensions to avoid potential conflicts while you test this out.

Question owner

Yes, i saw a little bar between the toolbar and the page, asking me if continue blocking or allow. I choose continute blocking. Is that what you meant?

Yes, i saw a little bar between the toolbar and the page, asking me if continue blocking or allow. I choose continute blocking. Is that what you meant?
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

If the bar appears and you continue blocking, then Flash shouldn't play at all on that site. Does the site still manage to play the video somehow?

If the bar appears and you continue blocking, then Flash shouldn't play at all on that site. Does the site still manage to play the video somehow?
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Also, you can just ignore the bar unless you want to change what is happening. You don't need to use Continue buttons.

Also, you can just ignore the bar unless you want to change what is happening. You don't need to use Continue buttons.

Question owner

It seems work. Thanks.

Which addon or change in config makes that work?

It seems work. Thanks. Which addon or change in config makes that work?

Modified by Timmm

jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Ask to Activate is the basic feature, and the Click to Play per Element modifies it so that it's not global to the site.

Ask to Activate is the basic feature, and the Click to Play per Element modifies it so that it's not global to the site.
FredMcD
  • Top 10 Contributor
4188 solutions 58471 answers

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it


Adblock Plus {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).

'''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it --------------------------- '''[https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/ Adblock Plus]''' {web link} Blocks annoying video ads on YouTube, Facebook ads, banners and much more. Adblock Plus blocks all annoying ads, and supports websites by not blocking unobtrusive ads by default (configurable).