Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube seems to be blocking the use of Firefox (MaskingAgent ?) on 2015-01-08

more options
  • YouTube seems to be blocking the use of Firefox on 2015-01-08 , please allow me to (ATTACH) a screenshot.
  • I note that the default Search engine (a.k.a. "revenue) for Firefox recently changed from Google/YouTube, to be Yahoo.

Modified by greg-mozilla

Chosen solution

This is caused by the Masking Agent extension, which sends intentionally inaccurate information to sites about the browser you're using. I don't know whether the extension lets you make an exception for youtube.com and ytimg.com in order to work around the issue. If not, you might need to disable the extension.

You can manage the extension on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find Masking Agent and check for an Options button. This also is where you would disable it.

(Often a link appears above a disabled extension to restart Firefox. You can complete your work on the tab and click that as the last step.)

As far as I know, your default search engine is invisible to websites, so that probably is not an issue. Or did you want to make a change there? This article has the steps: Search with the Firefox address bar.

Read this answer in context 👍 2

All Replies (8)

more options

Screenshot, is *attached*. Thanks so much.

more options

Chosen Solution

This is caused by the Masking Agent extension, which sends intentionally inaccurate information to sites about the browser you're using. I don't know whether the extension lets you make an exception for youtube.com and ytimg.com in order to work around the issue. If not, you might need to disable the extension.

You can manage the extension on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find Masking Agent and check for an Options button. This also is where you would disable it.

(Often a link appears above a disabled extension to restart Firefox. You can complete your work on the tab and click that as the last step.)

As far as I know, your default search engine is invisible to websites, so that probably is not an issue. Or did you want to make a change there? This article has the steps: Search with the Firefox address bar.

more options

Your More system Details on right of you post has this. User Agent: Mozilla/5.0 (masking-agent; rv:24.0) Gecko/20100101 Firefox/24.0

more options

(1) Masking Agent 1.3.0 , Information

>>> snip >>> about:addons Masking AgentMasking Agent protects you from showing platform information (OS and CPU) on the internet. Details of your platform are revealed through a HTTP request header (User-Agent) and through a javascript object (navigator). That enables evildoers to exploit platform specific weaknesses, create a profile of you, and/or target you in commercial or other campaigns.

Masking Agent hides those platform details, by substituting a short (configurable) replacement text.

The browser name and version information remains intact. <----

   {  
    Perhaps I'll try to contact "basa", the publisher of this Very Fine Addon , and ask about whitelisting.
    https://addons.mozilla.org/en-US/firefox/user/basa_nl/?src=api  
    http://basa.nl/apps/maskingagent/ 
    http://basa.nl/apps/maskingagent/demo 
        {
            Known Issues:  ( http://basa.nl/apps/maskingagent ) 
       
           * "The Firefox version is not incremented in the User-Agent after a Firefox update."
              Please follow the Reset instructions below.  <--- Let me try this. Progress ...

<--- OK, these instructions (a) Fix (Yahoo and Mozilla) and (b) Help-but-not-fix, YouTube , for me.

        }
    }

That way browser updates do not disturb the extension and the extension does not disturb browser updates.

The platform details are initially replaced by the text 'masking-agent'. You can provide a custom text, if so desired, in the addon's preferences interface. Any changes made to the replacement text are immediately reflected in the platform details. >>> snip >>>

(2) This very site, Mozilla, https://support.mozilla.org/en-US/questions/new/confirm , is *also* saying , "Looks like you’re using an older version of Firefox. Update to stay fast and safe. Later."

(3) Yahoo mail, https://us-MMM.mail.yahoo.com/neo/launch?.rand=RRRRRRRR , is *also* saying , "Upgrade to the new Firefox" (4) Thank you Mozilla volunteers, for helping.

more options

Good work finding the instructions for manually updating the version number.

I wonder what else Youtube is looking at?

Maybe it stashed the old version number in a cookie? While you're on the site, you can clear its cookies using either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Not sure that will make the site any happier...

more options

SUMMARY:

  • I deleted all the Youtube coookes from the FF Tools menu. Good, but that did not seem to get the video to start
  • I went to the FlashBlock extension and Whitelisted "youtube.com" . That whitelisting did get it to work.
  • Note, I have used FlashBlock with Youtube for years.
  • Thanks for the volunteer help.
more options

Normally I think FlashBlock displays a link or button which lets you start the video. Is that is not appearing, something else may be blocking it. Does anything appear where the video normally appears? Could it be Adblock Plus?

more options

@jscher2000: Normally I think FlashBlock displays a link or button which lets you start the video. Is that is not appearing, something else may be blocking it. Does anything appear where the video normally appears?

A: Yes, FlashBlock is still displaying the "(F)" icon it has for years, but for some reason when I click on the "(F)" icon, nothing happens. So I just whitelisted YouTube for FlashBlock, and YouTube works now.

@jscher2000 Could it be Adblock Plus? A: Hmmm, I'm not sure how I could debug that. But it seems I have a "Flashblock" workaround that goes with the "MaskingAgent" , browser-version-reset procedure ... found on the "MaskingAgent" , publisher's site.

Q: Does anybody have permissions to (or know how to) add the Tags=( AdBlock and FlashBlock ) , to this posting ... to help other people when they search ?

Modified by greg-mozilla