X
Tap here to go to the mobile version of the site.

Support Forum

How do I fix Javascript message that says "too much recursion"?

Posted

Hi there, every time that I load up or refresh a webpage in Firefox, I'm getting a message popup from Javascript that says "too much recursion" - I have no idea what this means or how to fix it, but it's gotten to a point where it's making it almost impossible to do anything through Firefox as it's popping up so often. Is there a way to make this stop?

Hi there, every time that I load up or refresh a webpage in Firefox, I'm getting a message popup from Javascript that says "too much recursion" - I have no idea what this means or how to fix it, but it's gotten to a point where it's making it almost impossible to do anything through Firefox as it's popping up so often. Is there a way to make this stop?

Additional System Details

Installed Plug-ins

  • Google Update
  • HPDetect
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Pando Web Plugin
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • iTunes Detector Plug-in

Application

  • Firefox 35.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.6 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Blur (Formerly DoNotTrackMe) 4.5.1334 (donottrackplus@abine.com)
  • Download Status Bar 12.3.0 ({6c28e999-e900-4635-a39d-b1ec90ba0c0f})
  • DownloadHelper 4.9.24 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Greasemonkey 2.3 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Save Session 1.3.1.6 (savesession@noasobi.net)
  • Stylish 2.0.0 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Updated Ad Blocker for Firefox 11+ 0.7.7 ({4DC70064-89E2-4a55-8FC6-E8CDEAE3618C})
  • XKit 7.4.4 (xkit@studioxenix.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 196f103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17415
  • driverDate: 11-15-2013
  • driverDate2:
  • driverVersion: 10.18.10.3355
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 2
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141211142524
  • browser.startup.homepage_override.buildID: 20141211142524
  • browser.startup.homepage_override.mstone: 35.0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 35.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • media.gmp-gmpopenh264.lastUpdate: 1412205326
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1418726497
  • network.cookie.prefsMigrated: True
  • network.dns.disableIPv6: True
  • network.dnsCacheEntries: 100
  • network.dnsCacheExpiration: 120
  • network.http.connect.timeout: 150
  • network.http.keep-alive: True
  • network.http.keep-alive.timeout: 300
  • network.http.max-connections: 24
  • network.http.max-connections-per-server: 8
  • network.http.max-persistent-connections-per-proxy: 6
  • network.http.max-persistent-connections-per-server: 4
  • network.http.pipelining: True
  • network.http.pipelining.maxrequests: 4
  • network.http.proxy.keep-alive: True
  • network.http.proxy.pipelining: True
  • places.database.lastMaintenance: 1418722246
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.np32dsw: 0
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1416872034

Misc

  • User JS: Yes
  • Accessibility: No
ideato 893 solutions 6250 answers

Hello lavendermoon, maybe an installed Extension that have problems with their JavaScript is the issue, to check that Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • In Firefox 29.0 and above, click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
  • In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on Help (or click on Help in the Menu bar, if you don't have a Firefox button) then click on Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.


also try to delete in your profile folder the User.js file you have.

The user.js file does not exist by default. If you create the file, forget it, if you have not create the file then delete the User.js file, to see if the problem goes away (some programs create and write in the file also).

thank you

Hello lavendermoon, maybe an installed Extension that have problems with their JavaScript is the issue, to check that '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu: *In Firefox 29.0 and above, click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. *In previous Firefox versions, click on the Firefox button at the top left of the Firefox window and click on ''Help'' (or click on ''Help'' in the Menu bar, if you don't have a Firefox button) then click on ''Restart with Add-ons Disabled''. If Firefox is not running, you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". :[[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' -------------------------------------------------------------------------------------------------- also try to delete in your [http://kb.mozillazine.org/Profile_folder_-_Firefox#Windows profile folder] the [http://kb.mozillazine.org/User.js_file User.js file] you have. The user.js file does not exist by default. If you create the file, forget it, if you have not create the file then delete the User.js file, to see if the problem goes away (some programs create and write in the file also). thank you
cor-el
  • Top 10 Contributor
  • Moderator
17479 solutions 157962 answers

You can cleanup the prefs to have a fresh start and delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

You can cleanup the prefs to have a fresh start and delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can use this button to go to the currently used Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox