X
Tap here to go to the mobile version of the site.

Support Forum

HTML5 is CPU-hog

Posted

Why is it that after FF 33 HTML5 has been taking insane amounts of CPU? I'm using 33.1 and removing HTML5 from being default player removed almost half of the CPU use (even with flash-player active) and cut Firefox's CPU use to fraction.

That said, multiple tabs and pages with many pics still take far more CPU than with 32.03. KK

Why is it that after FF 33 HTML5 has been taking insane amounts of CPU? I'm using 33.1 and removing HTML5 from being default player removed almost half of the CPU use (even with flash-player active) and cut Firefox's CPU use to fraction. That said, multiple tabs and pages with many pics still take far more CPU than with 32.03. KK

Additional System Details

Installed Plug-ins

  • Shockwave Flash 15.0 r0
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.12
  • Facebook Video Calling Plugin
  • 5.1.30514.0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7.148
  • NPWLPG
  • Office Live Update v1.5
  • Picasa plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:33.0) Gecko/20100101 Firefox/33.0

More Information

theshine 2 solutions 33 answers

i think that you have add some ip blocking rule in your host file, please check it , cause the high level of CPU usage is causing by the svschot.exe part of the host file.

Try to run

http://software-files-a.cnet.com/s/software/13/80/01/46/cureit.exe?token=1416701220_bef0aa549e17f57cec912609bd47e9d7&fileName=cureit.exe

it's a antivirus especially to detect violation memory on process and to disinfect your host file... , if you have problem yet, you can send me a feedback :)

i think that you have add some ip blocking rule in your host file, please check it , cause the high level of CPU usage is causing by the svschot.exe part of the host file. Try to run http://software-files-a.cnet.com/s/software/13/80/01/46/cureit.exe?token=1416701220_bef0aa549e17f57cec912609bd47e9d7&fileName=cureit.exe it's a antivirus especially to detect violation memory on process and to disinfect your host file... , if you have problem yet, you can send me a feedback :)

Question owner

Tried it, found nothing, no difference.

Plus I forgot to mention two things: shifting back to 32.03 removes all the problems, and as I said it only started since FF 33.

Secondly, this happens in two completely different computers 'bout 60 km apart, this uses vista, other windows 7 for starters... so I rather doubt it's something that easy. KK

Tried it, found nothing, no difference. Plus I forgot to mention two things: shifting back to 32.03 removes all the problems, and as I said it only started since FF 33. Secondly, this happens in two completely different computers 'bout 60 km apart, this uses vista, other windows 7 for starters... so I rather doubt it's something that easy. KK
theshine 2 solutions 33 answers

Send to me all your info about your chipset (amd or intel) i don't know, maybe your installation is not compatible with your operating system, give all the details about your navigator, the version of it, 32.03 is not enough is it a x86 or a x64 architecture?

Send to me all your info about your chipset (amd or intel) i don't know, maybe your installation is not compatible with your operating system, give all the details about your navigator, the version of it, 32.03 is not enough is it a x86 or a x64 architecture?

Question owner

Being a lay-users, how is this done? Could you give as clear/simple guidelines as possible.

Also something you might find notable, and I realized only after the last post: when HTML5 is in use, Firefox takes constantly quite a bit more CPU and memory percentage even when there's no video playing, when I returned to default player both dropped to the level of FF 32.03. KK

Being a lay-users, how is this done? Could you give as clear/simple guidelines as possible. Also something you might find notable, and I realized only after the last post: when HTML5 is in use, Firefox takes constantly quite a bit more CPU and memory percentage even when there's no video playing, when I returned to default player both dropped to the level of FF 32.03. KK
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

You can try to disable OMTC and leave hardware acceleration in Firefox enabled.

  • about:config page: layers.offmainthreadcomposition.enabled = false

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable OMTC and leave hardware acceleration in Firefox enabled. *<b>about:config</b> page: layers.offmainthreadcomposition.enabled = false You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

What does OMTC do and why would that help here? Lay-user, remember...

Tried disabling hardware acceleration and that does nothing useful. KK

What does OMTC do and why would that help here? Lay-user, remember... Tried disabling hardware acceleration and that does nothing useful. KK
theshine 2 solutions 33 answers

Go to your configuration panel on windows, click on system and security and then, on system, say it to me all the stuff that is visible... i mean your stuff that your system can detecting, (your fast memory and your Controller Process Unit).

Go to your configuration panel on windows, click on system and security and then, on system, say it to me all the stuff that is visible... i mean your stuff that your system can detecting, (your fast memory and your Controller Process Unit).
theshine 2 solutions 33 answers

Or if you want to reload back in a safe place, try to uninstall firefox, but also in the c:\\programdata\mozilla (delete it) and user/yourname/appdata/local/temp (delete it)

and user/yourname/appdata/roaming/mozilla (delete it)

then run ccleaner (on Google.com) to avoid registry problems.

Reinstall Firefox v33.exec on the official repository (https://www.mozilla.org)

Or if you want to reload back in a safe place, try to uninstall firefox, but also in the c:\\programdata\mozilla (delete it) and user/yourname/appdata/local/temp (delete it) and user/yourname/appdata/roaming/mozilla (delete it) then run ccleaner (on Google.com) to avoid registry problems. Reinstall Firefox v33.exec on the official repository (https://www.mozilla.org)

Question owner

Having my computer in Finnish makes this bit ques work, but...

In this computer: Pentium(R) Dual-Core CPU T4200 @ 2.00 GHz 2.00 GHz

(RAM) 4.00 Gt

32-bit

I'll post the details of my other computer when I get to it. KK

Having my computer in Finnish makes this bit ques work, but... In this computer: Pentium(R) Dual-Core CPU T4200 @ 2.00 GHz 2.00 GHz (RAM) 4.00 Gt 32-bit I'll post the details of my other computer when I get to it. KK

Question owner

Second computer: Intel(R) Celeron(R) CPU E3300 @ 2.50 GHz 2.50 GHz

(RAM) 2.00 Gt

84-bit

Considering the differences and the main thing connecting them is that I use both and that Firefox has Classic theme restored, I wonder how they both could have same problem. Especially since first FF 33 had very serious problems with HTML5, which was supposed to be fixed in 33.01.

This problem started in FF 33, only happens using it and only when HTML5 is on use. Did their fix actually correct the problem (in which case I'm wrong and we need to find other way to fix mine), or it just mitigated the problem?

To put this to test, could you check CPU/memory use with HTML5 and default-player? Youtube has most videos on HTML5 so that would be good place to test this. If there's anything in what I suspect, there should be obvious difference on how much CPU/memory either one uses. KK

Second computer: Intel(R) Celeron(R) CPU E3300 @ 2.50 GHz 2.50 GHz (RAM) 2.00 Gt 84-bit * Considering the differences and the main thing connecting them is that I use both and that Firefox has Classic theme restored, I wonder how they both could have same problem. Especially since first FF 33 had very serious problems with HTML5, which was supposed to be fixed in 33.01. This problem started in FF 33, only happens using it and only when HTML5 is on use. Did their fix actually correct the problem (in which case I'm wrong and we need to find other way to fix mine), or it just mitigated the problem? To put this to test, could you check CPU/memory use with HTML5 and default-player? Youtube has most videos on HTML5 so that would be good place to test this. If there's anything in what I suspect, there should be obvious difference on how much CPU/memory either one uses. KK
theshine 2 solutions 33 answers

AS IT SAY , your computer with this component doesn't allow you to avoid cpu problem, the main fact is that your cpu (dual core T4200 or E3300) is to slow, so the frequency must be higher, to run properly as possible the new architecture of firefox it self, firefox does originally mastering some of 600 mb with the faster_memory for better performance... i'm wondering if you have a old graphic card to, so the best way to re-run your computer with all the fluidity that you want is to change with a intel core i3 and also your graphic card... to display html5 (the new version) as clearly as possible, but i have a trick, try to run firefox in safe mode, i mean windows safe-mode, and you will no more have such problem :)... but no playing video or your navigator will freeze again...

AS IT SAY , your computer with this component doesn't allow you to avoid cpu problem, the main fact is that your cpu (dual core T4200 or E3300) is to slow, so the frequency must be higher, to run properly as possible the new architecture of firefox it self, firefox does originally mastering some of 600 mb with the faster_memory for better performance... i'm wondering if you have a old graphic card to, so the best way to re-run your computer with all the fluidity that you want is to change with a intel core i3 and also your graphic card... to display html5 (the new version) as clearly as possible, but i have a trick, try to run firefox in safe mode, i mean windows safe-mode, and you will no more have such problem :)... but no playing video or your navigator will freeze again...

Question owner

Well, I was planning to get new computer pretty soon anyway... as soon as the next windows version has been proved to be usable anyway.

How's that safe-mode done?

Well, I was planning to get new computer pretty soon anyway... as soon as the next windows version has been proved to be usable anyway. How's that safe-mode done?

Question owner

If it means using Firefox safe-mode, forget it. Every single one of the extensions and themes I have is there for a reason...

If it means using Firefox safe-mode, forget it. Every single one of the extensions and themes I have is there for a reason...
cor-el
  • Top 10 Contributor
  • Moderator
17352 solutions 156837 answers

Did you try to disable hardware acceleration in Firefox?

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Did you try to disable hardware acceleration in Firefox? You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/how-do-i-upgrade-my-graphics-drivers

Question owner

Tried disabling hardware acceleration and said that in answer to your first time asking it.


Being a lay-user and careful at that, I'll ask few stupid questions:

Checking "Upgrade your graphics drivers" => "Troubleshooting Information page" gives "Adapter Description Intel(R) G41 Express Chipset", does this mean that my "dual core E3300" is compatible with generic graphics driver provided by Intel Drivers?

That warning about possibly experiencing problems is bit concerning... if it causes problems, how to remove it/them? KK

Tried disabling hardware acceleration and said that in answer to your first time asking it. Being a lay-user and careful at that, I'll ask few stupid questions: Checking "Upgrade your graphics drivers" => "Troubleshooting Information page" gives "Adapter Description Intel(R) G41 Express Chipset", does this mean that my "dual core E3300" is compatible with generic graphics driver provided by Intel Drivers? That warning about possibly experiencing problems is bit concerning... if it causes problems, how to remove it/them? KK

Question owner

Anyone?

Anyone?
theshine 2 solutions 33 answers

Because the safe mode, do only pass all your systems services that is required for you to open the computer, and not your graphic card or sound card or the spooler service system (printer) so the best way is to rerun your operating systeme and press on the boot loading the F8 module on your keyboard, and then enter on the sentences that is saying that you can enabled your networking system to, so finally .... have a good time :p, or else, you can have some fastidious task to uninstall your graphic driver properly, and than go to safe mode directly, and there install manually the driver (the last that you download before) you can try to extract the setup.exe directly with universal extractor... try this it would be grateful to you :p , but it is not for noob, may i say that you can ask some help ^^,

Because the safe mode, do only pass all your systems services that is required for you to open the computer, and not your graphic card or sound card or the spooler service system (printer) so the best way is to rerun your operating systeme and press on the boot loading the F8 module on your keyboard, and then enter on the sentences that is saying that you can enabled your networking system to, so finally .... have a good time :p, or else, you can have some fastidious task to uninstall your graphic driver properly, and than go to safe mode directly, and there install manually the driver (the last that you download before) you can try to extract the setup.exe directly with universal extractor... try this it would be grateful to you :p , but it is not for noob, may i say that you can ask some help ^^,

Modified by theshine