X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes very frequently

Posted

I've been using another browser (Opera) for some time now, and recently switched back to firefox. However, firefox is crashing constantly (I'm counting in excess of 30 crashes over a period of 4 days). It can't (AFAIK) be traced to any specific web page or activity, it even happens when no activity is performed whatsoever (no clicking, scrolling etc).

I've been using another browser (Opera) for some time now, and recently switched back to firefox. However, firefox is crashing constantly (I'm counting in excess of 30 crashes over a period of 4 days). It can't (AFAIK) be traced to any specific web page or activity, it even happens when no activity is performed whatsoever (no clicking, scrolling etc).

Chosen solution

Hmm, this solution solved a similar question a while back

Does it still crash in Safe Mode?
You can start Firefox in Safe Mode below:

  • Windows/Mac: Go to Help > Restart with add-ons disabled
  • Linux: Run firefox -safe-mode in the Terminal/Konsole

If it doesn't, then set javascript.options.baselinejit to false in about:config:

  • Navigate to about:config in your Address Bar
  • Press the "I'll be careful, I promise!" button to proceed
  • Search for javascript.options.baselinejit and set it to false by right clicking the pref and selecting Toggle.
  • Restart Firefox and see if it works properly.
Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Google Update
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.30214.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • iTunes Detector Plug-in
  • DivX Plus Web Player version 2.2.0.52
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • DivX VOD Helper Plug-in
  • NPWLPG

Application

  • Firefox 29.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
  • Support URL: http://support.mozilla.com/1/firefox/29.0.1/WINNT/nb-NO/eu/

Extensions

  • Linkury Smartbar 1.1 ({bfa23612-2cab-4150-aea2-89c27ab71c5a})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Default Tab 2.4 (addon@defaulttab.com) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Xmarks 4.2.1 (foxmarks@kei.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2: NVIDIA GeForce GT 640M
  • adapterDeviceID: 0x0166
  • adapterDeviceID2: 0x0fd2
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 2-14-2012
  • driverDate2: 11-11-2013
  • driverVersion: 8.15.10.2653
  • driverVersion2: 9.18.13.3182
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: http://mixidj.delta-search.com/?babsrc=NT_ss&mntrId=56AD9CB70DE718B4&affID=123187&tsp=5014
  • browser.places.smartBookmarksVersion: 6
  • browser.privatebrowsing.autostart: True
  • browser.sessionstore.enabled: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140506152807
  • browser.startup.homepage: https://fronter.uio.no/
  • browser.startup.homepage_override.buildID: 20140506152807
  • browser.startup.homepage_override.mstone: 29.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 29.0.1
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://feed.helperbar.com/?publisher=OC&dpid=OC&co=NO&userid=bfa23612-2cab-4150-aea2-89c27ab71c5a&affid=111583&searchtype=ds&babsrc=lnkry&installDate=01/01/1970&q=
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1400513391
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.cookies: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1400152363

Misc

  • User JS: Yes
  • Accessibility: No

Helpful Reply

Latest crash-ID: https://crash-stats.mozilla.com/report/index/bp-6e3d5bf0-4160-4847-972b-463482140519
Moses
  • Moderator
459 solutions 3607 answers

Chosen Solution

Hmm, this solution solved a similar question a while back

Does it still crash in Safe Mode?
You can start Firefox in Safe Mode below:

  • Windows/Mac: Go to Help > Restart with add-ons disabled
  • Linux: Run firefox -safe-mode in the Terminal/Konsole

If it doesn't, then set javascript.options.baselinejit to false in about:config:

  • Navigate to about:config in your Address Bar
  • Press the "I'll be careful, I promise!" button to proceed
  • Search for javascript.options.baselinejit and set it to false by right clicking the pref and selecting Toggle.
  • Restart Firefox and see if it works properly.
Hmm, this solution solved a similar question a while back Does it still crash in Safe Mode?<br> You can start Firefox in Safe Mode below: *'''Windows/Mac''': Go to Help > Restart with add-ons disabled *'''Linux''': Run ''firefox -safe-mode'' in the Terminal/Konsole If it doesn't, then set '''javascript.options.baselinejit''' to false in about:config: *Navigate to '''about:config''' in your Address Bar *Press the "I'll be careful, I promise!" button to proceed *Search for '''javascript.options.baselinejit''' and set it to false by right clicking the pref and selecting Toggle. *Restart Firefox and see if it works properly.

Question owner

That seems to have done the trick - so far no new crashes. Thanks!

That seems to have done the trick - so far no new crashes. Thanks!

Question owner

Unfortunately, the solution turned out to be merely temporary. Crashes have returned, gradually increasing in frequency (with 10 crashes so far today) Latest crash reports: https://crash-stats.mozilla.com/report/index/bp-9ce11f44-53e5-4e5b-8d24-444a82140530 https://crash-stats.mozilla.com/report/index/bp-4f853bef-a467-421f-b200-5aa2e2140530 https://crash-stats.mozilla.com/report/index/bp-24843b24-7d08-4ab1-8c13-204082140530 https://crash-stats.mozilla.com/about/throttling https://crash-stats.mozilla.com/report/index/bp-e8274262-219f-4711-8e85-560622140530 https://crash-stats.mozilla.com/report/index/bp-2ba874e6-ca77-490e-aa31-39e152140530 https://crash-stats.mozilla.com/report/index/bp-21dc620e-59aa-4084-a823-80a9a2140530 https://crash-stats.mozilla.com/report/index/bp-a9aebf9c-acf2-47ec-b0d5-449102140530 https://crash-stats.mozilla.com/report/index/bp-603cd787-208a-4c23-95b0-db5822140530 https://crash-stats.mozilla.com/report/index/bp-ac705fb4-f382-4957-bbe0-141b52140530 https://crash-stats.mozilla.com/report/index/bp-677b2c3c-2160-4959-a005-62f6a2140530 https://crash-stats.mozilla.com/report/index/bp-a8f5a9c1-6ddc-40d0-b21d-812c42140530
Moses
  • Moderator
459 solutions 3607 answers

Your crashes are all over the place. I can't pinpoint an exact cause for the crashes. Since this is a solved thread, you need to create a new thread since your crashes are not the same as in your original post. Please create a new thread using the /questions/new link. Thanks!

Your crashes are all over the place. I can't pinpoint an exact cause for the crashes. Since this is a solved thread, you need to create a new thread since your crashes are not the same as in your original post. Please create a new thread using the [/questions/new] link. Thanks!
guigs 1072 solutions 11697 answers

Your most recent crash bug still needs the steps to reproduce thIs: I will add this thread to the bug, but if you have any other information on how this crash is reproduced please comment on the bug.

https://bugzilla.mozilla.org/show_bug.cgi?id=1014554

Your most recent crash bug still needs the steps to reproduce thIs: I will add this thread to the bug, but if you have any other information on how this crash is reproduced please comment on the bug. [https://bugzilla.mozilla.org/show_bug.cgi?id=1014554]
Moses
  • Moderator
459 solutions 3607 answers

guigs2:

The user has created a new thread with newer crash reports. The newer reports look somewhat promising.

<i>guigs2:</i> The user has created a new thread with newer crash reports. The newer reports look somewhat promising. *https://support.mozilla.org/en-US/questions/1003884