Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

How to avoid leaving a gap when closing tabs on Firefox 5?

  • 6 απαντήσεις
  • 20 έχουν αυτό το πρόβλημα
  • 12 προβολές
  • Τελευταία απάντηση από jami48

more options

Hello,

I want to disable a new feature on Firefox 5. Or, at least, I don't recall it being a feature on Firefox 4.

When I have various tabs open, and close one of them, they go to the left, leaving a gap to the right that will be filled the time I move the mouse somewhere else.

Being graphical:

Starting from this: |¨¨a¨¨||¨¨b¨¨||¨¨c¨¨||¨¨d¨¨||¨¨e¨¨|

I close the last two tabs, first "d", then "e", keeping the mouse over the tabs zone: |¨¨a¨¨||¨¨b¨¨||¨¨c¨¨|_Blank Space_

Then, I move the cursor somewhere else, and then it fills the blank space: |¨¨1¨¨||¨¨2¨¨||¨¨a¨¨||¨¨b¨¨||¨¨c¨¨|

How can I avoid this gap when I close tabs?

Turning browser.tabs.animate to false did nothing.

Thank you very much :)

Hello, I want to disable a new feature on Firefox 5. Or, at least, I don't recall it being a feature on Firefox 4. When I have various tabs open, and close one of them, they go to the left, leaving a gap to the right that will be filled the time I move the mouse somewhere else. Being graphical: Starting from this: |¨¨a¨¨||¨¨b¨¨||¨¨c¨¨||¨¨d¨¨||¨¨e¨¨| I close the last two tabs, first "d", then "e", keeping the mouse over the tabs zone: |¨¨a¨¨||¨¨b¨¨||¨¨c¨¨|_Blank Space_ Then, I move the cursor somewhere else, and then it fills the blank space: |¨¨1¨¨||¨¨2¨¨||¨¨a¨¨||¨¨b¨¨||¨¨c¨¨| How can I avoid this gap when I close tabs? Turning browser.tabs.animate to false did nothing. Thank you very much :)

Όλες οι απαντήσεις (6)

more options

Sorry, I don't see a pref for controlling that new feature in Firefox 5.0.

more options

Well, at least it looks like I was able to explain my issue in an understandable way. Thank you anyway.

I hope there is a way (Now, or in a future version) that let me disable this behaviour. I really miss the ability to close multiple tabs with a few clicks, and don't having to move the mouse somewhere else to make room for the older tabs.

Is there any way to ask for a way to add a way to disable this to the Firefox team?

more options

See if the TabMix Plus extension includes a feature for that.

http://tmp.garyr.net/forum/

more options

That feature was added to make it possible to close multiple tabs without having them changing the width if there are more tabs than fit and you have the scroll buttons visible. In that case you can't easily click a close button on a tab in the middle and close more than one in a sequence and you may have to adjust the position for closing the next tab because the width keeps changing.

  • Bug 465086 - When closing a tab, other tabs should not resize until cursor leaves toolbar region

(please do not comment in bug reports)

more options

Cor-el, when we close the tabs, there's an animation where the remaining tabs grow into the vacated space. I have browser.tabs.animate switched off and would, as a result, have expected the tabs to instantaneously resize, instead of doing an animation that slows things down slightly and which I thought I'd turned off.

more options

Well, instantaneously resize after the cursor is moved out of the tab area anyway - I agree with the reasoning in Bug 465086, but the animation still shouldn't be able to override user preferences like that.