X
Πατήστε εδώ για μετάβαση στην έκδοση της ιστοσελίδας για κινητές συσκευές.

Φόρουμ υποστήριξης

unchecking "Allow pages to choose their own fonts, instead of your selections above" has no effect

Δημοσιεύτηκε

MSI GE72 2QF Apache Pro notebook (stock) Windows 10 Pro Firefox 63.0.3

I recently reinstalled Windows 10 and Firefox. Before the reinstall, unchecking this box had an immediate visible effect. Now, as can be seen in the screenshot, it doesn't.

So far I've tried: - "refreshing" Firefox to defaults and unchecking the box again, - going into "about:config" and changing the value of "browser.display.use_document_fonts" to "0"

Neither of these things worked.

On my other two computers, one of which was bought new less than three weeks ago, unchecking the box does what it's supposed to do.

MSI GE72 2QF Apache Pro notebook (stock) Windows 10 Pro Firefox 63.0.3 I recently reinstalled Windows 10 and Firefox. Before the reinstall, unchecking this box had an immediate visible effect. Now, as can be seen in the screenshot, it doesn't. So far I've tried: - "refreshing" Firefox to defaults and unchecking the box again, - going into "about:config" and changing the value of "browser.display.use_document_fonts" to "0" Neither of these things worked. On my other two computers, one of which was bought new less than three weeks ago, unchecking the box does what it's supposed to do.
Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

Toggling this font setting won't have effect if a web page doesn't set its own font(s) because then the default font is used. You should see effect on pages that use a special icon font for some images.

Ανάγνωση απάντησης σε πλαίσιο 0

Επιπρόσθετες λεπτομέρειες συστήματος

Εφαρμογή

  • Πλατφόρμα χρήστη: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0

Περισσότερες πληροφορίες

cor-el
  • Top 10 Contributor
  • Moderator
17578 λύσεις 159013 απαντήσεις
Δημοσιεύτηκε

How does the browser.display.use_document_fonts pref show on the about:config page?

You can check for problems with preferences.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

How does the browser.display.use_document_fonts pref show on the <b>about:config</b> page? You can check for problems with preferences. *delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases *http://kb.mozillazine.org/preferences_not_saved *http://kb.mozillazine.org/resetting_preferences You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

browser.display.use_document_fonts has a value of '0'

There is no user.js file and no numbered prefsXX.js files.

I renamed prefs.js to prefs.js.backup, then went into Options and unchecked that checkbox again, but still no luck.

Good tip for getting to the profile folder. Thanks.

I read through both articles, but didn't find an answer. One thing I just thought to try is dig up the backup copy of my profile and copy the prefs.js from there into my profile folder. That's what I'll be trying next.

browser.display.use_document_fonts has a value of '0' There is no user.js file and no numbered prefsXX.js files. I renamed prefs.js to prefs.js.backup, then went into Options and unchecked that checkbox again, but still no luck. Good tip for getting to the profile folder. Thanks. I read through both articles, but didn't find an answer. One thing I just thought to try is dig up the backup copy of my profile and copy the prefs.js from there into my profile folder. That's what I'll be trying next.
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Follow up: Nope, recopying my old prefs.js file didn't work. After doing so, I started Firefox, but it refused to bring up any web page. (I tried several, including Facebook, gMail, and YouTube.)

Any other info I can bring to the discussion?

Follow up: Nope, recopying my old prefs.js file didn't work. After doing so, I started Firefox, but it refused to bring up any web page. (I tried several, including Facebook, gMail, and YouTube.) Any other info I can bring to the discussion?
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

No one else has any insight into this?

No one else has any insight into this?
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

New info: I looked at prefs.js and the setting for display.use_document_fonts is set to '0' which should mean web sites are NOT allowed to pick their own fonts.

So, it's not a preferences problem. Firefox is ignoring this setting. That sounds like a bug.

New info: I looked at prefs.js and the setting for display.use_document_fonts is set to '0' which should mean web sites are NOT allowed to pick their own fonts. So, it's not a preferences problem. Firefox is ignoring this setting. That sounds like a bug.
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

More new info: I disabled all addons and extensions. Still no luck, so I'm gonna say that none of my addons or extensions are causing the problem.

More new info: I disabled all addons and extensions. Still no luck, so I'm gonna say that none of my addons or extensions are causing the problem.
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Still have this problem, even on Linux.

About 25% of sites are affected by turning off "Allow pages to choose their own fonts."

Perhaps this is because so many sites are now using WordPress and/or markdown?

I'd really like to find an answer to this. I'm tired of having to copy/paste anything I need to read into a word processor.

Still have this problem, even on Linux. About 25% of sites are affected by turning off "Allow pages to choose their own fonts." Perhaps this is because so many sites are now using WordPress and/or markdown? I'd really like to find an answer to this. I'm tired of having to copy/paste anything I need to read into a word processor.

Τροποποιήθηκε στις από το χρήστη rontarrant

Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

I just checked about:config and browser.display.use_document_fonts doesn't change when the checkbox is checked or unchecked. It's always 0. Perhaps this is the problem?

I just checked about:config and browser.display.use_document_fonts doesn't change when the checkbox is checked or unchecked. It's always 0. Perhaps this is the problem?
Δημοσιεύτηκε

Ιδιοκτήτης ερώτησης

Ha! I have a workaround.

In Fonts > Advanced, I set sans-serif to a serif font. Now it works, except not in the Firefox Preferences page. Now isn't that odd?

Still, not the expected behaviour. Someone might wanna have a look at this.

Ha! I have a workaround. In Fonts > Advanced, I set sans-serif to a serif font. Now it works, except not in the Firefox Preferences page. Now isn't that odd? Still, not the expected behaviour. Someone might wanna have a look at this.

Τροποποιήθηκε στις από το χρήστη rontarrant

cor-el
  • Top 10 Contributor
  • Moderator
17578 λύσεις 159013 απαντήσεις
Δημοσιεύτηκε

Επιλεγμένη λύση

Toggling this font setting won't have effect if a web page doesn't set its own font(s) because then the default font is used. You should see effect on pages that use a special icon font for some images.

Toggling this font setting won't have effect if a web page doesn't set its own font(s) because then the default font is used. You should see effect on pages that use a special icon font for some images.