Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Firefox 9.0.1 UK seems to say everything is badly spelt, why?

  • 6 wótegrona
  • 2 matej toś ten problem
  • 9 naglědow
  • Slědne wótegrono wót VishyMoghan

more options

Since updating to Firefox 9.0.1 UK the app seems to think that my spelling language should be Greek, as the right click shows Greek as my language! I have set the language to English UK in prefs, and my entire system is English based. No other spell checkers seem to agree with Firefox. On my blog (Wordpress engine, self hosted) every single word is underlined in red by Firefox (this does not happen on any other browser). But even on Facebook where the text boxes normally show instructions Firefox underlines the default live text! Can anyone tell me if they are familiar with this or seen it before?

Thanks VM

Since updating to Firefox 9.0.1 UK the app seems to think that my spelling language should be Greek, as the right click shows Greek as my language! I have set the language to English UK in prefs, and my entire system is English based. No other spell checkers seem to agree with Firefox. On my blog (Wordpress engine, self hosted) every single word is underlined in red by Firefox (this does not happen on any other browser). But even on Facebook where the text boxes normally show instructions Firefox underlines the default live text! Can anyone tell me if they are familiar with this or seen it before? Thanks VM

Wubrane rozwězanje

OK all good. Found the problem. I must have at some point installed a Greek dictionary plug in for Firefox and that was what was over-riding everything else. I just installed the English UK plugin and it's all good now. Thanks for your suggestions.

Toś to wótegrono w konteksće cytaś 👍 0

Wšykne wótegrona (6)

more options

Do you have a dictionary installed and selected?

  • You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Firefox > Preferences > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

See also:

more options

Yes to the first question. I have all my system and individual apps set to UK English, and as I said above none of the others are showing this problem. As for the pref settings all settings are as per your suggestion.

As I say it simply behaves strangely. For example I have global spell checking active yet right here on the Firefox forum it does not check spelling at all. hatel for example just as a random non-word produces no response from the checker.

And then on WP as my example said, it underlines every word in red. Even though my WP sites are all set to English and do not behave strangely in any other browser.

more options

Here I attach an example from Facebook. As you see it simply tells me everything is spelt badly. I just downloaded the US version and it does the same thing. Even though I have not added a Greek dictionary to the browser, when I right click to see the attached dictionaries as US English and Greek... Although I have no Greek dictionary in the browser prefs. See second attachment. Also as you can see from the third attachment there are only English and UK English set in my preferences.

more options

The third screenshot doesn't apply to spell checking.
The languages that you install here are only send to the server as preferred languages to serve websites.
Your second screenshot shows the spell check working on this site with the en-US dictionary.
It that different from what you see on Facebook?

more options

The question is not what all the screens mean. Whee do I get rid of the Greek spelling preference and the fact that Firefox assumes my default spelling is Greek?

It's a huge pain having to right click everything I write and tell the browser that I am not writing in Greek, or indeed US English. I write in UK English spelling and anyway I am British. So I don't understand where Firefox is getting the idea I should be writing in Greek to begin with. Yes I live in Athens but my system is Mac OS X 10.6.8 and no where does the system have Greek as a default setting. I have the Greek keyboard activated since as a graphic designer working in Greece I deal with Greek text. But the system is not a localised one.

I can not find any menu for changing my desired default writing language in Firefox.

more options

Wubrane rozwězanje

OK all good. Found the problem. I must have at some point installed a Greek dictionary plug in for Firefox and that was what was over-riding everything else. I just installed the English UK plugin and it's all good now. Thanks for your suggestions.