Pomoc pśepytaś

Glědajśo se wobšudy pomocy. Njenapominajomy was nigda, telefonowy numer zawołaś, SMS pósłaś abo wósobinske informacije pśeraźiś. Pšosym dajśo suspektnu aktiwitu z pomocu nastajenja „Znjewužywanje k wěsći daś“ k wěsći.

Learn More

Firefox can't save MP3's

  • 3 wótegrona
  • 1 ma toś ten problem
  • 295 naglědow
  • Slědne wótegrono wót oygle

more options

Firefox version 58.0.2 on Ubuntu.

FF always plays MP3 files, it won't save them. In the preferences, for "MP3 Audio" it is set to 'Always ask" yet it always plays. I changed those prefs to "Save File" yet it still continues to play the MP3. So I can't download/save MP3's.

I looked at https://support.mozilla.org/en-US/questions/1152317 , and my settings are

media.play-stand-alone true

Firefox version 58.0.2 on Ubuntu. FF always plays MP3 files, it won't save them. In the preferences, for "MP3 Audio" it is set to 'Always ask" yet it always plays. I changed those prefs to "Save File" yet it still continues to play the MP3. So I can't download/save MP3's. I looked at https://support.mozilla.org/en-US/questions/1152317 , and my settings are media.play-stand-alone true

Wót oygle změnjony

Wubrane rozwězanje

By the way, if you want to keep the default setting, you can:

  • right-click the link to the MP3 > Save Link As... to download the file before loading it
  • right-click the player bar > Save Audio As... to download the file if it already is in the stand-alone player
Toś to wótegrono w konteksće cytaś 👍 1

Wšykne wótegrona (3)

more options

oygle said

FF always plays MP3 files, it won't save them. In the preferences, for "MP3 Audio" it is set to 'Always ask" yet it always plays. I changed those prefs to "Save File" yet it still continues to play the MP3. So I can't download/save MP3's.

Firefox won't consult the instructions for how to handle downloads if the content type is something Firefox can handle itself and the website doesn't force a download (by specifying content-disposition:attachment).

Since you can't control how websites serve MP3 files, the workaround is to set Firefox not to handle direct links to MP3s itself.

I looked at https://support.mozilla.org/en-US/questions/1152317 , and my settings are
media.play-stand-alone    true

Okay, yes, that's the default setting. So when Firefox follows a direct link to a media file it can play, it will load the media into a media player in a tab.

If you want Firefox NOT to do that, then you need to switch that preference to false. Then Firefox should ask you want you want to do with it. Make sense?

In case you found philipp's steps hard to follow, I'll spell them out in more detail:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste alone and pause while the list is filtered

(3) Double-click the media.play-stand-alone preference to switch the value from true to false

(4) Quit/Exit Firefox and start it up again to complete the change (I'm not sure this is essential for this preference, it might have been for the other one)

more options

Wubrane rozwězanje

By the way, if you want to keep the default setting, you can:

  • right-click the link to the MP3 > Save Link As... to download the file before loading it
  • right-click the player bar > Save Audio As... to download the file if it already is in the stand-alone player
more options

I set the 'media.play-stand-alone' to false, then I saw your post (above) about right click, so I tried that, and was able to download the MP3.

Just to test things again, I reset it back to 'true', exited Firefox, and was able to download the MP3

So, in summary, your solution of jscher2000 said

By the way, if you want to keep the default setting, you can:
  • right-click the link to the MP3 > Save Link As... to download the file before loading it
  • right-click the player bar > Save Audio As... to download the file if it already is in the stand-alone player

works fine, thanks very much  :)

Wót oygle změnjony