Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to disable hidpi on FireFox 22

  • 31 Antworten
  • 71 haben dieses Problem
  • 5337 Aufrufe
  • Letzte Antwort von cor-el

more options

I whish to know how to disable hidpi

Alle Antworten (20)

more options

hello, firefox 22 is now respecting the pixel density you've set on a system level in the windows control panel.

if you want to set the text size/pixel density in firefox different from that of your system's settings like it was handled in prior versions, enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named layout.css.devPixelsPerPx. double-click it and change its value to 1.0 (or any other zoom factor that fits your purpose; -1.0 is the default value and will adhere to the system settings).

more options

thank you for your answer. I don't want to be a pain in the ass, but changing the value of layout.css.devPixelsPerPx does not look like it was before the 22 version. I taught that the hidpi could be disabled altogether.

more options

hello, maybe i've also misunderstood your question, could you attach a screenshot that is showing the problem?

more options

There used to be gfx.hidpi.enabled in about:config in previous versions. I guess that's what you are looking for, right? It's gone (in Fx 21 and 22 too).

more options

that is exactly what i am looking for

more options

I have the same problem. That tip with adjusting layout.css.devPixelsPerPx parameter doesn't help with returning the scale I had in v.21 and earlier versions.

more options

It's a mess. Respecting dpi or not, a lot of websites look broken now because they're zoomed in! The user doesn't care why, he just sees it's wrong. No one but developers and Geeks would have a clue why.

Make the activation optional, what is Mozilla thinking? This will backfire...

For everyone who wants to get rid of it in the mean time, go to the Firefox config (about:config) and change the value: layout.css.devPixelsPerPx -1.0 to layout.css.devPixelsPerPx 1.0

Geändert am von netrix

more options

Hi netrix, you wrote:

For everyone who wants to get rid of it in the mean time, go to the Firefox config (about:config) and change the value: layout.css.devPixelsPerPx -1.0 to layout.css.devPixelsPerPx 1.0

I think the best value for a given individual depends on your system font size setting. With 1.0, everything becomes tiny for me, while 1.25 looks right to me and is the same as setting -1.0 since I set 125% font size in Windows.

Edit: I have a new view on this. 1.25 (or -1.0) is correct for the menu/toolbar/tab area, but on a good number of pages the 25% zooming is too high. As far as I know, the scaling factor applies to both. If I lose patience with Ctrl+- to reduce the zoom on those pages that are already large, either I can try to find a compromise number I'm happy with, or I can use an add-on to adjust either the content or the toolbar area.

My latest thinking: https://support.mozilla.org/en-US/questions/963009#answer-448757

Geändert am von jscher2000

more options

Thank you ! That's exactly what i am thinking ! It is a mess, nothing looks like it use to be, the picture are overstretched, the tabs are way to big etc... Changing the layout.css.devPixelsPerPx value does not look like it used to. It makes me want to go back the 21 version of Firefox. Like you said, this should be an option that you can enable or disable altogether. Big turn-off for this 22 version ! Thank you all anyway for the much appreciated answers !!

more options

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Geändert am von cor-el

more options

am also getting this problem whenever am trying to open <links removed by Moderator> tis url but thanx a lot guys the above discussion help me alot

Geändert am von cor-el

more options

the problem with setting up layout.css.devPixelsPerPx is that it actually still doesnt goto the display mode that firefox 21 used, the hidpi icons etc still make everything big, probably some setting to disable this hidpi totally including hidpi icons in menus etc would make it look like firefox 21 or else many are going to leave firefix for chrome or something else because on most screens everything looks to big with broken websites. i myself also have gone back to v21 and disabled auto update till a way to override this new method and stay on old method is available

more options

Exactly what i am thinking ! I will go with chrome if this hidpi does not go away, and i am not alone in this case !

more options

Hi xbipin and jack767cc, so that we can get a better understanding of how Firefox 22 is working on different Windows setups, could you reply with:

  • Windows OS version (e.g., XP, Vista, 7, 8)
  • Windows DPI setting (e.g., 125% text size, or 120ppi)
  • Firefox layout.css.devPixelsPerPx setting (e.g., default of -1.0 or another setting)

My understanding is that the chrome area (menu, toolbar, tabs) should look like other applications at the default setting (-1.0), while the content area should be zoomed exactly as set in your Windows DPI setting. However, if you do not get that, it would be really helpful to get more detail on where it doesn't work that way.


To "unzoom" the content area now, as opposed to waiting for a program update in a few months, you could keep the -1.0 default setting and try one of these extensions:

For example, in the extension, change your global zoom setting to 80% to counteract 125% Windows font size.

Alternately, if you set the Firefox preference to 1.0, you can use this extension to enlarge the chrome area (menu, toolbar, tab):


All feedback on whether these work would be helpful since many users may not be interested in using other browsers or downgrading.

more options

my OS is windows 7 ultimate x64 dpi settings 121% firefox settings -1.0 (tried 1.0 also but the toolbar still seem zoomed, probably because of hidpi icons in bookmarks toolbar items)

more options

SOLUTION FOR FF 22 LOOKING LIKE FF 21 and older:

sample for - If you have set Windows DPI setting to 125%:

1. layout.css.devPixelsPerPx set to 1.25

2. simple calculation (proportion)

100% is 1.25 | x% is 1.0

(1.0*100)/1.25 = 80% <- this is default zoom to set in FF 22 using NoSquint plugin. Results (see attachment): Still keeping Windows DPI setting to 125%, web pages in ff looking normal, ff interface (bars, icons etc) is zoomed by Windows DPI setting like in older versions ff. Sorry for my english.

Geändert am von arczas89

more options

2 xbipin & others

What I found out was the following:

After I changed css.devPixelsPerPx to 1.0 - the content's scale became like it was in v21 & older, but Firefox UI became a mess.

I followed jscher's advice and tried Theme Font & Size Changer extension for zooming UI (tabs, menus, icons). Particularly "Font size" parameter.

Worked for me.

Basically, all you need to do is to find an optimal combination of css.devPixelsPerPx in about:config and Font size in Theme Font & Size Changer extension.

more options

I accidentally set mine to 11 now its extremely huge to where i cant do anything. Hpw can i revert it back?

more options

You can edit the prefs.js file in the Firefox profile folder with a plain text editor like Notepad and remove the line with the layout.css.devPixelsPerPx pref or change the value to 1.0

  • user_pref("layout.css.devPixelsPerPx", "1.0");
  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

The "Application Data" folder in XP/Win2K and the "AppData" folder in Windows Vista and Windows 7 and later versions are hidden folders.

Alternatively you can create a file user.js and place the above posted user_pref() line in the user.js file and start Firefox once to reset the pref.

After having done this and have restarted and closed Firefox you can remove the user.js file because otherwise you can't make changes to this pref that will last.

more options

I've spent lot of time tuning my ff toolbars, bookmarks, text sizes etc.

Now in v22 everything is broken. Neither -1 or 1 is good for me.

Is there a switch I can turn this feature off completely ?

  1. 1
  2. 2