X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.
Ihr Firefox ist nicht aktuell und könnte ein Sicherheitsrisiko darstellen! Firefox aktualisieren

Hilfe-Forum

Does not warn before closing multiple tabs

Veröffentlicht

On version 12 and even now 13, even with "warn me before closing multiple tabs" checked, it does not warn me. I have read about issues with saving data to disk and private browsing. All I want is to be warned before X-ing out of a window with multiple tabs open

Mehr Details zum System

Das passierte

Immer wenn Firefox geöffnet wird

Das begann, als…

as long as I can remember

Installierte Plugins

None

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0

Weitere Informationen

cor-el
  • Top 10 Contributor
  • Moderator
10749 Lösungen 96724 Antworten
Veröffentlicht

You do not get the 'Save & Quit' pop-up dialog if you choose Tools > Options > General > Startup: "When Firefox Starts": "Show my windows and tabs from last time".

If that option is selected then your pages will already be reopened the next time.
To get that pop-up dialog you have to select one of the other choices (Show my home page or Show a blank page).

You can set the warn prefs on the about:config page to true via the right-click context menu or toggle the value with a double left-click.

Veröffentlicht

Hilfreiche Antwort

Hi, my issue has nothing to do with saving tabs for the next time. If I have at least two tabs open, then click on the X to close the window, I do not want the window and tabs to close. I want a warning asking me, "do you want to close this window?"

That feature is not working anymore. It just closes the window without prompting a warning, asking if that is what I really want to do.

ideato
  • Top 25 Contributor
617 Lösungen 4263 Antworten
Veröffentlicht

In About:config find browser.warnOnQuit and double-click on it top make it TRUE.

Do the same with browser.tabs.warnOnClose


thank you

Please mark "Solved" the answer that really solve the problem, to help others with a similar problem.


EDIT cor-el sorry you already suggest, what i suggest, 1 day ago !

where i had my mind ? sorry again

Geändert am von ideato

Veröffentlicht

Fragesteller

Quote: "In About:config find browser.warnOnQuit and double-click on it top make it TRUE. Do the same with browser.tabs.warnOnClose"

Both of these settings were already set to True. This does not help.

Thanks, Jamie

Veröffentlicht

Fragesteller

I checked another machine with Windows 7 professional and the warning box appears before allowing me to close.

On the XP machine, the warning still does not appear. I can have 1,2,5, or more tabs open and if I click on the X to close, they all disappear instantly.

cor-el
  • Top 10 Contributor
  • Moderator
10749 Lösungen 96724 Antworten
Veröffentlicht

Are there any other windows (Library, Download manager) open when this happens?

Veröffentlicht

Fragesteller

No. All I have open or running is a single FireFox window with multiple tabs open.

cor-el
  • Top 10 Contributor
  • Moderator
10749 Lösungen 96724 Antworten
Veröffentlicht

Try to reset the preferences.


Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Veröffentlicht

Fragesteller

Yes! When I reset the preferences, the warning came back. Thank you.

Veröffentlicht

Fragesteller

Update - NOT solved. Sorry. The warning did come back, but as soon as I went to private browsing and asked 'not to be tracked', the warning went away and the windows closed without warning.

So, the warning does not work in private browsing.

Geändert am von kbabin1

blaakso1 0 Lösungen 1 Antworten
Veröffentlicht

I also have this problem when private browsing is selected. I noticed that if two instances of FF 13.0.1 are running the warning about closing multiple tabs is shown. If only one instance is running, no warning about closing multiple tabs is shown. If private browsing is not selected warning shows as expected.

FFmurphy 0 Lösungen 30 Antworten
Veröffentlicht

This exact bug is back in FF17, even if private browsing is not selected.


Update: setting browser.warnOnQuit to true now does the trick and brings browser.tabs.warnOnCloseOtherTabs back to functionality again.

Geändert am von FFmurphy