Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Two problems with Wayland Gnome

  • 3 Antworten
  • 0 haben dieses Problem
  • 28 Aufrufe
  • Letzte Antwort von zeroknight

more options

I discovered two issues with Firefox on my Wayland Gnome. Picture-in-picture windows should be opened with the "always on top" attribute, but in Wayland they are not on top. It's not a big deal to manually set always-on-top. Although I need to remember to do this after the window appears. The second problem is related to selecting multiple tabs. I should be able to detach selected tabs from the window by dragging them from the tab bar. A new window is then created with the selected tabs. This doesn't work in my Wayland. I can detach one tab, but not multiple tabs at once. I can still move multiple tabs from one window to another open window. So, as a workaround, on Wayland I need to open a new window and then move the selected tabs there. Which is inconvenient. I am curious if anyone else noticed these things on Wayland. There might be something wrong with my instance of Wayland.

I discovered two issues with Firefox on my Wayland Gnome. Picture-in-picture windows should be opened with the "always on top" attribute, but in Wayland they are not on top. It's not a big deal to manually set always-on-top. Although I need to remember to do this after the window appears. The second problem is related to selecting multiple tabs. I should be able to detach selected tabs from the window by dragging them from the tab bar. A new window is then created with the selected tabs. This doesn't work in my Wayland. I can detach one tab, but not multiple tabs at once. I can still move multiple tabs from one window to another open window. So, as a workaround, on Wayland I need to open a new window and then move the selected tabs there. Which is inconvenient. I am curious if anyone else noticed these things on Wayland. There might be something wrong with my instance of Wayland.

Ausgewählte Lösung

Install the "PiP on top" GNOME extension.

You can right-click > Move Tabs > Move to New Window.

Diese Antwort im Kontext lesen 👍 1

Alle Antworten (3)

more options

Ausgewählte Lösung

Install the "PiP on top" GNOME extension.

You can right-click > Move Tabs > Move to New Window.

Hilfreich?

more options

Thanks zeroknight for this info! PiP on top is a good solution. However, adding Gnome and browser extensions just to save two extra clicks on each PiP window is too much for me. On Wailand, I manually set "always on top" with just two mouse clicks or a few keystrokes.

The "Move to New Window" command is the much better workaround than I've used. I missed the appearance of the "Move Tabs" option in Firefox. Apparently it is relatively new.

However, I found a much better workaround. Chrome/Chromium don't have two above problems. Both are running under Xwayland. So, I tried Firefox under Xwayland by setting the environment variable MOZ_ENABLE_WAYLAND to a value other than 1. Using Xwayland fixed these issues in Firefox, too. I also didn't notice any other differences between running on Wayland and running on Xwayland. Even running on Xwayland fixed the third issue that I had with Firefox on Wayland, witch was touchpad scrolling. On Wayland, scrolling in Firefox was almost impossible, the touchpad was too sensitive. Xwayland has returned Firefox to normal behavior. So I don't know what I lost by returning to Xweland, but I know what I gained.

Geändert am von YDUBINSKY

Hilfreich?

more options

XWayland runs the application in legacy X11 mode which is not fully supported and does not have Wayland features like video accelerated decoding (VAAPI), touchpad gestures (kinetic scroll, two-finger swipe), vsync, reduced latency, window occlusion, optimal fractional scaling, better security and more.

You can reduce touchpad scroll sensitivity by changing apz.gtk.pangesture.page_delta_mode_multiplier to 0.3 in about:config.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.