Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Firefox v123 Snap on UbuntuStudio 22.04 only works in Safe Mode

  • 2 Antworten
  • 0 haben dieses Problem
  • 3 Aufrufe
  • Letzte Antwort von jonzn4SUSE

more options

UbuntuStudio 22.04 uses the Firefox Snap package by default. The latest automatic update does not display pages correctly in normal mode, but does work correctly on Safe Mode. Snap.io lists only the latest version of Firefox so I was unable to ask snap to revert to the previous release (prior to 5 Mar 24) and by the time I had tried to investigate the previous version was no longer cached. I did not see a way to force a fresh download of firefox from the latest channel on snap.io.

I tried the snap beta channel for v124, but that exhibited the same problems.

I tried adding a symbolic link to colors.css after seeing firefox complaining that it could not be found when started from the command line. That removed the error/warning message but did not clear the problem with normal mode.

I use the en-GB locale extension only. The technical details about my PC are as follows:

  • Operating System: Ubuntu Studio 22.04
  • KDE Plasma Version: 5.24.7
  • KDE Frameworks Version: 5.92.0
  • Qt Version: 5.15.3
  • Kernel Version: 6.5.0-25-lowlatency (64-bit)
  • Graphics Platform: X11
  • Processors: 12 × AMD Ryzen 5 7600 6-Core Processor
  • Memory: 30.5 GiB of RAM
  • Graphics Processor: RAPHAEL_MENDOCINO

I have now downloaded v123 and installed it in my local home directory, and that version is working well. I have removed the firefox channel via snap. It is likely to be a fault in the construction of the snap for v123 that was not present for v122 prior to 5 Mar 24.

UbuntuStudio 22.04 uses the Firefox Snap package by default. The latest automatic update does not display pages correctly in normal mode, but does work correctly on Safe Mode. Snap.io lists only the latest version of Firefox so I was unable to ask snap to revert to the previous release (prior to 5 Mar 24) and by the time I had tried to investigate the previous version was no longer cached. I did not see a way to force a fresh download of firefox from the latest channel on snap.io. I tried the snap beta channel for v124, but that exhibited the same problems. I tried adding a symbolic link to colors.css after seeing firefox complaining that it could not be found when started from the command line. That removed the error/warning message but did not clear the problem with normal mode. I use the en-GB locale extension only. The technical details about my PC are as follows: * Operating System: Ubuntu Studio 22.04 * KDE Plasma Version: 5.24.7 * KDE Frameworks Version: 5.92.0 * Qt Version: 5.15.3 * Kernel Version: 6.5.0-25-lowlatency (64-bit) * Graphics Platform: X11 * Processors: 12 × AMD Ryzen 5 7600 6-Core Processor * Memory: 30.5 GiB of RAM * Graphics Processor: RAPHAEL_MENDOCINO I have now downloaded v123 and installed it in my local home directory, and that version is working well. I have removed the firefox channel via snap. It is likely to be a fault in the construction of the snap for v123 that was not present for v122 prior to 5 Mar 24.

Alle Antworten (2)

more options

If it is of any help, I have attached is a screenshot from the console showing warnings and errors.

Hilfreich?

more options

So your issue is resolved because something went SNAP.  ;-)) I would also suggest you try my openSUSE on a live usb stick. https://download.opensuse.org/tumbleweed/iso/openSUSE-Tumbleweed-KDE-Live-x86_64-Current.iso

If there are no further questions, please mark this issue as resolved and have a nice day.


Operating System: openSUSE Leap 15.6 KDE Plasma Version: 5.27.10 KDE Frameworks Version: 5.114.0 Qt Version: 5.15.12 Kernel Version: 6.4.0-150600.9-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 PRO 6850HS with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP EliteBook 865 16 inch G9 Notebook PC

Geändert am von jonzn4SUSE

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.