Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Cannot install any add-ons or themes: "Download failed. Please check your connection."

  • 10 Antworten
  • 0 haben dieses Problem
  • 45 Aufrufe
  • Letzte Antwort von zeroknight

more options

Hi,

I cannot download & installed any add-ons or themes. After clicking the install button, I always get a red bar saying "Download failed. Please check your connection.". This happens on Firefox, Firefox beta and Firefox nightly.

I did some googling and found similar posts from a few years ago. These seem to suggest I don't have the correct certificate used to verify extension signatures:

I checked my certificates and I don't have anything from "Mozilla Corporation - signingca1.addons.mozilla.org" (there's a screenshot of this cert in the first forum link above), so I think this is indeed the issue? I've attached a screenshot of my cert list where the Mozilla cert should be.

Please note I am on an M3 Pro macbook pro. It's a work laptop and I thought maybe our network settings were interfering with things, but my previous work laptop (Intel) could install add-ons just fine.

Would appreciate some help!

P.S. I found a workaround where I copied over all extension JSON and XPI files from my old laptop. So I am using my previous extensions just fine but still cannot download any new ones. Also I don't have access to my old laptop anymore so can't copy over any new ones.

Hi, I cannot download & installed any add-ons or themes. After clicking the install button, I always get a red bar saying "Download failed. Please check your connection.". This happens on Firefox, Firefox beta and Firefox nightly. I did some googling and found similar posts from a few years ago. These seem to suggest I don't have the correct certificate used to verify extension signatures: * https://support.mozilla.org/en-US/questions/1257997 * https://support.mozilla.org/bm/questions/1258023 I checked my certificates and I don't have anything from "Mozilla Corporation - signingca1.addons.mozilla.org" (there's a screenshot of this cert in the first forum link above), so I think this is indeed the issue? I've attached a screenshot of my cert list where the Mozilla cert should be. Please note I am on an M3 Pro macbook pro. It's a work laptop and I thought maybe our network settings were interfering with things, but my previous work laptop (Intel) could install add-ons just fine. Would appreciate some help! P.S. I found a workaround where I copied over all extension JSON and XPI files from my old laptop. So I am using my previous extensions just fine but still cannot download any new ones. Also I don't have access to my old laptop anymore so can't copy over any new ones.
Angefügte Screenshots

Alle Antworten (10)

more options

If you right-click (or Ctrl+click) the blue button and click Save Link As, can you get a more informative error message? You also could check the Browser Console (Command+Option+J) to see whether there is an error with the CDN redirect or some kind of block.

Hilfreich?

more options

Note that you posted with a Nightly build, does this also happen with the current release?

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works, you can transfer files from a previously used profile to the new profile, but be careful not to copy corrupted files to avoid carrying over problems.

Hilfreich?

more options

jscher2000 - Support Volunteer said

If you right-click (or Ctrl+click) the blue button and click Save Link As, can you get a more informative error message? You also could check the Browser Console (Command+Option+J) to see whether there is an error with the CDN redirect or some kind of block.
  1. "Save Link As" downloads the extension as an xpi file to my Downloads folder, so that seems ok?
  2. On the dev tools network tab, I can only see GET requests to googleanalytics when I click the blue button

Hilfreich?

more options

cor-el said

Note that you posted with a Nightly build, does this also happen with the current release? You can create a new profile as a quick test to see if your current profile is causing the problem. See "Creating a profile": If the new profile works, you can transfer files from a previously used profile to the new profile, but be careful not to copy corrupted files to avoid carrying over problems.

It happens on a brand new profile. I've updated Nightly a couple of times in the past 2 days already.

Hilfreich?

more options

yusufmahtab12 said

jscher2000 - Support Volunteer said

If you right-click (or Ctrl+click) the blue button and click Save Link As, can you get a more informative error message? You also could check the Browser Console (Command+Option+J) to see whether there is an error with the CDN redirect or some kind of block.
  1. "Save Link As" downloads the extension as an xpi file to my Downloads folder, so that seems ok?
  2. On the dev tools network tab, I can only see GET requests to googleanalytics when I click the blue button

Thank you for testing. #1 sounds good. For #2, the retrieval probably won't appear in a given tab's Network list, you would need to enable network logging in the Browser Console (gear icon at the right end of that window's filter bar).

Hilfreich?

more options

yusufmahtab12 said

It's a work laptop

Do you see any active policies if you visit about:policies in the address bar?

Are you able to install the downloaded xpi manually?

Hilfreich?

more options

Hi both, thanks for your help so far. I realised that our company is using Netskope to control traffic on our laptops and addons.mozilla.org (or something similar) wasn't allowlisted. I asked for it to be added but the response was that Firefox has some security issues (I'm not sure what exactly) and it's not a supported browser for us, so unfortunately I'm going to have to use Google Chrome.

I also checked my personal PC and addons can be downloaded there without any issues. It also doesn't have the Mozilla certificate I mentioned in the original post. At this point I'm confident the issue is due to the company's network configuration.

Geändert am von yusufmahtab12

Hilfreich?

more options

Well, that's frustrating!

Hilfreich?

more options

If they do not block or prohibit extensions in Firefox but merely block the Add-ons website, then you can always download the extension elsewhere to a removable USB device and install the extension locally.

Hilfreich?

more options

Did you try manually installing the extension xpi file like I mentioned?

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.