Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Cannot disable session restore

  • 3 Antworten
  • 0 haben dieses Problem
  • 21 Aufrufe
  • Letzte Antwort von zeroknight

more options

Whenever I open Firefox, it opens every tab from my previous session. I don't want this - if I closed the window, it was because I wanted it closed, and I don't need any automated system to re-open everything on the off chance I was wrong. I believe the setting for this is on the General tab, but as you can see in the attached screenshot, it's definitely off, yet the feature won't go away. I also tried changing the config settings, as listed here:

https://askubuntu.com/questions/1285172/firefox-always-restores-windows-and-tabs-after-reboot

, but it had no effect.

How do I stop Firefox opening these tabs without permission?

Whenever I open Firefox, it opens every tab from my previous session. I don't want this - if I closed the window, it was because I wanted it closed, and I don't need any automated system to re-open everything on the off chance I was wrong. I believe the setting for this is on the General tab, but as you can see in the attached screenshot, it's definitely off, yet the feature won't go away. I also tried changing the config settings, as listed here: https://askubuntu.com/questions/1285172/firefox-always-restores-windows-and-tabs-after-reboot , but it had no effect. How do I stop Firefox opening these tabs without permission?
Angefügte Screenshots

Ausgewählte Lösung

I tried a few different methods of closing Firefox, no effect. In the end, I solved it via the suggestions at this link:

https://support.mozilla.org/en-US/questions/1182594

Namely, using About:config to disable a couple more default options.

Anyway, thanks for taking the time to help out.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (3)

more options

This can happen if Firefox doesn't close properly or let Windows close Firefox when you shutdown the computer.

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox Title bar, especially if you have multiple windows or Private Browsing windows open to prevent losing tabs in unnoticed windows.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

See also:

Hilfreich?

more options

Ausgewählte Lösung

I tried a few different methods of closing Firefox, no effect. In the end, I solved it via the suggestions at this link:

https://support.mozilla.org/en-US/questions/1182594

Namely, using About:config to disable a couple more default options.

Anyway, thanks for taking the time to help out.

Hilfreich?

more options

It sounds like Firefox is crashing instead of cleanly closing, you might want to investigate that since it could lead to other issues. Maybe some third-party antivirus or security software is interfering.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.