Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

FF shuts down to update when I’m trying to use it.

  • 1 Antwort
  • 0 haben dieses Problem
  • 20 Aufrufe
  • Letzte Antwort von Terry

more options

This often happens when I’m using it to play music. It’s also restarted when I’m trying to watch a video, read a web page or, once, when I was part way through setting up login details for a new bank account. I want to apply updates when it’s convenient for me, not when Firefox decides to update. So, how do I prevent my activities being interrupted by Firefox update?

I appreciate that it’s important to keep it up to date but I’m not happy when my activities are interrupted because Firefox decides that it needs to update itself. I suppose one approach would be to apply updates every day when I start Firefox however; I often have a specific task in mind when I start it so I really don’t want the distraction of having to update first.

Here’s what I’ve tried so far. None of these have stopped Firefox restarting itself:

On the Settings page: Select “Check for updates but let you choose to install them” Disable “Use a background service to install updates”

Since the above didn’t stop the Firefox restarts, I tried: Select “Automatically install updates (recommended)” with “When Firefox is not running”

In 'about:config' : Set 'app.update.auto', to FALSE. Set ‘app.update.background.interval’ to 31536000 (i.e. 1 year) Set ‘app.update.interval’ to 31536000 (i.e. 1 year)

       Set 'app.update.auto.migrated' to FALSE.

In Windows Registry Editor, set: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox] "DisableAppUpdate"=dword:00000001

Used Win 10 to disable the “Mozilla Maintenance Service”: FF still restarts when I’m trying to use it. Also renamed the updater exe to: "C:\Program Files\Mozilla Firefox\updaterXXX.exe": auto update still runs (and installs a new updater.exe).

This often happens when I’m using it to play music. It’s also restarted when I’m trying to watch a video, read a web page or, once, when I was part way through setting up login details for a new bank account. I want to apply updates when it’s convenient for me, not when Firefox decides to update. So, how do I prevent my activities being interrupted by Firefox update? I appreciate that it’s important to keep it up to date but I’m not happy when my activities are interrupted because Firefox decides that it needs to update itself. I suppose one approach would be to apply updates every day when I start Firefox however; I often have a specific task in mind when I start it so I really don’t want the distraction of having to update first. Here’s what I’ve tried so far. None of these have stopped Firefox restarting itself: On the Settings page: Select “Check for updates but let you choose to install them” Disable “Use a background service to install updates” Since the above didn’t stop the Firefox restarts, I tried: Select “Automatically install updates (recommended)” with “When Firefox is not running” In 'about:config' : Set 'app.update.auto', to FALSE. Set ‘app.update.background.interval’ to 31536000 (i.e. 1 year) Set ‘app.update.interval’ to 31536000 (i.e. 1 year) Set 'app.update.auto.migrated' to FALSE. In Windows Registry Editor, set: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox] "DisableAppUpdate"=dword:00000001 Used Win 10 to disable the “Mozilla Maintenance Service”: FF still restarts when I’m trying to use it. Also renamed the updater exe to: "C:\Program Files\Mozilla Firefox\updaterXXX.exe": auto update still runs (and installs a new updater.exe).

Alle Antworten (1)

more options