Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How to prevent firefox from redirecting to HTTPS

  • 1 Antwort
  • 0 haben dieses Problem
  • 7 Aufrufe
  • Letzte Antwort von cor-el

more options

How do I prevent firefox from redirecting to HTTPS when it can't find the HTTP website I typed into the address bar?

Background (please read) I run a website for my team at work off my local machine. It's just http, because it's local, and I don't need any fancy encryption schemes. I have no domain for it ... me and my users just type the local IP of my machine. Like this: http://10.111.111.11/myapp/login.php

To work from home, I set up a VPN tunnel thru my workplace firewall so I can hit the webserver on my local machine. If I forget to start the VPN tunnel on my remote machine and then try going to my website, I get an error message in firefox:

   Unable to connect
   An error occurred during a connection to 10.111.111.11.
   The site could be temporarily unavailable or too busy. Try again in a few moments.
   If you are unable to load any pages, check your computer’s network connection.
   If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the web.


After receiving this message, Firefox changes the address in the address bar from what I typed to the same thing, only with "https" instead of "http". This drives me insane. How do I force Firefox to preserve what I typed in the address bar EXACTLY as I typed it?

How do I prevent firefox from redirecting to HTTPS when it can't find the HTTP website I typed into the address bar? '''Background (please read)''' I run a website for my team at work off my local machine. It's just http, because it's local, and I don't need any fancy encryption schemes. I have no domain for it ... me and my users just type the local IP of my machine. Like this: http://10.111.111.11/myapp/login.php To work from home, I set up a VPN tunnel thru my workplace firewall so I can hit the webserver on my local machine. If I forget to start the VPN tunnel on my remote machine and then try going to my website, I get an error message in firefox: Unable to connect An error occurred during a connection to 10.111.111.11. The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer’s network connection. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the web. After receiving this message, Firefox changes the address in the address bar from what I typed to the same thing, only with "https" instead of "http". This drives me insane. How do I force Firefox to preserve what I typed in the address bar EXACTLY as I typed it?

Geändert am von the guy with the issue

Alle Antworten (1)

more options

You can try to create a HTTPS-Only Mode of exception for http://10.111.111.11