Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

font corruption? the font called Calibri is showing up as italic in all websites that use calibri. but i dont have calibri installed on my computer. how do i fix this?

  • 8 Antworten
  • 0 haben dieses Problem
  • 79 Aufrufe
  • Letzte Antwort von rachelcenter

more options

font corruption? the font called Calibri is showing up as italic in all websites that use calibri. but i dont have calibri installed on my computer. how do i fix this? in the past, my friend had a similar issue with fonts looking all weird in code on websites and i told her it was font corruption and had to remove a font on the system level which rectified the issue. but in my case, i dont have calibri installed on my computer. so when i go to the outlook website, all the emails are coming in as calibri italic out of nowhere, when i didnt change any font settings. if i go into google docs, and paste some notes and change all the notes to the font called calibri, it shows it as italic. but i dont have italic selected in google docs. how do i fix this in firefox???

font corruption? the font called Calibri is showing up as italic in all websites that use calibri. but i dont have calibri installed on my computer. how do i fix this? in the past, my friend had a similar issue with fonts looking all weird in code on websites and i told her it was font corruption and had to remove a font on the system level which rectified the issue. but in my case, i dont have calibri installed on my computer. so when i go to the outlook website, all the emails are coming in as calibri italic out of nowhere, when i didnt change any font settings. if i go into google docs, and paste some notes and change all the notes to the font called calibri, it shows it as italic. but i dont have italic selected in google docs. how do i fix this in firefox???
Angefügte Screenshots

Ausgewählte Lösung

as my original post stated: "i dont have calibri installed on my computer." So i went and downloaded the 'calibri regular' font to my computer just now, installed the font, and that weirdly fixed the issue.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (8)

more options

the issue is only with firefox because i went to that same google doc in safari and it wasnt italic. safari showed calibri normally without it being in italics

more options

Hmm, if you don't have a font that a page requires, Firefox usually will try to substitute with something else. This can lead to unpredictable results. To check what font Firefox is using, you can right-click (or Ctrl+click) the word and use the "Inspect" item on the menu to open the developer tools panel with the problem text selected in the HTML code diagram. (Note: if the site shows its own menu on right-click, hold the Shift key while right-clicking to bypass that and summon Firefox's menu.) On the right side, use the little triangle to switch to the Fonts pane and Firefox should show what the italic font is.

More info on the Font Inspector: https://firefox-source-docs.mozilla.org/devtools-user/page_inspector/how_to/edit_fonts/index.html

When I searched for how to get Calibri for Mac, I saw a suggestion that if you have a Microsoft Office application installed already, you can install Calibri from the application's fonts folders by installing the Calibri file into FontBook. Otherwise... hmm.

more options
  • "To check what font Firefox is using" before i even bother checking, i can tell you right now its taking "calibri" and substituting it with the italic version of it
  • "if you don't have a font that a page requires" <- i've never had the font Calibri and its never been an issue.
  • "Microsoft Office application installed already," i dont have it installed. I just use the web browser to access office.

the issue is clearly with firefox because i dont have this issue when i use safari and navigate to google docs and attempt to use the calibri font.

Geändert am von rachelcenter

more options

"no compatibility issues found"

more options

I don't know why Firefox is able to find Calibri Italic on your system but not regular Calibri. That does not make sense to me.

You can restrict the local fonts Firefox uses to a more standard set for your OS. Not sure whether this will make a difference but you can give it a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste layout.css.font-visibility and pause while the list is filtered

Firefox should display four preferences:

  • layout.css.font-visibility.private
  • layout.css.font-visibility.resistFingerprinting
  • layout.css.font-visibility.standard
  • layout.css.font-visibility.trackingprotection

(3) To prevent Firefox from using optional local fonts, double-click each preference that has a value of 3 and reduce the value to 2 then press Return or click the blue check mark button to save the change.

Any difference?

This is what the different values mean in case you want to experiment further:

  • 1 => Only use base system fonts
  • 2 => Use base system fonts plus fonts installed by optional Firefox language packs
  • 3 => Use all available fonts

To reset any preference to its default value, click the leftward-arching arrow button at the far end of the row for that preference.

more options

I'm not going to restrict firefox from using any fonts. That's opening a whole can of worms, and that's taking me in a way different direction then i want to go. restricting fonts doesn't really address the issue of why calibri is all of a sudden defaulting to italics and refusing to show me the normal non-italic version of it.

more options

Where is the italic Calibri file installed? When I compare the Windows fonts folder, I find these files:

Regular: CALIBRI.TTF Bold: CALIBRIB.TTF Italic: CALIBRII.TTF (double i) Bold Italic: CALIBRIZ.TTF Light: CALIBRIL.TTF Light Italic: CALIBRILI.TTF

How many of those do you find?

more options

Ausgewählte Lösung

as my original post stated: "i dont have calibri installed on my computer." So i went and downloaded the 'calibri regular' font to my computer just now, installed the font, and that weirdly fixed the issue.