Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Since update to 103.0.1, Mail opens links in a new FF window with a virgin profile.

more options

Before I updated to FF 103.0.1, links I clicked on in e-mails in Outlook would open in an FF window using my existing default profile. Since updating to FF 103.0.1, these links open in an FF window with a virgin profile. If no such window was already open (from clicking on another e-mail link) this will be a new FF window, even if FF was already open with my normal profile. As a result, e-mail links to PDFs open the files directly in FF (instead of asking me where to download them to, as I have configured in my profile) and I am missing my stored passwords when the links lead to websites that require login.

This is a real PITA! Is there anything I can do other than revert to an earlier FF version? Please help!

I am running Windows 10 2021H2.

Before I updated to FF 103.0.1, links I clicked on in e-mails in Outlook would open in an FF window using my existing default profile. Since updating to FF 103.0.1, these links open in an FF window with a virgin profile. If no such window was already open (from clicking on another e-mail link) this will be a new FF window, even if FF was already open with my normal profile. As a result, e-mail links to PDFs open the files directly in FF (instead of asking me where to download them to, as I have configured in my profile) and I am missing my stored passwords when the links lead to websites that require login. This is a real PITA! Is there anything I can do other than revert to an earlier FF version? Please help! I am running Windows 10 2021H2.

Ausgewählte Lösung

The problem wasn't quite what you described, but your answer helped me to find a solution. When I started FF normally, it still used my original profile as expected. The "virgin" profile was only used when I started FF from an e-mail link. So I started FF from an e-mail link, went into about:profiles and set my original profile as default there, instead of the selected "virgin" profile, "arzcqggl.default-release-1". After closing FF, e-mail links now also open in my original FF profile. This still smells like a bug to me, but I am happy to have found a workaround. Thanks for your help.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (7)

more options

Hi rsbrux, It sounds like a new Profile was created and set as the Default.

Launch your "normal" Firefox. Enter about:profiles in the address bar and press Enter. You should see at least two Profiles listed and one which says "This is the Profile in use and it cannot be deleted" Below that one, select "Set as default profile"

Your "virgin" Profile won't interfere with anything and you can leave it if you like. It might even be a good idea to leave it available for troubleshooting later.

Try a link and see how it works.

Hilfreich?

more options

Ausgewählte Lösung

The problem wasn't quite what you described, but your answer helped me to find a solution. When I started FF normally, it still used my original profile as expected. The "virgin" profile was only used when I started FF from an e-mail link. So I started FF from an e-mail link, went into about:profiles and set my original profile as default there, instead of the selected "virgin" profile, "arzcqggl.default-release-1". After closing FF, e-mail links now also open in my original FF profile. This still smells like a bug to me, but I am happy to have found a workaround. Thanks for your help.

Hilfreich?

more options

When a new Profile is created it is set as the Default automatically and most people don't notice it.


Please mark your answer as the solution so that others can find it easier.

Happy Surfing!

Hilfreich?

more options

@RobertJ, As I mentioned before, when I started FF normally, it still showed my normal profile as the default. How I could have a different default profile when opening FF from an e-mail link is a mystery to me. Nothing of this sort has ever happened to me before, and I have been using FF for decades. If FF is suddenly creating a new profile for an update installation, then this is a bug! It is bad enough that the option to reset everything is enabled by default when one installs an update manually!

Hilfreich?

more options

Could you double-check that you do not have a dual install. Long-time users with Firefox installed under the 32-bit programs path occasionally report that an update created a duplicate installation under the 64-bit program path. I have no idea why that might happen, but it's a good idea to rule that out.

Start Firefox up using your shortcut and open the Troubleshooting Information page. In the first table, check the path of the "Application Binary." Use the Troubleshooting Information page to help fix Firefox issues

Start Firefox up using an external link and repeat and compare. Note that two installations of Firefox may not be able to share the same profile at the same time.

Hilfreich?

more options

@jscher2000, I can assure you that I *do not* have a dual installation. I have a 64 bit Firefox installation. There is a 32 bit "Mozilla Maintenance Service" installed. Even if i had a dual installation, why would it suddenly behave differently after updating to 103.0.1 than it has after the dozens of previous updates I have installed? IAC, I cannot perform the experiment you suggest, because I have already corrected the problem. Please see my post above describing the fix, which I have now marked as the solution.

Hilfreich?

more options

If modifying your default profile setting was the same as removing a duplicate installation, I would not have bothered replying. However, thank you for checking.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.