Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

firefox html overriding adobe pdf files

  • 7 Antworten
  • 1 hat dieses Problem
  • 61 Aufrufe
  • Letzte Antwort von crl4242

more options

Without my doing anything, firefox has decided to download pdf files in its own html. I have changed the default to adobe rather than ask. When I open the downloaded file in adobe it comes down as an adobe file, I tell it to save as an adobe pdf, but it appears in file manager and then opens in firefox html. Worse, it, whatever it is, has gone into file manager and changed adobe pdf files, some of which have been sitting on my hard drive for some years, into firefox html files. How do I rectify this please?

Without my doing anything, firefox has decided to download pdf files in its own html. I have changed the default to adobe rather than ask. When I open the downloaded file in adobe it comes down as an adobe file, I tell it to save as an adobe pdf, but it appears in file manager and then opens in firefox html. Worse, it, whatever it is, has gone into file manager and changed adobe pdf files, some of which have been sitting on my hard drive for some years, into firefox html files. How do I rectify this please?

Alle Antworten (7)

more options

Hi, as I understand, the icon and the filetype description has been unexpectedly changed to "Firefox HTML document", but this is not a pdf conversion. It's still the same intact PDF. Just set the default pdf reader (in OS settings) back to Acrobat and everything will back to normal.

more options

Thank you. I've tried that (windows 10) - it shows adobe is there as default app, but it's still storing in firefox. This means I have to tell it to open the file it in adobe, but that's an extra step I shouldn't be having to make.

more options

Could you double-check your preference for PDF files on the Settings page. This article has the steps: View PDF files in Firefox or choose another viewer.

more options

Does this only work with newly downloaded PDF files? I changed the setting but when I open click on the document it still opens in FIrefox. The extension for this file is Firefox PDF Document (.pdf). Even if I open the document in Adobe and save it as an Adobe PDF it still opens in FIrefox when I click on it.

How can the Firefox Adobe feature be disabled?

more options

ADDENDUM: My existing PDF files have been changed to Firefox PDF. This is most annoying.

more options

crl4242 said

Does this only work with newly downloaded PDF files? I changed the setting but when I open click on the document it still opens in FIrefox. The extension for this file is Firefox PDF Document (.pdf). Even if I open the document in Adobe and save it as an Adobe PDF it still opens in FIrefox when I click on it.

Are you running Windows 10-11? Go to the system search bar (could be on the Taskbar, or Start menu) and enter default apps and click Default apps to call up the system settings panel. Toward the bottom, click Choose apps by file type. Wait for Windows to load this list... patiently... Scroll down to .pdf and click whatever program is shown as the default program for opening .pdf files. Select your preferred program from the list.

Switch over to a regular File Explorer window and see whether that fixed the problem.

more options

Thank you that worked perfectly.