Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Controls in a game, that use the Alt key, aren't working?

more options

On this page with an Atari emulator, I am unable to use its controls that use the Alt key, such as Alt+P to pause.

It works with another browser, or with a fresh profile.

I've tried disabling add-ons and trying it again, but it fails even after disabling each of them. It also doesn't even work in troubleshooting mode, and that seems kinda odd?

It may be some modified settings in my Firefox profile? Though if it is, I don't know what settings, nor how to fix it. What sorts of settings are retained even in troubleshooting mode?

On [https://atarionline.org/atari-2600/space-invaders this page] with an Atari emulator, I am unable to use its controls that use the Alt key, such as Alt+P to pause. It works with another browser, or with a fresh profile. I've tried disabling add-ons and trying it again, but it fails even after disabling each of them. It also doesn't even work in troubleshooting mode, and that seems kinda odd? It may be some modified settings in my Firefox profile? Though if it is, I don't know what settings, nor how to fix it. What sorts of settings are retained even in troubleshooting mode?

Geändert am von Sterrence

Alle Antworten (13)

more options

Is Alt a menu key on Linux like it is on Windows, for example, does Alt+S drop down the History menu from the menu bar?

Hilfreich?

more options

Yes, Alt is a menu key, and Alt+S does drop down the history menu.

Hilfreich?

more options

Does Alt+Shift (Alt+Shift+P) work as that is normally used for access keys on webpages ?

I use a bookmarklet to add access keys to the Preview Reply (p) and Post Reply (s) buttons and use the Alt+Shift modifiers to activate those buttons.

Hilfreich?

more options

You could turn off Alt as a menu key to see whether that helps:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.key.menuAccessKey and pause while the list is filtered

The legal values on Linux and Windows for this preference (according to a note in the source code) are:

  • 0 => none
  • 17 => Ctrl
  • 18 => Alt
  • 91 => Win
  • 224 => Meta

(3) Double-click the preference to display an editing field, and change the value to 0 for testing, then press Enter or click the blue check mark button to save the change.

I think this doesn't take effect until after a browser restart.

Hilfreich?

more options

I've tried hitting the key combination Alt+Shift+P, and I don't see that it is doing anything at all. Not even in Troubleshooting mode.

Setting ui.key.menuAccessKey to 0 has prevented the Alt key from opening the menu. Though Alt+P still isn't working to pause a game in Javatari.

Hilfreich?

more options

Alt+P works for me to toggle between PAUSE and RESUME the game. Alt+Shift+P appears to toggle to "PAUSE with AUDIO ON", so that works as well. If I click in the game to set focus to the player area then Alt and Shift+F10 no longer activate the menu bar, so make sure to click in that area.

Hilfreich?

more options

I've just made extra sure to click in the playfield before trying it again. The key combos that use Alt are still not working.

Hilfreich?

more options

I don't know what impact changing ui.key prefs has for this case where a script seems to override some key sequences, so maybe best is to restore that changes you made asx it works for me with the default settings. Note that there is ui.key.menuAccessKeyFocuses = false to prevent opening/focusing the menu bar if you press the Alt key (pressing a valid combination like Alt+S or Alt+H still opens the menu).

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Hilfreich?

more options

Okay, I'll set the ui.key.menuAccessKey back to default.

I don't think it can be the version of the program that is the problem. As I said in the original post, "It works with another browser, or with a fresh profile." To elaborate, the other browser I tried it in was Chrome, and the fresh profile was in Firefox, with the exact same program installation. It worked fine with both. So it seems like it has to be some setting or another?

I'd like to keep the bulk of my current Firefox profile and settings, but just cut out what's breaking it.

Hilfreich?

more options

Have you customized the keyboard shortcut permission? It should only be necessary for shortcuts that override a built-in Firefox shortcut, but just in case:

While on the site, call up Page Info (for example, Ctrl+i) and click over to the Permissions panel.

If the effective permission on the right side of "Override keyboard shortcuts" is Block, you can uncheck "Use default" and click Allow. (Allow is the default that you would get in a new profile.)

Hilfreich?

more options

It was on default, and seemed to be set on allow by default, but I unchecked it and set the page specifically to allow to be sure. Still not working. :(

Not in that game, but some shortcuts seem to be working, though, like Ctrl+i to open page info, Alt+F4 to close a window, or Alt+q to close the browser, in case that's any use to know.

Geändert am von Sterrence

Hilfreich?

more options

I have tried refreshing Firefox because of sheer desperation with other issues, and I've found a setting is causing problems that really seems like it shouldn't, and I'd like to know how to keep the setting set, without any of this problem.

I have privacy.resistFingerprinting set to true. It's one of the things I setup after the refresh. I want that set to true, but with the game controls actually working right.

Hilfreich?

more options

Oh! That feature is not very well documented, so we don't know all of the things it does. And it seems to be changing over time.

When I look at the source file for reporting keys to websites (https://searchfox.org/mozilla-release/source/dom/events/KeyboardEvent.cpp#36), it looks like when resistFingerprinting is enabled, some keys are not reported honestly, especially the Alt key. That is consistent with your experience and a quick test on my keyboard shortcut test page (https://www.jeffersonscher.com/res/keyvents.html -- image attached)

Since you are familiar with using multiple profiles, what if you use one just for the game so you can keep resistFingerprinting for your other browsing?

In the long run, it is planned to allow site exceptions, but for now, although you can add sites to a list in about:config, it has no effect on the Alt key spoofing (bug 1711619 has more status information on the possible future of this feature).

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.