Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Telefonnummer anzurufen, eine SMS an eine Telefonnummer zu senden oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

"Secure Connection Failed" Persistent Error

  • 4 Antworten
  • 0 haben dieses Problem
  • 59 Aufrufe
  • Letzte Antwort von Anan

more options

I recently installed Firefox 102.0.1 64-bit on a new WinX laptop. Using the same link as always (http://www.henderson.lib.nc.us/) I am unable to connect with my county library. I'm not having trouble with other sites. The error message says

Secure Connection Failed

An error occurred during a connection to www.hendersoncountync.gov. PR_END_OF_FILE_ERROR

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I turned off HTTPS-Only Mode but the problem persisted. I also tried entering this site as an exception for HTTPS-Only but that didn't help. Even after restarting the computer, Firefox continues to reset the URL to HTTPS from HTTP. My wife was able to access this website on her desktop WinX with Firefox and no problem. On my WinX desktop with Firefox I connected to https://www.hendersoncountync.gov/library instantly.

Is the HTTPS-Only Mode sticky? What am I missing?

I recently installed Firefox 102.0.1 64-bit on a new WinX laptop. Using the same link as always (http://www.henderson.lib.nc.us/) I am unable to connect with my county library. I'm not having trouble with other sites. The error message says '''Secure Connection Failed An error occurred during a connection to www.hendersoncountync.gov. PR_END_OF_FILE_ERROR The page you are trying to view cannot be shown because the authenticity of the received data could not be verified. Please contact the website owners to inform them of this problem.''' I turned off HTTPS-Only Mode but the problem persisted. I also tried entering this site as an exception for HTTPS-Only but that didn't help. Even after restarting the computer, Firefox continues to reset the URL to HTTPS from HTTP. My wife was able to access this website on her desktop WinX with Firefox and no problem. On my WinX desktop with Firefox I connected to https://www.hendersoncountync.gov/library instantly. Is the HTTPS-Only Mode sticky? What am I missing?

Geändert am von Anan

Ausgewählte Lösung

jscher2000 -- thanks for your effort, though it didn't fix my problem.

cor-el -- The link you provided proved helpful, especially the following:

2. Refresh Firefox browser:

   Open up your Firefox browser and click on the action button in the top-right section of the screen. Next, from the list of available options, click on Help > Troubleshooting Information.
   Accessing the Troubleshooting Information menu in Firefox
   Once you’re inside the Troubleshooting Information menu, go to the right-hand side section and click on Refresh Firefox (under Give Firefox a tune-up).
   Giving Firefox a tuneup via the Refresh Firefox feature
   At the final confirmation prompt, click on Refresh Firefox once again to start the process. Then wait patiently until the process is complete before restarting the browser.
   Refreshing Firefox
   Repeat the action that was previously causing the problem and see if the same issue is still occurring.

Looks like that fixed it... THANKS!

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (4)

more options

A screenshot would show exactly the error message copied and pasted above.

more options

When my Firefox requests

http://www.henderson.lib.nc.us/

the site returns a Permanent Redirect to

https://www.hendersoncountync.gov/library

So it's time to update your bookmark.

But if you try that address directly (on your laptop) rather than going through the redirect, does it have the same problem?


Just to rule out the potential complication of a system-level proxy server intercept, set Firefox to ignore that. Here's how:

Open the Settings page using either:

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the tiny search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. Set this to "No proxy" and click the OK button at the bottom of the dialog to save it.

Any difference?

more options
more options

Ausgewählte Lösung

jscher2000 -- thanks for your effort, though it didn't fix my problem.

cor-el -- The link you provided proved helpful, especially the following:

2. Refresh Firefox browser:

   Open up your Firefox browser and click on the action button in the top-right section of the screen. Next, from the list of available options, click on Help > Troubleshooting Information.
   Accessing the Troubleshooting Information menu in Firefox
   Once you’re inside the Troubleshooting Information menu, go to the right-hand side section and click on Refresh Firefox (under Give Firefox a tune-up).
   Giving Firefox a tuneup via the Refresh Firefox feature
   At the final confirmation prompt, click on Refresh Firefox once again to start the process. Then wait patiently until the process is complete before restarting the browser.
   Refreshing Firefox
   Repeat the action that was previously causing the problem and see if the same issue is still occurring.

Looks like that fixed it... THANKS!