On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

[LINUX][NON-WINDOWS][ONLY REPRODUCABLE ON LINUX] Sessionstore variables for OS restart don't do anything

  • 7 Antworten
  • 1 hat dieses Problem
  • 24 Aufrufe
  • Letzte Antwort von cor-el

more options

browser.sessionstore.resuming_after_OS_restart = false. My browser still restores on os restart. Startup -> Restore previous windows and tabs is unchecked browser.sessionstore.max_resumed_crashes = 0 browser.sessionstore.restore_on_demand = false browser.sessionstore.resume_from_crash = false

I do not and will not manually close my browser session every time I want to shut down my computer in order to get it to do what it's supposed to. Linux sends SIGTERM to all running processes on shutdown. Firefox isn't handling this correctly, obviously, because if it was, then my settings would be getting respected. SIGTERM is the standard signal sent to windows that need to close gracefully and are expected to still be functional.

NOTE: Do not provide windows-specific support to this thread. I am not running firefox on windows, and I do not possess a windows computer or license.

browser.sessionstore.resuming_after_OS_restart = false. My browser still restores on os restart. Startup -> Restore previous windows and tabs is unchecked browser.sessionstore.max_resumed_crashes = 0 browser.sessionstore.restore_on_demand = false browser.sessionstore.resume_from_crash = false I do not and will not manually close my browser session every time I want to shut down my computer in order to get it to do what it's supposed to. Linux sends SIGTERM to all running processes on shutdown. Firefox isn't handling this correctly, obviously, because if it was, then my settings would be getting respected. SIGTERM is the standard signal sent to windows that need to close gracefully and are expected to still be functional. NOTE: Do not provide windows-specific support to this thread. I am not running firefox on windows, and I do not possess a windows computer or license.

Ausgewählte Lösung

When Firefox is signalled that the OS is shutting down it sets the following preference

browser.sessionstore.resume_session_once => true

(This is the same flag used when you restart Firefox to install an update, at least on Windows.)

That may be more relevant than the preference you're setting, or the one you're setting is overridden in the restart scenario:

https://searchfox.org/mozilla-release/source/browser/components/sessionstore/SessionStore.jsm#2246

Diese Antwort im Kontext lesen 👍 2

Alle Antworten (7)

more options

Firefox might need more time to close properly then Linux allows, especially if you use "Clear history when Firefox closes". So if you are using this feature to clear data when you close Firefox then try to disable it to see if that has effect.

Hilfreich?

more options

cor-el said

Firefox might need more time to close properly then Linux allows, especially if you use "Clear history when Firefox closes". So if you are using this feature to clear data when you close Firefox then try to disable it to see if that has effect.

That setting isn't enabled either. Firefox is usually the first window to close, even faster than my terminal, so questionable whether it's a timing issue.

Hilfreich?

more options

Ausgewählte Lösung

When Firefox is signalled that the OS is shutting down it sets the following preference

browser.sessionstore.resume_session_once => true

(This is the same flag used when you restart Firefox to install an update, at least on Windows.)

That may be more relevant than the preference you're setting, or the one you're setting is overridden in the restart scenario:

https://searchfox.org/mozilla-release/source/browser/components/sessionstore/SessionStore.jsm#2246

Hilfreich?

more options

Oh wow that's obnoxious. That code means that *no matter what the user does* firefox will reload their session on OS restart.

Hilfreich?

more options

Hmm, perhaps it's too soon to give up? If you search for tips on using an autoconfig file to force browser.sessionstore.resume_session_once to false (using the lockpref() function) perhaps you can defeat it. It would be at the cost of never having Firefox restore your session automatically after a restart (i.e., having to restore your session manually from the menu in that case).

Hilfreich?

more options

jscher2000 - Support Volunteer said

Hmm, perhaps it's too soon to give up? If you search for tips on using an autoconfig file to force browser.sessionstore.resume_session_once to false (using the lockpref() function) perhaps you can defeat it. It would be at the cost of never having Firefox restore your session automatically after a restart (i.e., having to restore your session manually from the menu in that case).

What I did was raise an issue over on Bugzilla, and pointed the folx over there towards the problem code in question. This way we can get a proper fix instead of having to do hacky stuff.

Geändert am von ctrentsj

Hilfreich?

more options

For reference:


EDIT: An older bug that might be related:

  • 1754346 - Pages are restored after restart despite settings and about:config tweaks.

Geändert am von cor-el

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.