Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

Insecure password warning in Firefox

  • 10 Antworten
  • 2 haben dieses Problem
  • 7 Aufrufe
  • Letzte Antwort von joemartinello

more options

I have had it with Firefox playing cop. I really have. I have a site that I visit frequently but these past two updates have now broken my ability to sign into the site at all, even in private mode. All I get is the shield and human icons with the strike-through and the error message on the user name/password field that says: This Connection Is Not Secure. Logins Entered Here Could Be Compromised. Learn More.

I've hit the escape button, tried private windows, done everything I can including resetting which was my last resort and which I hate doing, there's no more whitelist, no way to bypass anything, this is totally unacceptable that I cannot get past this. Firefox is becoming more useless to me as they try to become more and more in control of what I can and cannot do. If there is no override to this, then I have to find a different browser because it's pretty useless to use one browser for some sites and another for other sites, don't you think? So if someone has a workaround for this problem, can you please tell me what it is?

I have had it with Firefox playing cop. I really have. I have a site that I visit frequently but these past two updates have now broken my ability to sign into the site at all, even in private mode. All I get is the shield and human icons with the strike-through and the error message on the user name/password field that says: This Connection Is Not Secure. Logins Entered Here Could Be Compromised. Learn More. I've hit the escape button, tried private windows, done everything I can including resetting which was my last resort and which I hate doing, there's no more whitelist, no way to bypass anything, this is totally unacceptable that I cannot get past this. Firefox is becoming more useless to me as they try to become more and more in control of what I can and cannot do. If there is no override to this, then I have to find a different browser because it's pretty useless to use one browser for some sites and another for other sites, don't you think? So if someone has a workaround for this problem, can you please tell me what it is?

Alle Antworten (10)

more options

Is this with all websites/pages, some, a few?

Please provide a public link (no password) that we can check out. No Personal Information Please !


I don't know if this will help. https://support.mozilla.org/en-US/kb/insecure-password-warning-firefox There is a hidden preference to turn off the warning on the login form if it really annoys you and you think it will never be of value. Here's how:

Type about:config<enter> in the address box. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar. Set;

security.insecure_field_warning.contextual.enabled = False security.insecure_password.ui.enabled = False

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

Geändert am von Chris Ilias

more options

So far, that seems to work! FINALLY! It wasn't that the message annoyed me, I couldn't get past it. Didn't matter what I did, nothing worked and I couldn't log in regardless of what I tried to do. And it's happening not on all sites, but a lot of sites. I've only tried it on the one site that prompted me to have my meltdown here so time will tell if it works with them all, but this is great. Thank you.

The site in question is/was celticradio.net. I couldn't sign in anymore to listen to their premium music which I subscribe to thanks to not being able to sign in. But looking at the cert, everything's fine according to FF and just hitting the escape button did nothing but get rid of the warning. I still couldn't log in so thank you again!

yay!

more options

I'm back, I lied. It works on some pages on that site and not on others. On some, it still boots me out when I click a link to go to another page on the site and on others, I don't have any trouble going from page to page. I have to find out what happens on the other sites I'm having trouble with but there isn't time today. I wish they'd just bring back the blanket whitelist and leave it at that. grrrrrrrrrrr

more options

I called for more help.

more options

Thanks! I thought it was all good. Got a private message, tried to send a reply. I was logged in, typed out a lengthy reply, hit send and got an error message that sending messages isn't allowed because I'm not logged into the site. Logged in, was successful, tried again, got the same error message and booted out again. Tried a different message page, typed a very short message this time, hit send and it went right through. I know it's not their site because I'm having no problem at all on other browsers. So I'm at a loss here. And I'm sorry. I know this is probably a small problem in the big scheme of things, but still frustrating.

more options

nightsmusic said

I have a site that I visit frequently but these past two updates have now broken my ability to sign into the site at all, even in private mode. All I get is the shield and human icons with the strike-through and the error message on the user name/password field that says: This Connection Is Not Secure. Logins Entered Here Could Be Compromised. Learn More.

nightsmusic said

The site in question is/was celticradio.net. I couldn't sign in anymore to listen to their premium music which I subscribe to thanks to not being able to sign in. But looking at the cert, everything's fine according to FF and just hitting the escape button did nothing but get rid of the warning. I still couldn't log in so thank you again!

This site has an older design where it prefers insecure (HTTP) connections with you can override that on a case by case basis to an HTTPS connection. Unfortunately, even when you override the address in the address bar, the login form is hard coded to submit insecurely. (See attached screenshot.) If you have Firefox set to use "HTTPS Only" mode, it can fix that, but it doesn't remove the warnings.

That said, the warnings should not prevent you from typing in the form. ??

nightsmusic said

Got a private message, tried to send a reply. I was logged in, typed out a lengthy reply, hit send and got an error message that sending messages isn't allowed because I'm not logged into the site. Logged in, was successful, tried again, got the same error message and booted out again. Tried a different message page, typed a very short message this time, hit send and it went right through.

Login cookies usually do not expire in the time it takes to compose a message, unless the site has a very aggressive inactivity time-out, or you have an add-on that flushes cookies based on inactivity.

Sometimes sites invalidate your session if they detect a change in your IP address. For some sites, this helps:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

Select "No proxy" and use the Save button at the bottom of the panel.

Any difference?

more options

I had to go to Settings and search Proxy. The about:config gave me about 20 proxy settings and I wasn't comfortable with doing anything with those. I chose No Proxy under settings. We'll see what happens.

You said: This site has an older design where it prefers insecure (HTTP) connections with you can override that on a case by case basis to an HTTPS connection. Unfortunately, even when you override the address in the address bar, the login form is hard coded to submit insecurely. (See attached screenshot.) If you have Firefox set to use "HTTPS Only" mode, it can fix that, but it doesn't remove the warnings.

That said, the warnings should not prevent you from typing in the form. ??

I could still type in the form, but still got the error message. It didn't matter that I was able to clear the form. What's odd is, clicking through the site, some pages I'm logged in on and some, I'm not. In order to get to the premium player on the browser and not using the app on my phone, I have to be logged into the site and I'm not always able to do that. Maybe it's on their end, I'd have to ask, but I'll have to wait until after the new year for that. There are some personal things happening now that I don't want to add to their burden with. It's not a small site, but it's got a small admin group that runs it. While that might be what's happening with this site, it has happened elsewhere, it's just easiest to use this site as an example. As to the cookies, I don't delete them when exiting the site, I don't even clear them when I close the browser and they're set to never expire. It's just me on this laptop with my husband using it rarely, usually when he's fat-fingered something on his and in the middle of something that can't wait.

I had no problems with any sites up until two updates ago. That's when things started to break down for me. Maybe I'm the only one, I don't know. It's just frustrating and I'm a person who started computing with zeroes and ones. I'd kind of rather they let me save myself. It would make things easier.

Thanks for the help. I've changed to no proxy so we'll see how it goes. It's just so odd to happen on some pages and not others on the same site.

more options

You can try to close the warning by pressing the ESC (escape) key, that should allow to type in the form.

more options

Yes, as I stated originally, I hit the escape button and the message goes away and I can enter my info but I still can't login. I just keep getting the error message in response.

more options

When I get these messages I switch to Microsoft Edge