Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

updating firefox

  • 20 Antworten
  • 1 hat dieses Problem
  • 25 Aufrufe
  • Letzte Antwort von TyDraniu

more options

If I try to update firefox browser (via "about") my system answers: It is not allowed because of administrator rules.

How can I overcome this barrier?

There is no administrator besides myself.

Ausgewählte Lösung

Please mark this question as Solved.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (20)

more options

Do you remember ever setting up either Windows Group Policy or a policies.json file with Firefox?

If not, what you do you see a policy related to updates on the active section of the about:policies page in Firefox?

The first thing I'd recommend is going to the folder that Firefox is installed in and see if there's a distribution folder in there. If there is, there's probably a file called policies.json in that folder. Rename it to policies.json.old (or something similar) and restart your computer.

If you don't remember ever setting this file up, it's possible that it was installed by some malware on your computer. It's not uncommon for some malware to try and disable updates for your internet browser so that you stay stuck on an unpatched version. See the Troubleshoot Firefox issues caused by malware page for more information on how to address malware issues.

Hope this helps.

Hilfreich?

more options

Hello Wesley,

thanks for your reply. Unfortunately, I am not so fit with program details, so I can not follow your hints. At first, where is the folder that Firefox is installed in? I can see Firefox under "downloads" - it is the exe only, no folder. And Firefox is listed under "programs" - but there is only the possibility to deinstal the program.

Meanwhile I have performed a new installation from Mozilla website - simply by overwriting. Thereafter I am now proceeding version 84.0 instead of 83 before. but even now the limitation is the same: no (automatic) updating...

To overcome this trouble, I would appreciate a step-by-step instruction - for fools.

Regards, Klauser

Hilfreich?

more options

Enter about:policies in the URL bar and check, what's active.

Hilfreich?

more options

Hello Guys, after setting in about:policies I found the infirmation attached. I am still unable to understand what to do. Notice that there is "true" indicated.

Hilfreich?

more options

Now you can check the Firefox folders on your computer to see if you have a policy file in there that's causing the issue.

The easiest way to find the Firefox installation is to right click on the Firefox shortcut on your desktop and select Open file location.

If you don't have a Firefox shortcut on your desktop, you can right click on the Windows menu button in the bottom-left of your screen and select Search. If you type Firefox, it should display the Firefox program in the right-side of the search window with an arrow button to view more options, one of which should be the Open file location option. That will open where a Firefox shortcut is located and you can right click on that shortcut and select Open file location to go to the Firefox installation folder.

You will know when you are at the Firefox installation folder because there will be other folders there called browser and fonts.

In the installation folder, check to see if you have a folder called distribution. If you do, open that folder and see if you have a file called policies.json (Windows may display it as just policies). If you see that file there, delete it.

Close and open Firefox and see if you can update Firefox.

Hilfreich?

more options

Hi Wesley, Thank you anew. Now I followed your latest instruction (hope so). And I could open different windows - see attachment. But nowhere I can see any "distribution" or "policies"... By the way, the firefox.exe on my computer is always opened as by administrator = user as indicated by the properties; so that problem is not to be understood.

Hilfreich?

more options

So it must be in the registry. Open regedit.exe and check HKLM\Software\Policies\Mozilla\Firefox\ and HKCU\Software\Policies\Mozilla\Firefox\.

Hilfreich?

more options

Hi all, I am amazed about your enthusiasm to help me. But also the hint from TyDraniu did not come a step ahead. Look by yourself into my registry (attached) - I can not find HKLM or HKCU...

Hilfreich?

more options

This is it, you've found it. Just remove this DisableAppUpdate entry.

PS. HKEY_LOCAL_MACHINE is HKLM in short.

Geändert am von TyDraniu

Hilfreich?

more options

I am happy for your satisfaction. But as you know, I am not really firm in computer internals. So I have to be sure not to do any wrong thing. Lokk at my screenshot attached. On the left side KHLM is indicated. It is not possible to delete this as complete - the command is grey. But each of the 6 subordinated lines below are possible to delete individually - not grey. And also the ab(standard) line on the right side would be possible to delete - not grey. What will be the correct proceeding?

Hilfreich?

more options
/

On the previous screenshot you have the DisableAppUpdate entry with blue icon. This is to be deleted, not everything.

Hilfreich?

more options

If I start to delete the blue line/icon "ab(standard)" - attachment 1 - a warning occurs because of possible instability of my system - attachment 2. Should I delete it really without any danger?

Hilfreich?

more options

Don't delete it. It will destroy your system.

Hilfreich?

more options

It seems I/we have just prevented catastrophe. So let me double-check, that it will be really really sound to delete that entry - ?!?

Hilfreich?

more options

Yes, this one.

Hilfreich?

more options

Hi TyDraniu, will you give me a GO (= delete!) - or not?

Hilfreich?

more options

Note that you can remove that specific key, but you will still see the message at the top of the Options/Preferences page.

Note that the mere presence of the "Mozilla\Firefox\" key is sufficient to make Firefox display this notification, so if you have the Firefox key then remove it and only leave the Mozilla key or remove this key as well if it is empty.

  • HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\Firefox\ =>
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla\

Hilfreich?

more options

If this key has been added by security software then it is possible that this software re-add this key, so you can keep an eye on this during the coming days.

Hilfreich?

more options

So, my friends all. I did it and it worked - see attachment. Thanks a lot.

Hilfreich?

more options

Ausgewählte Lösung

Please mark this question as Solved.

Hilfreich?

Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.