Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

After upgrade to firefox 71 I can only open links from some applications

  • 2 Antworten
  • 2 haben dieses Problem
  • 29 Aufrufe
  • Letzte Antwort von jmcmeek

more options

I'm on Fedora 31. Firefox was recently upgraded to 71.0 and I find a weird pattern in trying to open links from applications - possibly related to Slack:

If firefox was initially opened following a link from Slack, I can open other links from Slack, but trying to follow links from other applications (IBM Lotus Notes, or running "firefox URL" from a terminal window) fails with a "Firefox is already running" message.

If I open firefox from the desktop applications menu, the reverse happens. I can open links from Notes and a terminal, but following links from Slack fails.

I tried reinstalling firefox and slack with no success. Today I tried going back to an earlier version - firefox-70.0.1-4.fc30.x86_64.rpm - and everything seems to be okay.

It seems like something changed in firefox 71 that doesn't play well with Slack.

Alle Antworten (2)

more options

I found a work-around. Add this to ~/.bashrc, then log in again.


You might also be able to install firefox-x11 and make that the default browser. I have many personal bash scripts that open URLs via 'firefox URL'. I probably ought to be using 'xdg-open URL'.

Until then - or until the issue is fixed - this gets me going.

more options

Better solution:

I found that I had an old ~/.local/share/applications/slack.desktop file that launched Slack using: Exec=env XDG_CURRENT_DESKTOP=Unity /usr/bin/slack %U

Other apps have an environment with XDG_CURRENT_DESKTOP=GNOME, which I believe is correct.

I copied /usr/share/applications/slack.desktop over the .local file. That seems to have fixed it.