Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

filter mail to another folder always shows as read

  • 7 Antworten
  • 1 hat dieses Problem
  • 11 Aufrufe
  • Letzte Antwort von Dennist100

more options

I have a filter set up to reroute incoming email from my inbox to another folder based on the from address or the subject contains a certain string. This works fine. However the email in the target folder is always marked as read, even though it hasn't been read.

The Filter: Getting new mail is checked (filter before Junk) Match any of the following From contains [a string] Subject contains a [a string] From contains [a string] Perform these actions: Move message to [target folder] Mark as unread Forward message to [another email address]

Recap - filter works redirecting the email to the target folder and forwarding a copy. email in target folder is always marked read. This happens with "Mark as unread" in the filter and without it in the filter.

Filter log shows message moved to target folder, email forwarded to [another email address], and message marked as unread.

This IMAP email on a Zimbra server. Thunderbird is v68.1.0 (32 bit). OS is Win 10 Pro x64 Build 17134

I have a filter set up to reroute incoming email from my inbox to another folder based on the from address or the subject contains a certain string. This works fine. However the email in the target folder is always marked as read, even though it hasn't been read. The Filter: Getting new mail is checked (filter before Junk) Match any of the following From contains [a string] Subject contains a [a string] From contains [a string] Perform these actions: Move message to [target folder] Mark as unread Forward message to [another email address] Recap - filter works redirecting the email to the target folder and forwarding a copy. email in target folder is always marked read. This happens with "Mark as unread" in the filter and without it in the filter. Filter log shows message moved to target folder, email forwarded to [another email address], and message marked as unread. This IMAP email on a Zimbra server. Thunderbird is v68.1.0 (32 bit). OS is Win 10 Pro x64 Build 17134

Alle Antworten (7)

more options

I noticed something more - I have another IMAP account with a similar setup - a filter to route incoming email into another folder. This one doesn't forward to another mail address like the one above does though. Emails it forwards do appear in the forwarded to folder as unread.

Setup doesn't appear to be different in any way that would explain why one works properly but the other doesn't.

more options

I was able to work around this bug by adding another filter and modifying the first. The first filter I set it to star the email. I then added a second filter that runs every 10 minutes on the target folder and marks any starred as unread. It is awkward as I have to remember to un star any I read.

I really could use a fix to this bug. Alas, with only 3 views in 3 weeks it is apparent I have little chance of success here.

more options

Unfortunately for you you are using zimbra. They mark mail as read when it is moved via IMAP.

more options

I have emails that are filtered to other folders and those aren't being marked as read. Because of that I don't see how it could be a 100% Zimbra issue.

more options

I've been able to narrow this down to the forwarding of a copy. If it is forwarded it is marked as read. No forwarding then it shows properly as unread.

more options

I would assume: To forward the email, it is opened and attached to a new email to send, so therefore the server marks it as read.

Test: Switch off Thunderbird auto marking as read In Thunderbird 'Menu icon (3 lines) > Options > Options > Display > 'Advanced' tab uncheck 'automatically mark messages as read'


Then see if next forwarded email is marked as read. If it is then the server marked it as read.

more options

Thanks for the feedback. I had Automatically Mark Messages as read checked and set to Immediately on Display. I changed it to After displaying for 1 second and did another test. The message remains marked as unread. This is a good workaround.

However I reported this as a bug. The message was not displayed and should not be marked as read.