X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Suddenly unable to install update with error indicating incompatibility with Windows 64-bit despite running 64-bit Windows...?

Veröffentlicht

So I have a strange one... I'm using Firefox Developer Edition and I'm currently on version 69.0b15 (64-bit). My Windows operating system shows Windows 7 Enterprise 64-bit...

Here's the problem: when I go into "Help" and then click on "About" to apply any available updates from the Aurora channel, I'll click on "Apply Updates" only to see if constantly twirl the little twirly icon around but never finish. The update I'm trying to install is 70.0b5.

If I go into Computer Management / Windows Logs / Application, I can see entries being lodged for the following:

The program or feature "\??\C:\Users\<My User Account>\AppData\Local\Firefox Developer Edition\updater.exe" cannot start or run due to incompatibity with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

Can someone please help me here? I have a Windows 10 system sitting on the same desk right next to this workstation and it updates fine. I've also tried to update using elevated privileges, different compatibility modes (i.e. - running the updater.exe for Windows 7), etc.--nothing seems to fix this that I can tell.

So I have a strange one... I'm using Firefox Developer Edition and I'm currently on version 69.0b15 (64-bit). My Windows operating system shows Windows 7 Enterprise 64-bit... Here's the problem: when I go into "Help" and then click on "About" to apply any available updates from the Aurora channel, I'll click on "Apply Updates" only to see if constantly twirl the little twirly icon around but never finish. The update I'm trying to install is 70.0b5. If I go into Computer Management / Windows Logs / Application, I can see entries being lodged for the following: The program or feature "\??\C:\Users\<My User Account>\AppData\Local\Firefox Developer Edition\updater.exe" cannot start or run due to incompatibity with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available. Can someone please help me here? I have a Windows 10 system sitting on the same desk right next to this workstation and it updates fine. I've also tried to update using elevated privileges, different compatibility modes (i.e. - running the updater.exe for Windows 7), etc.--nothing seems to fix this that I can tell.
Zitieren

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4220 Lösungen 58899 Antworten
Veröffentlicht

Try downloading the full installer of the program. Any better?

Try downloading the full installer of the program. Any better?
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

FredMcD said

Try downloading the full installer of the program. Any better?

That would download the latest, sure, but it wouldn't verify whether or not the downloading + installing of updates from within Firefox is corrected.

''FredMcD [[#answer-1251107|said]]'' <blockquote> Try downloading the full installer of the program. Any better? </blockquote> That would download the latest, sure, but it wouldn't verify whether or not the downloading + installing of updates from within Firefox is corrected.
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.