X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

when I type the number 9, the underscore symbol appears

Veröffentlicht

when I type the number 9, the underscore symbol appears. The underscore symbol also replaces the number 9 in websites: ex: 2019 Season will read 201_ Season

I noticed this a few days ago when I checked the balance on one of my accouts. The number 9 was replaced by an underscore symbol.

I have no idea how or why this suddenly happened.

Help!

when I type the number 9, the underscore symbol appears. The underscore symbol also replaces the number 9 in websites: ex: 2019 Season will read 201_ Season I noticed this a few days ago when I checked the balance on one of my accouts. The number 9 was replaced by an underscore symbol. I have no idea how or why this suddenly happened. Help!
Zitieren

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 32.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:69.0) Gecko/20100101 Firefox/69.0

Weitere Informationen

WMagicModel
  • Top 25 Contributor
  • Administrator
13 Lösungen 195 Antworten
Veröffentlicht

Hi instepdrive,

Does your keyboard still give you the same output for other web browsers or is it just Firefox?

Can you use the 9 key in any other text file?

It's possible that the keyboard layout is configured in a different language.

To check the settings :

  1. Click on the Apple menu and then System Preferences….
  2. Click on Keyboard.
  3. Click on Input Sources tab at the top of the dialog box.
  4. Click on + .
  5. Click on a language.
  6. Click on the keyboard language that matches your own
  7. Click on Add.

You could try booting up in Safe Mode with Firefox to see if the issues go away :

  1. Click the menu '3-bar'.
  2. Click Help (towards the bottom).
  3. Click Restart with Add-ons Disabled....
  4. Click Restart.
  5. When given the choice, click Start in Safe Mode.

You could try to clear your cache in your web browser.

To do this :

1 Click the hamburger 3-bar menu in the top right of your web browser 2 On the left-side panel click Privacy & Security 3 Under Cookies and Site Data

Warning! Clearing all cookies and site data stored by Nightly may sign you out of websites and remove offline web content. Clearing cache data will not affect your logins.

4 Click Clear Data... 5 Check mark Cookies and Site Data 6 Check mark Cached Web Content 7 Click Clear

You also try restarting your Mac in safe mode by holding SHIFT R on reboot to see if it is an issue with the Operating System. To leave Safe Mode just restart again without holding any keys.

Hope this helps narrow it down!

Hi instepdrive, Does your keyboard still give you the same output for other web browsers or is it just Firefox? Can you use the 9 key in any other text file? It's possible that the keyboard layout is configured in a different language. To check the settings : # Click on the '''Apple menu''' and then '''System Preferences….''' # Click on '''Keyboard'''. # Click on '''Input Sources''' tab at the top of the dialog box. # Click on''' +''' . # Click on a '''language'''. # Click on the keyboard language that matches your own # Click on '''Add'''. You could try booting up in '''Safe Mode''' with Firefox to see if the issues go away : # Click the '''menu''' '3-bar'. # Click '''Help''' (towards the bottom). # Click '''Restart with Add-ons Disabled...'''. # Click '''Restart'''. # When given the choice, click '''Start in Safe Mode'''. You could try to clear your cache in your web browser. To do this : 1 Click the hamburger 3-bar '''menu''' in the top right of your web browser 2 On the left-side panel click '''Privacy & Security''' 3 Under Cookies and Site Data '''Warning!''' ''' Clearing all cookies and site data stored by Nightly may sign you out of websites and remove offline web content. Clearing cache data will not affect your logins.''''' 4 Click '''Clear Data...''' 5 Check mark '''Cookies and Site Data''' 6 Check mark '''Cached Web Content ''' 7 Click '''Clear''' You also try restarting your Mac in safe mode by holding SHIFT R on reboot to see if it is an issue with the Operating System. To leave Safe Mode just restart again without holding any keys. Hope this helps narrow it down!
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Correction: the underscore symbol is actually a long dash symbol.

Correction: the underscore symbol is actually a long dash symbol.
Hat Ihnen das weitergeholfen?
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17475 Lösungen 157942 Antworten
Veröffentlicht

Sounds like a problem with the font that is used.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

You can check in Font Book for font issues like corrupted and duplicate fonts.

Sounds like a problem with the font that is used. You can check in the <b>Rules</b> tab in the right panel in the Inspector what font-family is used for selected text. You can check in the <b>Font</b> tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts You can check in Font Book for font issues like corrupted and duplicate fonts.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

Hilfreiche Antwort

instepdrive said

Correction: the underscore symbol is actually a long dash symbol.

Hello instepdrive,

In addition to cor-el's post :

Others have reported that duplicate copies of Helvetica (like Helvetica Regular and Helvetica Bold) caused the problem .....

''instepdrive [[#answer-1250911|said]]'' <blockquote> Correction: the underscore symbol is actually a long dash symbol. </blockquote> Hello instepdrive, In addition to cor-el's post : Others have reported that duplicate copies of Helvetica (like Helvetica Regular and Helvetica Bold) caused the problem .....
Hat Ihnen das weitergeholfen? 1
Zitieren
cor-el
  • Top 10 Contributor
  • Moderator
17475 Lösungen 157942 Antworten
Veröffentlicht

If there are issues with Helvetica fonts then this is usually about the Windows platform where you need to install Helvetica if you want to use it and a lot of these fonts are damaged. On Mac Helvetica is a builtin installed system font and issues shouldn't happen. More likely is a problem with a user installed font that is used by default.

If there are issues with Helvetica fonts then this is usually about the Windows platform where you need to install Helvetica if you want to use it and a lot of these fonts are damaged. On Mac Helvetica is a builtin installed system font and issues shouldn't happen. More likely is a problem with a user installed font that is used by default.
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

^ The "others" I mentioned, were on Windows as well as on Mac ....

Just might be the same font that's causing the problem here - worth checking.

^ The "others" I mentioned, were on Windows as well as on Mac .... Just might be the same font that's causing the problem here - worth checking.
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

Switching from Helvetica to Arial solved the problem with my Xfinity email compositions.

However, the long dash still appears with some websites like this: 201- Women's Soccer Roster

However 2, when I copied 201- Women's Soccer Roster to this reply, it appeared correctly: 2019 Women's Soccer Roster

???

Switching from Helvetica to Arial solved the problem with my Xfinity email compositions. However, the long dash still appears with some websites like this: 201- Women's Soccer Roster However 2, when I copied 201- Women's Soccer Roster to this reply, it appeared correctly: 2019 Women's Soccer Roster ???
Hat Ihnen das weitergeholfen?
Zitieren

Fragesteller

It seems the problem exits only in Firefox. Text Edit and Safari worked correctly.

BTW - my iPhone Xfinity email works correctly using Safari.

Thanks to all of you for your help!

It seems the problem exits only in Firefox. Text Edit and Safari worked correctly. BTW - my iPhone Xfinity email works correctly using Safari. Thanks to all of you for your help!
Hat Ihnen das weitergeholfen?
Zitieren
McCoy
  • Top 10 Contributor
534 Lösungen 5035 Antworten
Veröffentlicht

'Been searching some more and came across a lot of the same reports, on other browsers as well, except for ...... Safari. (same problem is reported on on Linux, not just Mac and Windows)

Helvetica keeps coming up as the culprit, but someone suggested it might be an extension - seems unlikely, but have you tried Safe Mode yet, as suggested by WMagicModel ? Worth a try ....

'Been searching some more and came across a lot of the same reports, on other browsers as well, except for ...... Safari. (same problem is reported on on Linux, not just Mac and Windows) Helvetica keeps coming up as the culprit, but someone suggested it might be an extension - seems unlikely, but have you tried Safe Mode yet, as suggested by WMagicModel ? Worth a try ....
Hat Ihnen das weitergeholfen?
Zitieren
jscher2000
  • Top 10 Contributor
8695 Lösungen 71066 Antworten
Veröffentlicht

instepdrive said

Switching from Helvetica to Arial solved the problem with my Xfinity email compositions. However, the long dash still appears with some websites like this: 201- Women's Soccer Roster

Hi instepdrive, in case you didn't already try this in the past two weeks, how about replacing your other default fonts with TrueType fonts for testing? Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

''instepdrive [[#answer-1250923|said]]'' <blockquote> Switching from Helvetica to Arial solved the problem with my Xfinity email compositions. However, the long dash still appears with some websites like this: 201- Women's Soccer Roster </blockquote> Hi instepdrive, in case you didn't already try this in the past two weeks, how about replacing your ''other'' default fonts with TrueType fonts for testing? Here's how: Open the Preferences page: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the Language and Appearance section, and click the '''Advanced...''' button. This should open the Fonts dialog. (1) Select the '''Latin''' character set Near the top there is a character set selector. Latin is used for pages in English. (2) Change the fonts to basic TrueType fonts Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts. * '''Serif''' - Change from Times or Times Roman (or other serif font) to '''Times New Roman''' * '''Sans-serif''' - Change from Helvetica (or other sans-serif font) to '''Arial''' * '''Monospace''' - Change from Courier (or other fixed-pitch font) to '''Courier New''' (3) Repeat #1 and #2 with the "Other Writing Systems" character set (4) Click OK to save changes Any difference on the problem sites? ''Screenshot for reference:'' <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-27-12-29-36-866df5.png" width="500">
Hat Ihnen das weitergeholfen?
Zitieren
Stellen Sie eine Frage

Sie müssen sich mit Ihrem Benutzerkonto anmelden, um auf Beiträge zu antworten. Bitte stellen Sie eine neue Frage, wenn Sie noch kein Benutzerkonto haben.