X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Unable to read/save passwords on Thunderbird 60.2.1 on Xubuntu

Veröffentlicht

Hello,

After upgrading my Thunderbird install to version 60.2.1 on my Xubuntu 18.04 machine, I cannot access my mail anymore, because there seems to be a problem with passwords.

Symptoms:

- When starting Thunderbird, I get an "Enter your password" box for each of my accounts even though I had my passwords saved.

- When I go to Preferences -> Security -> Passwords -> Saved Passwords, the list is empty.

- When I try to enter a password and save it, it does not actually get saved and Thunderbird will ask again soon after.

- The following line is logged to console a whole bunch of times:

JavaScript error: jar:file:///usr/lib/thunderbird/omni.ja!/components/crypto-SDR.js, line 179: NS_ERROR_FAILURE: Couldn't decrypt string

Other findings:

- Downgrading Thunderbird to 52.7.0 fixes the problem. The old saved passwords just reappear again and Thunderbird has no problem logging in.

- Starting Thunderbird 60.2.1 on a Windows 10 box with exactly the same profile folder works fine. It can read the passwords and access my mail accounts.

Can you please tell me what to do to fix this, so I don't need to keep using an old version of Thunderbird just to access my mail?

Thanks,

Hello, After upgrading my Thunderbird install to version 60.2.1 on my Xubuntu 18.04 machine, I cannot access my mail anymore, because there seems to be a problem with passwords. Symptoms: - When starting Thunderbird, I get an "Enter your password" box for each of my accounts even though I had my passwords saved. - When I go to Preferences -> Security -> Passwords -> Saved Passwords, the list is empty. - When I try to enter a password and save it, it does not actually get saved and Thunderbird will ask again soon after. - The following line is logged to console a whole bunch of times: JavaScript error: jar:file:///usr/lib/thunderbird/omni.ja!/components/crypto-SDR.js, line 179: NS_ERROR_FAILURE: Couldn't decrypt string Other findings: - Downgrading Thunderbird to 52.7.0 fixes the problem. The old saved passwords just reappear again and Thunderbird has no problem logging in. - Starting Thunderbird 60.2.1 on a Windows 10 box with exactly the same profile folder works fine. It can read the passwords and access my mail accounts. Can you please tell me what to do to fix this, so I don't need to keep using an old version of Thunderbird just to access my mail? Thanks,

Geändert am von Carbon_dioxide

Ausgewählte Lösung

sfhowes said

Safe mode disables more than just add-ons. Launch TB in safe mode, check 'Reset toolbars and controls' and click 'Make changes and restart'. If the problem still remains in normal mode, change the hardware acceleration setting in Edit/Preferences/Advanced/General.

I tried both. Neither solved the problem. Hardware acceleration was off, turning it on didn't help and turning it back off afterwards didn't help either.

Clicking through on your link I did find this page: http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird

None of the steps up till "Create a new profile" worked. At that point I decided to not create a completely new profile but to restore an older backup version of the same profile as a new profile instead. For some reason, that worked. It took a little while to sync up everything but now it's working well again.

I still have no clue what actually caused this but at least it has been resolved. Thanks for the help.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0

Weitere Informationen

christ1
  • Top 25 Contributor
2136 Lösungen 15587 Antworten
Veröffentlicht

Did you set a master password? Is one or more of the password prompts you get for the master password?

Did you set a master password? Is one or more of the password prompts you get for the master password?

Fragesteller

I am not using a master password and did not get a prompt for that.

I am not using a master password and did not get a prompt for that.
christ1
  • Top 25 Contributor
2136 Lösungen 15587 Antworten
Veröffentlicht

Are you using the Thunderbird version provided by your distribution or the vanilla version from https://www.thunderbird.net/ ?

Are you using the Thunderbird version provided by your distribution or the vanilla version from https://www.thunderbird.net/ ?

Geändert am von christ1

Fragesteller

I use the version installed through apt.

However, I just tried installing the version from thunderbird.net and I run into the exact same password problem. The only difference is that the error message is not logged to console this time.

I use the version installed through apt. However, I just tried installing the version from thunderbird.net and I run into the exact same password problem. The only difference is that the error message is not logged to console this time.
christ1
  • Top 25 Contributor
2136 Lösungen 15587 Antworten
Veröffentlicht

Try to start Thunderbird in safe mode. https://support.mozilla.org/kb/safe-mode-thunderbird

Does the problem go away?

Try to start Thunderbird in safe mode. https://support.mozilla.org/kb/safe-mode-thunderbird Does the problem go away?

Fragesteller

Yes, the passwords work again in safe mode.

I decided to see if switching off any plugins/extensions in regular mode did anything but I barely got any - a spellchecker dictionary and "Messaging Menu and Unity Launcher integration" which I realize I actually don't need. Anyway, disabling those by hand in regular mode does not solve the problem, but starting Thunderbird in safe mode does.

Yes, the passwords work again in safe mode. I decided to see if switching off any plugins/extensions in regular mode did anything but I barely got any - a spellchecker dictionary and "Messaging Menu and Unity Launcher integration" which I realize I actually don't need. Anyway, disabling those by hand in regular mode does not solve the problem, but starting Thunderbird in safe mode does.
christ1
  • Top 25 Contributor
2136 Lösungen 15587 Antworten
Veröffentlicht
disabling those by hand in regular mode does not solve the problem, but starting Thunderbird in safe mode does.

Did you try that with the Ubuntu version of Thunderbird or the vanilla one?

<blockquote> disabling those by hand in regular mode does not solve the problem, but starting Thunderbird in safe mode does. </blockquote> Did you try that with the Ubuntu version of Thunderbird or the vanilla one?

Fragesteller

Same effect on both.

Same effect on both.
sfhowes
  • Top 10 Contributor
1363 Lösungen 6456 Antworten
Veröffentlicht

Carbon_dioxide said

Yes, the passwords work again in safe mode. I decided to see if switching off any plugins/extensions in regular mode did anything but I barely got any - a spellchecker dictionary and "Messaging Menu and Unity Launcher integration" which I realize I actually don't need. Anyway, disabling those by hand in regular mode does not solve the problem, but starting Thunderbird in safe mode does.

Safe mode disables more than just add-ons. Launch TB in safe mode, check 'Reset toolbars and controls' and click 'Make changes and restart'.

If the problem still remains in normal mode, change the hardware acceleration setting in Edit/Preferences/Advanced/General.

''Carbon_dioxide [[#answer-1165543|said]]'' <blockquote> Yes, the passwords work again in safe mode. I decided to see if switching off any plugins/extensions in regular mode did anything but I barely got any - a spellchecker dictionary and "Messaging Menu and Unity Launcher integration" which I realize I actually don't need. Anyway, disabling those by hand in regular mode does not solve the problem, but starting Thunderbird in safe mode does. </blockquote> [http://kb.mozillazine.org/Safe_mode Safe mode] disables more than just add-ons. Launch TB in safe mode, check 'Reset toolbars and controls' and click 'Make changes and restart'. If the problem still remains in normal mode, change the hardware acceleration setting in Edit/Preferences/Advanced/General.

Ausgewählte Lösung

sfhowes said

Safe mode disables more than just add-ons. Launch TB in safe mode, check 'Reset toolbars and controls' and click 'Make changes and restart'. If the problem still remains in normal mode, change the hardware acceleration setting in Edit/Preferences/Advanced/General.

I tried both. Neither solved the problem. Hardware acceleration was off, turning it on didn't help and turning it back off afterwards didn't help either.

Clicking through on your link I did find this page: http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird

None of the steps up till "Create a new profile" worked. At that point I decided to not create a completely new profile but to restore an older backup version of the same profile as a new profile instead. For some reason, that worked. It took a little while to sync up everything but now it's working well again.

I still have no clue what actually caused this but at least it has been resolved. Thanks for the help.

''sfhowes [[#answer-1165612|said]]'' <blockquote> [http://kb.mozillazine.org/Safe_mode Safe mode] disables more than just add-ons. Launch TB in safe mode, check 'Reset toolbars and controls' and click 'Make changes and restart'. If the problem still remains in normal mode, change the hardware acceleration setting in Edit/Preferences/Advanced/General. </blockquote> I tried both. Neither solved the problem. Hardware acceleration was off, turning it on didn't help and turning it back off afterwards didn't help either. Clicking through on your link I did find this page: http://kb.mozillazine.org/Standard_diagnostic_-_Thunderbird None of the steps up till "Create a new profile" worked. At that point I decided to not create a completely new profile but to restore an older backup version of the same profile as a new profile instead. For some reason, that worked. It took a little while to sync up everything but now it's working well again. I still have no clue what actually caused this but at least it has been resolved. Thanks for the help.