Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How do I re-configure which microphone Firefox uses after saying "remember these settings" the first time?

  • 4 Antworten
  • 2 haben dieses Problem
  • 9604 Aufrufe
  • Letzte Antwort von cor-el

more options

Using Facebook video/voice call: Browser asks me for permission to use video and mic AND gives me dropdowns to configure devices for each. Figuring I probably won't need to configure these settings again, I checked "remember these settings" and hit OK. Started the call - video worked, but microphone did not, even though the device was tested and worked. Now I wanted to go back and look at the settings for which devices to use for video and microphone. My BIG mistake: telling Firefox to remember settings. Oh no!

At this point, I figured the internet would have the answer. I can't find anybody who has mentioned this issue. The question: where do I go to change the video device or microphone device for Firefox AFTER I hit "remember" the first time? Or is hitting "remember" the kiss of death for being able to change these settings in the future? I searched Firefox settings: apparently the only settings relevant to mic/webcam are to allow or disallow those devices. Not what I want. An additional question: does Firefox just go directly to the default devices specified by Windows? Regardless of what I told it the first time? That might explain it. If this is the case, it's a major design flaw that it even asked me which devices to use the first time.

Geändert am von AutoBotAM

Ausgewählte Lösung

In your picture can you see the Circle with a i in next to the padlock ? Click on that, then click on the Arrow that looks like this > Then : More Information, then Permissions you can make some changes there if Microphone is not set up the way you want it. Usually it is allow everything. If you wipe out the cookies for the site that should do it also.

and just to make sure clear the cache while you are there also so it does not pull up a remembered version of the site.

Ah, think I now remembered, after above go down the page to Permissions and you will find Microphone there. Click on it and find the site you gave permissions to and Remove Website, or Remove All Websites.

Please let us know if this solved your issue or if need further assistance.

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (4)

more options

That isn't a FF issue but a driver issue. You need to find out what you have installed for Mic driver.

more options

WestEnd said

That isn't a FF issue but a driver issue. You need to find out what you have installed for Mic driver.

One problem: the microphone works with FB in Google Chrome, as well as Discord, OBS, and all other apps. I suspect it's some issue with Firefox getting confused with default Windows settings. If only there were a way to reconfigure what Firefox uses (or is there even such a custom setting?).

Regardless of drivers, the core issue is that Firefox provided a configurable setting, and then made that setting unavailable to change after checking "remember this". Unless if anyone here knows of an alternative way to access that setting?

Attached a picture, an example of these settings, which show up as long as I don't use Facebook. If I change these on a different site (the device dropdowns) will those settings replicate to all other websites (including Facebook) or just this website?

Geändert am von AutoBotAM

more options

Ausgewählte Lösung

In your picture can you see the Circle with a i in next to the padlock ? Click on that, then click on the Arrow that looks like this > Then : More Information, then Permissions you can make some changes there if Microphone is not set up the way you want it. Usually it is allow everything. If you wipe out the cookies for the site that should do it also.

and just to make sure clear the cache while you are there also so it does not pull up a remembered version of the site.

Ah, think I now remembered, after above go down the page to Permissions and you will find Microphone there. Click on it and find the site you gave permissions to and Remove Website, or Remove All Websites.

Please let us know if this solved your issue or if need further assistance.

more options

See also the Permissions section on the "Options/Preferences -> Privacy & Security" page.