X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

how to set Firefox to open local files with syntax file://

Veröffentlicht

Greetings! addresses like file://server/filename (local files) get opened in IE and Chrome without problem, even Edge does (but very slow). Why Firefox (tested versions 39.0, 41.0.2 änd 42.0) seem to totally ignore these addresses? It doesn't even display an error, just don't do anything. Is there a simple setting to fix that? We have a local html portal (not on web server) with links to local files, and Firefox seems to be the only user's beloved browser that makes problems with this. Hope there is an easy enough way to fix this. Thanks in advance.

Greetings! addresses like file://server/filename (local files) get opened in IE and Chrome without problem, even Edge does (but very slow). Why Firefox (tested versions 39.0, 41.0.2 änd 42.0) seem to totally ignore these addresses? It doesn't even display an error, just don't do anything. Is there a simple setting to fix that? We have a local html portal (not on web server) with links to local files, and Firefox seems to be the only user's beloved browser that makes problems with this. Hope there is an easy enough way to fix this. Thanks in advance.

Ausgewählte Lösung

file:///// try adding those "//"

Diese Antwort im Kontext lesen 2

Mehr Details zum System

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36

Weitere Informationen

guigs 1072 Lösungen 11697 Antworten
Veröffentlicht

Ausgewählte Lösung

file:///// try adding those "//"

file:///// try adding those "//"
Veröffentlicht

Hilfreiche Antwort

guigs said

file:///// try adding those "//"

thanks, that's correct: Firefox wants exactly 5 slashes (/), address with less or more slashes after "file:" is just ignored.

Suggestion: wouldn't it be smart for firefox to just add those 3 missing slashes so that it can open the same links as other browsers, too?

''guigs [[#answer-818386|said]]'' <blockquote> file:///// try adding those "//" </blockquote> thanks, that's correct: Firefox wants exactly 5 slashes (/), address with less or more slashes after "file:" is just ignored. Suggestion: wouldn't it be smart for firefox to just add those 3 missing slashes so that it can open the same links as other browsers, too?
cor-el
  • Top 10 Contributor
  • Moderator
17541 Lösungen 158607 Antworten
Veröffentlicht
See also: *http://kb.mozillazine.org/Links_to_local_pages_do_not_work