Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

How do I troubleshoot calendar crashing?

  • 2 Antworten
  • 4 haben dieses Problem
  • 4174 Aufrufe
  • Letzte Antwort von amandabee

more options

Thunderbird is getting hung up syncing one calendar and it eventually crashes the program or just consumes so much CPU that I have to kill it. It's a google calendar, that worked fine for the last ~month. Here's what happens:

I launch Thunderbird, and it checks email, but when the status bar gets to `synchronizing person@gmail.com event 727 of 1000` it just hangs. It isn't always event 727, but it is always the same user where it hangs. Eventually I get an Unresponsive Script Warning:

> A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete. > Script: chrome://calendar/content/calendar-multiday-view.xml:3513

If I continue, I get the same error with `Script: chrome://calendar/content/calendar-base-view.xml:191`or `calendar-base-view.xml` -- it seems to cycle through them over and over until my whole computer grinds to a halt. If I choose "stop script" Thunderbird just freezes.

I can launch tbird in safe mode, but I'd like to be able to use my calendars again!

Is there any way to get in and disable the offending calendar? Or ... anything I can do?

Ausgewählte Lösung

You can disable the problematic calendar in safe mode in the following way:

  • open config editor https://support.mozilla.org/en-US/kb/config-editor
  • search for "calendar.registry*name"
  • look for the name of problematic calendar in value column and take note of the alphanumeric key it has in preference name column (calendar.registry.key.name)
  • search for "calendar.registry.key"
  • look for "calendar.registry.key.disabled" entry
  • doubleclick it to set it to true
  • restart Thunderbird in normal mode

After this you should have this calendar disabled in Thunderbird and it should not try to sync it any longer.

If the calendar has caching enabled you may want to try to disable caching and reenabling the calendar. If the problem persists you can always disable again after trying this. If problem solves itself you can try reenabling caching.

For the problem itself to get solved you'd need to provide logging and file a bug at bugzilla.mozilla.org

Diese Antwort im Kontext lesen 👍 0

Alle Antworten (2)

more options

Ausgewählte Lösung

You can disable the problematic calendar in safe mode in the following way:

  • open config editor https://support.mozilla.org/en-US/kb/config-editor
  • search for "calendar.registry*name"
  • look for the name of problematic calendar in value column and take note of the alphanumeric key it has in preference name column (calendar.registry.key.name)
  • search for "calendar.registry.key"
  • look for "calendar.registry.key.disabled" entry
  • doubleclick it to set it to true
  • restart Thunderbird in normal mode

After this you should have this calendar disabled in Thunderbird and it should not try to sync it any longer.

If the calendar has caching enabled you may want to try to disable caching and reenabling the calendar. If the problem persists you can always disable again after trying this. If problem solves itself you can try reenabling caching.

For the problem itself to get solved you'd need to provide logging and file a bug at bugzilla.mozilla.org

Geändert am von Merike

more options

Hmmm. I am seeing calendar.registry.{key}.name (and .uri, .color, .cache.version, a bunch of .settings, where {key} is the actual key) but I don't see a anything like "disabled".

But I was able to add a new preference, calendar.registry.{key}.disabled which did work.

Happy to try to log & troubleshoot if that's useful. But now that I know how to manage it I'm good.

Geändert am von amandabee