Hilfe durchsuchen

Vorsicht vor Support-Betrug: Wir fordern Sie niemals auf, eine Nummer anzurufen, sie per SMS zu kontaktieren oder persönliche Daten preiszugeben. Bitte melden Sie verdächtige Aktivitäten über die Funktion „Missbrauch melden“.

Learn More

untrusted connection does not show "This connection is untrusted" dialog

  • 4 Antworten
  • 15 haben dieses Problem
  • 1023 Aufrufe
  • Letzte Antwort von henrybluebottle

more options

In FF39, opening an untrusted connection doesn't show the "This connection is untrusted" dialog, the tab title just says "untrusted connection" and the page is blank. How can i turn on the display of the "This connection is untrusted" dialog so i can get to the page ?

Ausgewählte Lösung

Firefox has a setting to hide error pages and instead show a pop-up dialog (and if the page was directed to a new tab, a blank page). Are you getting that? If so, you may be able to return to normal by changing the setting here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste xul and pause while the list is filtered

(3) If the browser.xul.error_pages.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true.


If that's not it, perhaps Firefox's program files were damaged in the update. For that, I suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement after this reinstall?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Diese Antwort im Kontext lesen 👍 1

Alle Antworten (4)

more options

That's strange. Does this occur on numerous sites or just on a particular site? For example, this URL should give you an error page:

https://www.sothai.com/ (cert is for the wrong domain)

If you only notice this on particular sites, could you post the URL?


Also, could you test in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Diagnose Firefox issues using Troubleshoot Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Yes, your example has the same result, including in safe mode. An empty page and a tab titled "Untrusted Connection" with an alert icon.

more options

Ausgewählte Lösung

Firefox has a setting to hide error pages and instead show a pop-up dialog (and if the page was directed to a new tab, a blank page). Are you getting that? If so, you may be able to return to normal by changing the setting here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste xul and pause while the list is filtered

(3) If the browser.xul.error_pages.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true.


If that's not it, perhaps Firefox's program files were damaged in the update. For that, I suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(1) Download a fresh installer for Firefox 39.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox (if applicable).

(3) Rename the program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Any improvement after this reinstall?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Yes, a clean reinstall has fixed this. Thank you :)