X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox keeps me logged IN until I restart it, even after website log off. Why ?

Veröffentlicht

Hello,

I use Firefox 35.0.1. I set up the options to never keep the cookies.

The issue : I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I go back to the mail page of the webmail, and I am logged in !

Other test : I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I close Firefox. I re open firefox, I go back to the mail page of the webmail, and I have to enter my credentials (that is normal)

Other test : I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I force Firefox to remove the cookies, but I keep Firefox opened. I go back to the mail page of the webmail, and I have to enter my credentials (that is normal)


Other test : I tried to reproduce the issue with another Internet Browser (the "e" one). I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I go back to the mail page of the webmail, and I have to enter my credentials.

So, it seems not to be a webmail configuration, as another browser behaves normally.

Is there something that i have not thought about ?

Thank you for your help

Hello, I use Firefox 35.0.1. I set up the options to never keep the cookies. The issue : I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I go back to the mail page of the webmail, and I am logged in ! Other test : I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I close Firefox. I re open firefox, I go back to the mail page of the webmail, and I have to enter my credentials (that is normal) Other test : I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I force Firefox to remove the cookies, but I keep Firefox opened. I go back to the mail page of the webmail, and I have to enter my credentials (that is normal) Other test : I tried to reproduce the issue with another Internet Browser (the "e" one). I log on an Exchange webmail. I read my emails. I log off from the Exchange webmail. I go back to the mail page of the webmail, and I have to enter my credentials. So, it seems not to be a webmail configuration, as another browser behaves normally. Is there something that i have not thought about ? Thank you for your help

Ausgewählte Lösung

Theses explications and links answers my questions. This is because of the basic pre auth.

Thank you guys for your help.

Have a good day.

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Installierte Plugins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Citrix Online App Detector Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_43 for Mozilla browsers
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • VLC media player Web Plugin 2.0.2
  • VMware Client Support Plug-in
  • VMware Remote Console Plug-in
  • iTunes Detector Plug-in

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4261 Lösungen 59654 Antworten
Veröffentlicht

Hilfreiche Antwort

You may have a corrupt cookies.sqlite file.

Type about:support in the address bar and press enter.

Under the page logo on the left side you will see Application Basics. Under this find Profile Folder. To it’s right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the cookies.sqlite file. Then rename or delete it. Restart Firefox.

You may have a corrupt '''cookies.sqlite''' file. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side you will see '''Application Basics.''' Under this find '''Profile Folder.''' To it’s right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the '''cookies.sqlite''' file. Then rename or delete it. Restart Firefox.
Veröffentlicht

Fragesteller

Hi Fred,

No sure this issue is because the corrupt file. Actually, several people have the same behavior. This occurs on this particular webmail. There is no issue with yahoo mail, gmail or anything else.

Anyway, I have closed Firefox. Renamed the cookies.sqlite Opened Firefox again (I saw a new cookie.sqlite file) Tried to reproduce the issue : And the issue reproduced.

Maybe you have another idea ?

Thank you

Hi Fred, No sure this issue is because the corrupt file. Actually, several people have the same behavior. This occurs on this particular webmail. There is no issue with yahoo mail, gmail or anything else. Anyway, I have closed Firefox. Renamed the cookies.sqlite Opened Firefox again (I saw a new cookie.sqlite file) Tried to reproduce the issue : And the issue reproduced. Maybe you have another idea ? Thank you
FredMcD
  • Top 10 Contributor
4261 Lösungen 59654 Antworten
Veröffentlicht

That is very odd.

I've called the big guys to help you. Good luck.

That is very odd. I've called the big guys to help you. Good luck.
Veröffentlicht

Fragesteller

Hello big guys,

are you here ? :) I still got the issue and have not found any track to follow to resolve it.

Thank you.

Hello big guys, are you here ? :) I still got the issue and have not found any track to follow to resolve it. Thank you.
FredMcD
  • Top 10 Contributor
4261 Lösungen 59654 Antworten
Veröffentlicht

I sent out another message. Please wait a few days. With the new version out, some are having problems.

I sent out another message. Please wait a few days. With the new version out, some are having problems.
guigs 1072 Lösungen 11697 Antworten
Veröffentlicht

FredMcD apologies for the delay. Whiser, Please update to the most recent version of Firefox:

I tested and confirmed that this does not happen in Firefox 36.0.1. The Privacy Options for Custom History, there are three options for keeping cookies: they expire, I close Firefox, ask me everytime.

I have set it to "they expire" and was able to sign in, log out and visit outlook.com in the same session and be asked for credentials. This was the same for I close Firefox. Ask me everytime prompted me 20+ times to just click to sign in and it also asked me for credentials when I logged out.

FredMcD apologies for the delay. Whiser, Please update to the most recent version of Firefox: *[[Update Firefox to the latest version]] I tested and confirmed that this does not happen in Firefox 36.0.1. The Privacy Options for Custom History, there are three options for keeping cookies: they expire, I close Firefox, ask me everytime. I have set it to "they expire" and was able to sign in, log out and visit outlook.com in the same session and be asked for credentials. This was the same for I close Firefox. Ask me everytime prompted me 20+ times to just click to sign in and it also asked me for credentials when I logged out.
Veröffentlicht

Fragesteller

Hum, Strange.

I have updated to version 36.0.1 I got the same issue.

I repeat, to be clear. Maybe i have forgotten to tell you I use a proxy. Exchange Webmail is behind a proxy serveur.

So, I log to my exchange webmail. The proxy asks me for credentials. I put them in the form. I am logged to my exchange webmail. I read my emails.... I clic on "log off" Exchange tells me that I have been logged off but to protect my webmail, I have to close the browser. If i clic on "previous windows" button, or If i return on the webmail main page, I am logged in without credentials.

If I remove the cookies manually using Firefox options, the issue disappear. Of course, If I close Firefox after log off, the cookie is removed and I dont have the issue. Even if I am set up to keep the cookies, as soon as I close Firefox (after log off), I am asked to put my credentials.

That does not happen with outlook.com, gmail, yahoo etc... Only with my Enterprise Webmail.

Actually, normally, Firefox should remove the session cookie as soon as I clic on "Log off". That is the normal behavior and that is how it works usually except, in that case.

Is that an incompatible mix between firefox and my proxy ? Is that a Firefox bug ?

Thank you guys

Hum, Strange. I have updated to version 36.0.1 I got the same issue. I repeat, to be clear. Maybe i have forgotten to tell you I use a proxy. Exchange Webmail is behind a proxy serveur. So, I log to my exchange webmail. The proxy asks me for credentials. I put them in the form. I am logged to my exchange webmail. I read my emails.... I clic on "log off" Exchange tells me that I have been logged off but to protect my webmail, I have to close the browser. If i clic on "previous windows" button, or If i return on the webmail main page, I am logged in without credentials. If I remove the cookies manually using Firefox options, the issue disappear. Of course, If I close Firefox after log off, the cookie is removed and I dont have the issue. Even if I am set up to keep the cookies, as soon as I close Firefox (after log off), I am asked to put my credentials. That does not happen with outlook.com, gmail, yahoo etc... Only with my Enterprise Webmail. Actually, normally, Firefox should remove the session cookie as soon as I clic on "Log off". That is the normal behavior and that is how it works usually except, in that case. Is that an incompatible mix between firefox and my proxy ? Is that a Firefox bug ? Thank you guys
FredMcD
  • Top 10 Contributor
4261 Lösungen 59654 Antworten
Veröffentlicht

Is it possible that the web site is keeping copies of your cookies? Talk to their support.

There are add-ons that may be able to remove these cookies for you. Go to the Mozilla Add-ons Web Page {web link} (There’s a lot of good stuff here) and search for what you want.

Is it possible that the web site is keeping copies of your cookies? Talk to their support. There are add-ons that may be able to remove these cookies for you. Go to the '''[https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page]''' {web link} (There’s a lot of good stuff here) and search for what you want.
Veröffentlicht

Fragesteller

I am the support :) The website does not keep a copy of a cookie. If yes, the issue would occur also with Internet Explorer, and it does not.

As I am the administrator, I try to resolve the issue for all my users, not only for me :)

I am the support :) The website does not keep a copy of a cookie. If yes, the issue would occur also with Internet Explorer, and it does not. As I am the administrator, I try to resolve the issue for all my users, not only for me :)
Veröffentlicht

Fragesteller

Me again :)

I have search again and again.

The issue is not on the cookie side. I have set up a short timeout for the cookies, and i have also deleted the cookies. The issue is still present.

The issue comes from the "Active Connection"

(sorry for menus names, it is translated from my local language) In Firefox, if you go in Settings > Options Privacy Tab Remove all the current history Then you can select all that you want to remove.

When I remove "Active Connections", I have to log in again on my webmail. Each Time I remove "Active Connections" I have to log in again.

So, definetly, the issue comes from that active Connections which are kept in Firefox until i remove them, or Firefox is closed.

On another forum, I have read that this is a "bad practice" done by Mozilla. Is that true or is there something to be set up to avoid that ?

Thank you

Me again :) I have search again and again. The issue is not on the cookie side. I have set up a short timeout for the cookies, and i have also deleted the cookies. The issue is still present. The issue comes from the "Active Connection" (sorry for menus names, it is translated from my local language) In Firefox, if you go in Settings > Options Privacy Tab Remove all the current history Then you can select all that you want to remove. When I remove "Active Connections", I have to log in again on my webmail. Each Time I remove "Active Connections" I have to log in again. So, definetly, the issue comes from that active Connections which are kept in Firefox until i remove them, or Firefox is closed. On another forum, I have read that this is a "bad practice" done by Mozilla. Is that true or is there something to be set up to avoid that ? Thank you
FredMcD
  • Top 10 Contributor
4261 Lösungen 59654 Antworten
Veröffentlicht

I found the option. Why it keeps cookies active, I don't know.

I found the option. Why it keeps cookies active, I don't know.
cor-el
  • Top 10 Contributor
  • Moderator
17540 Lösungen 158598 Antworten
Veröffentlicht

Active Logins is about servers that use basic authentication instead of cookies, so clearing cookies might not work.

Active Logins is about servers that use basic authentication instead of cookies, so clearing cookies might not work. * http://en.wikipedia.org/wiki/Basic_access_authentication
jscher2000
  • Top 10 Contributor
8775 Lösungen 71736 Antworten
Veröffentlicht

Hilfreiche Antwort

My assumption is that you have pre-authentication using basic auth on both your proxy and OWA.

My guess is that OWA properly invalidated your mail session on logout, but when you went back to the page, the proxy started a new session for you using your basic auth credentials passed by Firefox. I guess you would need to compare session cookies to confirm that they changed between log out and the "new"/"continued" session.

This is a longstanding problem with basic auth, but there are workarounds for causing the browser to discard the credentials and stop sending them. For example, these old StackOverflow threads:

My assumption is that you have pre-authentication using basic auth on both your proxy and OWA. My guess is that OWA properly invalidated your mail session on logout, but when you went back to the page, the proxy started a new session for you using your basic auth credentials passed by Firefox. I guess you would need to compare session cookies to confirm that they changed between log out and the "new"/"continued" session. This is a longstanding problem with basic auth, but there are workarounds for causing the browser to discard the credentials and stop sending them. For example, these old StackOverflow threads: * http://stackoverflow.com/questions/233507/how-to-log-out-user-from-web-site-using-basic-authentication * http://stackoverflow.com/questions/2180206/how-to-force-jetty-to-ask-for-credentials-with-basic-authentication-after-invali
Veröffentlicht

Ausgewählte Lösung

Theses explications and links answers my questions. This is because of the basic pre auth.

Thank you guys for your help.

Have a good day.

Theses explications and links answers my questions. This is because of the basic pre auth. Thank you guys for your help. Have a good day.
FredMcD
  • Top 10 Contributor
4261 Lösungen 59654 Antworten
Veröffentlicht

Good to hear, Safe surfing.

Good to hear, Safe surfing.