X
Tryk her for at gå til webstedets mobilversion.
Din Firefox er forældet og kan indeholde en sikkerhedsrisiko! Opgrader Firefox

Supportforum

Javascript menus don't work.

Skrevet

I'm having some trouble with javascript menus (or what I believe are javascript menus). Whether it matters or not I am not sure, but it happens in both Firefox and Chrome...IE works fine.

Examples of sites with menus that don't work:

1. Orbitz.com: Can't pull down the "Adult" or "Child" menus. 2. toyota.com: Can't "select vehicle" at the top of the page.

I get no error messages. I have started Firefox in safe mode, I have also reset Firefox.

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 11.8 r800
  • Google Update
  • GEPlugin
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • iTunes Detector Plug-in
  • Nitro PDF plugin for Firefox and Chrome
  • Garmin Communicator Plug-In 4.0.4.0
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Program

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support-URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Udvidelser

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Chrome View 0.2.2 (chromeview@systemantics.net)
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • IE View 1.5.6 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • InvisibleHand 3.8.28 (canitbecheaper@trafficbroker.co.uk)
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 630M
  • adapterDescription2:
  • adapterDeviceID: 0x0de9
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2047
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 8-18-2012
  • driverDate2:
  • driverVersion: 9.18.13.593
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 630M)
  • windowLayerManagerType: Direct3D 10

Ændrede indstillinger

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 0
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.warnOnClose: False
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: True
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379028798
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378554434

Diverse

  • User JS: Nej
  • Tilgængelighed: Ja
Luk
cor-el
  • Top 10 Contributor
  • Moderator
10761 løsninger 96861 svar

Works here.
The orbitz.com page is using a clickable span and a div with a sprite for the arrow to open a select when clicked.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Also make sure that your security software isn't blocking JavaScript.

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Spørgsmålsstiller

Launching firefox in safe mode fixed orbitz.com....But toyota.com still doesn't work. I also launched Windows in Safe Mode with Networking to no avail.

I don't have any particular security software besides Microsoft's Security Essentials and I have completely disabled it.

jscher2000
  • Top 10 Contributor
2368 løsninger 20957 svar

The Toyota selector is very cool, you have to see it.

Do you have a touch screen and, if so, does the selector work if you touch it?

To disable touch events on websites, check out this thread: When trying to click on menus on USAA, it shows "javascript:;" in the bottom left hand corner and the menu won't work in FF 21.

Nyttigt svar

I do have a touch screen. Can't believe that matters!

I toggled both of these settings to:

dom.w3c_touch_events.enabled = 0 dom.w3c_touch_events.expose = false

However the selector still does not work. I don't get a "javascript;;" message.

This occurs both in Safe Mode and standard mode.

jscher2000
  • Top 10 Contributor
2368 løsninger 20957 svar

Do other scripts work on the page? For example, the preview previous and next buttons for the "slideshow" at the left and right sides of the huge photos on the home page?

Ændret af jscher2000 den

Spørgsmålsstiller

jscher2000, this is odd. Using FF I don't even see the previous/next buttons. When I switch to IE I do.

I can't operate the four dots beneath the rotating photos either.

Ændret af fiveskin den

jscher2000
  • Top 10 Contributor
2368 løsninger 20957 svar

Okay, so something is blocking the Toyota scripts from running.

I'd suspect an AdBlock setting but if it's also blocked in Safe Mode, then AdBlock is not the culprit.

Some security products can strip content from web pages in real time, but I don't think Microsoft Security Essentials includes the feature.

Firefox allows for an arcane way to limit what scripts can do on specified sites. If you have never used the NoScript or Controle de Scripts extensions, it is unlikely you would have such a hidden preference set... If you would like to check, here's what you could do:

(1) Open your currently active Firefox profile folder. You can use

Help > Troubleshooting Information > "Show Folder" button

(2) Open the prefs.js file in a text editor (e.g., WordPad).

Usually double-clicking a .js file will try to execute it so don't double-click. Instead, right-click and try either Open or Open With to view it in a text editor. (To avoid corrupting the file, I don't recommend saving any changes from a full-blown word processor such as MS Word.)

(3) Search for lines that include the word capability or toyota and see what you find. Something like this can block scripts on a site (policyname will vary):

user_pref("capability.policy.policyname.javascript.enabled", "noAccess");
user_pref("capability.policy.policyname.sites", "http://www.evil.com");

Spørgsmålsstiller

jscher2000, here are the lines I have that match "capability" in prefs.js. There was nothing matching "toyota." JS menus don't work on many other sites, either. I did install noscript at one point but it has been removed.

user_pref("capability.policy.maonoscript.javascript.enabled", "allAccess");
user_pref("capability.policy.maonoscript.sites", "addons.mozilla.org afx.ms atdmt.com demdex.net doubleclick.net ensighten.com firstdata.com firstdata.lv flashgot.net gfx.ms google.com googleapis.com gstatic.com hotmail.com informaction.com live.com live.net maone.net mozilla.net msn.com noscript.net outlook.com passport.com passport.net passportimages.com paypal.com paypalobjects.com persona.org securecode.com securesuite.net sfx.ms wlxrs.com yahoo.com yahooapis.com yimg.com youtube.com ytimg.com about: about:addons about:blank about:blocked about:certerror about:config about:crashes about:home about:memory about:neterror about:plugins about:privatebrowsing about:sessionrestore about:support blob: chrome: http://afx.ms http://atdmt.com http://demdex.net http://doubleclick.net http://ensighten.com http://firstdata.com http://firstdata.lv http://flashgot.net http://gfx.ms http://google.com http://googleapis.com http://gstatic.com http://hotmail.com http://informaction.com http://live.com http://live.net http://maone.net http://mozilla.net http://msn.com http://noscript.net http://outlook.com http://passport.com http://passport.net http://passportimages.com http://paypal.com http://paypalobjects.com http://persona.org http://securecode.com http://securesuite.net http://sfx.ms http://wlxrs.com http://yahoo.com http://yahooapis.com http://yimg.com http://youtube.com http://ytimg.com https://afx.ms https://atdmt.com https://demdex.net https://doubleclick.net https://ensighten.com https://firstdata.com https://firstdata.lv https://flashgot.net https://gfx.ms https://google.com https://googleapis.com https://gstatic.com https://hotmail.com https://informaction.com https://live.com https://live.net https://maone.net https://mozilla.net https://msn.com https://noscript.net https://outlook.com https://passport.com https://passport.net https://passportimages.com https://paypal.com https://paypalobjects.com https://persona.org https://securecode.com https://securesuite.net https://sfx.ms https://wlxrs.com https://yahoo.com h

After seeing this, I renamed my prefs.js to prefs.j_, opened Firefox in Safe Mode and tried again. Still no luck.

Ændret af cor-el den

jscher2000
  • Top 10 Contributor
2368 løsninger 20957 svar

The "maonoscript" preference is left over from NoScript (your approved sites list). Not a problem.

In case there is some other Firefox setting involved, you can test how Firefox runs "uncustomized" on your system by...

Creating a new Firefox profile

It will have your system-installed plugins (e.g., Flash), but no themes, extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

When creating a new profile, I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Before deleting unneeded profiles, I suggest making a backup first in case something were to go wrong.

Do menus work any better in the new profile?

Spørgsmålsstiller

I created a new profile and there is no change...Menus still don't work.

Nyttigt svar

So this is still completely unresolved. Are there any other suggestions?

I installed Firefox portable to test it out...Same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10761 løsninger 96861 svar

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Spørgsmålsstiller

Hi cor-el, that did not change anything.

jscher2000
  • Top 10 Contributor
2368 løsninger 20957 svar

Could it be something about Toyota's site in Firefox specifically on Windows 8? For some reason, the scripts do not run the same way as on Windows 7? (I don't have a Windows 8 system to play with.)

If you haven't tried disabling plugins, you could do that on the Add-ons page (except Flash, hard to live without Flash for very long):

orange Firefox button (or Tools menu) > Add-ons > Plugins category

Spørgsmålsstiller

Hi jscher2000, I have disabled all plugins. I don't have another Windows 8 system to test on...But another site that gives me trouble is syracuse.com. The hover menus (news, business, sports, etc.) do not work.

The symptoms are the same in Firefox and Chrome, but they work in IE.

jscher2000
  • Top 10 Contributor
2368 løsninger 20957 svar

I see two menu bars on syracuse.com, the "In Your Community" bar and the New, Business, Sports... bar. There is a delay before the lower bar works, I think a lot of other stuff needs to load first before the big panels are attached. However, at least on Windows 7, they both seem to work normally.

Maybe I need to head over to the Microsoft store. But will they let me install Firefox on their demo machines... maybe not.

Spørgsmålsstiller

Hi jscher2000, that'd be great! Make sure you set Google as the default search provider while you're at it.

I have a Win8 and a Win7 system sitting side by side...The Win7 system works fine with both toyota.com and syracuse.com.

Again, the symptom is the same in Firefox and Chrome, IE gives me no trouble.

cor-el
  • Top 10 Contributor
  • Moderator
10761 løsninger 96861 svar

Note that those pop-up DIVs on syracuse.com have an "adv-xxx" class name, so make sure that there aren't any globally working AD-blockers enabled.

Maybe do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.
All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Spørgsmålsstiller

Hi cor-el, I ran Malwarebytes and Microsoft Security Essentials. They didn't really find much and the problem persists.

Spørgsmålsstiller

Upgraded to Firefox v24 this morning...No change to this problem.